Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z przypisaniem itemu do klasy


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 3rr0r

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:18
  • Lokalizacja:wloclawek
Offline

Napisano 25.07.2010 22:40

Witam, mam problem z dodaniem itemu do danej klasy.
Chciałbym aby moja nowa klasa "Radek" miała standardowo w sobie AWP snipera, inaczej mówiąc żeby zabijała z AWP każdego na raz.

Klase dodałem pomyślnie, wszystko działa itp.
Czy mógłby ktoś zrobić i/lub powiedzieć jak to się robi, aby przypisac danej klasie dany item?

Plik *.sma w załączniku, z góry wielkie dzięki.

Załączone pliki


Użytkownik 3rr0r edytował ten post 25.07.2010 22:41

  • +
  • -
  • 0

#2 Big Smoke

    Wszechwidzący

  • Użytkownik

Reputacja: 56
Pomocny

  • Postów:286
  • Steam:steam
  • Lokalizacja:Daleko
Offline

Napisano 25.07.2010 22:44

Zobacz czy działa

Załączone pliki


  • +
  • -
  • 0

#3 3rr0r

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:18
  • Lokalizacja:wloclawek
Offline

Napisano 25.07.2010 23:12

No niestety nie zadziałało, jakieś inne rady?
  • +
  • -
  • 0

#4 Big Smoke

    Wszechwidzący

  • Użytkownik

Reputacja: 56
Pomocny

  • Postów:286
  • Steam:steam
  • Lokalizacja:Daleko
Offline

Napisano 26.07.2010 07:38

spróbuje jeszcze to

Załączone pliki


Użytkownik Gamer edytował ten post 26.07.2010 09:26

  • +
  • -
  • 0

#5 3rr0r

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:18
  • Lokalizacja:wloclawek
Offline

Napisano 26.07.2010 09:20

Niestety to też nie działa ;s

26 lipiec 2010 - 21:54:
jest ktoś w stanie jeszcze pomoc?
  • +
  • -
  • 0

#6 Apple()

    Wszechpomocny

  • Użytkownik

Reputacja: 128
Zaawansowany

  • Postów:398
  • Steam:steam
  • Lokalizacja:Długość geo. 22.632246 szerokość 51.221584
Offline

Napisano 27.07.2010 08:39

	if(informacje_przedmiotu_gracza[id][0] == 13)
give_item(id, "weapon_awp");

na
	if(informacje_przedmiotu_gracza[id][0] == 13 && klasa_gracza[id] == Radek)
give_item(id, "weapon_awp");



if(weapon == CSW_AWP && informacje_przedmiotu_gracza[idattacker][0] == 13)
damage=float(health);

na
	if(weapon == CSW_AWP && informacje_przedmiotu_gracza[idattacker][0] == 13 && klasa_gracza[idattacker] == Radek)
damage=float(health);


powinno działać.
  • +
  • -
  • 0

#7 3rr0r

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:18
  • Lokalizacja:wloclawek
Offline

Napisano 27.07.2010 10:22

Kurde blade, podmieniłem i dalej nic, próbowałem zabrać mu broń, oddać, ale nic z tego..
Jednak jest możliwe dodanie tego, bo widziałem na innych forach takie modyfikacje ;s
Pomoże ktoś jeszcze?
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych