Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z psychostats


  • Zamknięty Temat jest zamknięty
17 odpowiedzi w tym temacie

#1 ravziom

    Zaawansowany

  • Użytkownik

Reputacja: 6
Nowy

  • Postów:119
  • GG:
  • Lokalizacja:z domu
Offline

Napisano 16.07.2010 11:12

Witam, mam taki o to problem z psychostatami, w server.cfg ustawienia mam takie

mp_logdetail 3
mp_logecho 1 
mp_logfile 1 
mp_logmessages 1
sv_logbans 1 
sv_logblocks 1 
sv_logrelay 1

Jednak katalog logs w cstrike jest pusty i nie wiem czemu nie zapisuje mi do niego logów? Dodatkowo mam problem jak ustawić log source jeżeli i serwer i psycho staty mam na dedyku?

Pozdrawiam.
  • +
  • -
  • 0

#2 bakaj

    Profesjonalista

  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:152
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 21.07.2010 15:11

A "log on" masz?:) Jesli nie to dopisz... dodatkowo dodam, ze mp_logdetail mam ustawione na 3.

Co do log source to do log patch dajesz :
Log patch : cstrike/logs
Protocol : ftp
I reszte wypelniasz podajac dane do ftp'a

Użytkownik bakaj edytował ten post 21.07.2010 15:21

  • +
  • -
  • 1

#3 Apple()

    Wszechpomocny

  • Użytkownik

Reputacja: 128
Zaawansowany

  • Postów:398
  • Steam:steam
  • Lokalizacja:Długość geo. 22.632246 szerokość 51.221584
Offline

Napisano 21.07.2010 15:14

Może jeszcze wina chmodu? Utwórz sam folder w cstrike/logs i nadaj tam uprawnienia 744
  • +
  • -
  • 1

#4 bakaj

    Profesjonalista

  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:152
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 21.07.2010 15:24

Najlepiej zainstaluj wszystko wg poradnika [Poradnik] Instalacja Psychostats .
Przy okazji dodam, ze do poprawnego dzialania ps potrzebna jest obsluga perla na serwerze.
  • +
  • -
  • 0

#5 ravziom

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 6
Nowy

  • Postów:119
  • GG:
  • Lokalizacja:z domu
Offline

Napisano 22.07.2010 11:51

Ok zaczęło mi generować logi, tylko teraz mam problem z cron'em - zainstalowalem psychostaty na dedyku i sa w katalogu var/www/html/psychostats natomiast stats.pl mam w var/www/ no i jak ustawiam cron'a tak: /var/www/stats.pl to niestety nie działa mi, mimo tego iż w zakładce servers w psychostats już mam połączenie z serwerem ale nie generuje mi statystk.
  • +
  • -
  • 0

#6 bakaj

    Profesjonalista

  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:152
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 22.07.2010 13:17

Tak jak napisalem wyzej, skrypt stats.pl wywolywany jest przez perla. Jezeli Twoj serwer obsluguje perla to sprobuj tak : /var/www/ && /usr/bin/perl ./stats.pl

Użytkownik bakaj edytował ten post 22.07.2010 13:18

  • +
  • -
  • 1

#7 ravziom

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 6
Nowy

  • Postów:119
  • GG:
  • Lokalizacja:z domu
Offline

Napisano 22.07.2010 13:33

jak mogę sprawdzić czy obsługuje pearl? i ewentualnie mogę to jakoś doinstalować?
  • +
  • -
  • 0

#8 bakaj

    Profesjonalista

  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:152
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 22.07.2010 13:41

Ps masz u siebie na dedyku, czy na jakims hostingu?
  • +
  • -
  • 1

#9 ravziom

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 6
Nowy

  • Postów:119
  • GG:
  • Lokalizacja:z domu
Offline

Napisano 22.07.2010 13:45

no właśnie mam swojego dedyka i psycho staty i serwery sa na nim
  • +
  • -
  • 0

#10 bakaj

    Profesjonalista

  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:152
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 22.07.2010 14:00

Hm, nie wiem jak sie sprawdza czy obsluguje ci perla, ale mysle ze raczej go obsluguje. Ustaw sobie Crona, zeby zliczal statystyki co 5 min i ustaw sobie, zeby wysylal maile, a nastepnie kombinuj z poleceniem. Sproboj tak:

cd /var/www/ && /usr/bin/perl ./stats.pl

Albo poprostu odpal ta linijke przez roota:)

Użytkownik bakaj edytował ten post 22.07.2010 14:04

  • +
  • -
  • 0

#11 ravziom

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 6
Nowy

  • Postów:119
  • GG:
  • Lokalizacja:z domu
Offline

Napisano 22.07.2010 14:04

według phpinfo(); cos z perl jest enabled, wstawiłem do crona teraz Twoją ścieżkę i same gwiazdki tymczasowo, żeby co minutę odświeżało dla testu, z tym wysyłaniem logu na maila już czytałem ale nie bardzo mam pomysł gdzie ustawić na jakiego maila ma wysyłać.

Użytkownik ravziom edytował ten post 22.07.2010 14:05

  • +
  • -
  • 0

#12 bakaj

    Profesjonalista

  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:152
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 22.07.2010 14:11

I co dalej nie wyswietla statystyk? Sproboj przez roota odpalic ta linijke
  • +
  • -
  • 0

#13 ravziom

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 6
Nowy

  • Postów:119
  • GG:
  • Lokalizacja:z domu
Offline

Napisano 22.07.2010 14:22

brak statystyk, konsola wyrzuciła to:

PsychoStats failed initialization!
The following modules are required and could not be loaded.
        DBI
        DBD::mysql

You can install the modules listed using either CPAN or if your distro
supports it by installing a binary package with your package manager like
'yum' (fedora / redhat), 'apt-get' or 'aptitude' (debian).

  • +
  • -
  • 0

#14 bakaj

    Profesjonalista

  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:152
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 22.07.2010 14:24

do stats.pl i stats.cfg wpisales dane do bazy sql? jak nie to wpisz, stats.cfg poszukaj, stats.pl na samym dole;)
  • +
  • -
  • 0

#15 ravziom

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 6
Nowy

  • Postów:119
  • GG:
  • Lokalizacja:z domu
Offline

Napisano 22.07.2010 14:25

tak, wpisałem poprawne
  • +
  • -
  • 0

#16 bakaj

    Profesjonalista

  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:152
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 22.07.2010 14:37

Musisz zainstalowac sterowniki modułu DBD::mysql ---> http://portal.suse.p...a_modułów_perla

TU znalazlem szerszy poradnik:)

Użytkownik bakaj edytował ten post 22.07.2010 14:42

  • +
  • -
  • 1

#17 ravziom

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 6
Nowy

  • Postów:119
  • GG:
  • Lokalizacja:z domu
Offline

Napisano 22.07.2010 17:28

pokombinowałem i już ogarnałem dzięki za pomoc ;)
  • +
  • -
  • 0

#18 bakaj

    Profesjonalista

  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:152
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 22.07.2010 21:23

Nmzc:)
  • +
  • -
  • 1




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych