Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Diablo mod instalacjaproblemik na szybko.


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 kajt

    Życzliwy

  • Użytkownik

Reputacja: 17
Początkujący

  • Postów:27
  • GG:
  • Lokalizacja:Wrocław
Offline

Napisano 08.07.2010 13:46

A więc planuję zrobić modyfikację diablo moda. Znalazłem kompilującą się ładną wersję, więc zaczynam od instalacji na localhoscie. Tu pojawia się mały problem z którym już chwilę walczę.

Otóż co robię:
1. Instalacja amx pomyslnie :)
2. dbmod_5.9l.amxx do cs-serwer\cstrike\addons\amxmodx\plugins (a Plik dbmod_5.9l.sma do addons/amxmodx/scripting ale to mało istotne)
3. Baza danych gotowa na webd.pl
4. Modele wrzucone
5. dbmod_5.9l.amxx dopisane do amxmodx/configs/plugins.ini
6. Do amxx.cfg dopisane cvary podane poniżej
7. Coś jeszcze? Bo pojawia się problem ...

Cvary
//------------------ DIABLO ----------------------------
diablo_sql_host "192.168.1.102"
diablo_sql_user "kajtsweb_cs"
diablo_sql_pass "tu haslo"
diablo_sql_database "kajtsweb_lod"
diablo_sql_table "dbmod_tablet"
diablo_sql_save "0"
;0
;1
;2

diablo_classes "abcdefgh"
; a Mag
; b Paladyn
; c Mnich
; d Zabojca
; e Barbarzynca
; f Nekromanta
; g Ninja
; h Hunter

diablo_avg "1"
;0-off
;0> (1,2,3...) od jakiego lvl'a zlicza srednia (im mniejsza liczba tym bedzie ona gorsza)

diablo_xpbonus "10"
diablo_xpbonus2 "100"
diablo_durability "10"
SaveXP "1"
diablo_dir "addons/amxmodx/diablo/"
diablo_show_health "1"
diablo_knife "20"
diablo_knife_speed "1000"
diablo_arrow "120"
diablo_arrow_multi "2.0"
diablo_arrow_speed "1500"
diablo_klass_delay "2.5"



/menu się nie wyświetla, co jest oczywistym, że ma to związek z /klasa

W logach dostaje cos takiego:
L 07/08/2010 - 14:30:47: [AMXX] Plugin "dbmod_5.9l.amxx" failed to load: Module/Library "cstrike" required for plugin.  Check modules.ini.

Modules.ini:
;;;
; To enable a module, remove the semi-colon (;) in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time.  Use      ;;
;;  amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

mysql
sqlite

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here.              ;;
;; You can just list their names, without the _amxx ;;
;;  or file extension.                              ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; These modules will be auto-detected and loaded   ;;
;;  as needed.  You do not need to enable them here ;;
;;  unless you have problems.                       ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

;fun
;engine
;fakemeta
;geoip
;sockets
;regex
;nvault
;hamsandwich


Właściwie nigdy mi się nie zdarzyło łączyć do bazy danych przez csa. Gdy próbuję połączyć się przez sql.cfg (admin.sma) serwer przed startem chwile przymula po czym startuje i już jest ok. Podłączanie diablo przez amxx.cfg nie daje takich efektów, właściwie nie daje wcale efektów.

Proszę więc was o pomoc i z góry dziękuję :) rozdaje plusiki :D
  • +
  • -
  • 0

Lord Of Destruction Mod 100%

TES Mod 100%
New Lord Of Destruction Mod 100%

 

www.cs-lod.com.pl


#2 WarninG.

    Profesjonalista

  • Zbanowany

Reputacja: 11
Początkujący

  • Postów:203
  • GG:
  • Lokalizacja:Polska
Offline

Napisano 08.07.2010 13:57

PRZECIEŻ TO DAJE SIĘ DO SQL.CFG ....

diablo_sql_host "192.168.1.102"
diablo_sql_user "kajtsweb_cs"
diablo_sql_pass "tu haslo"
diablo_sql_database "kajtsweb_lod"
diablo_sql_table "dbmod_tablet"
diablo_sql_save "0"

#3 ZiuTeK

    Wszechwiedzący

  • Użytkownik

Reputacja: 133
Zaawansowany

  • Postów:507
  • Lokalizacja:inąd
Offline

Napisano 08.07.2010 15:41

Przeciez logi wyraznie pokazuja czego brakuje
Prawdopodobnie przy instalacji amxa nie wgrales dodatku do cstrike ktory zawiera 2 dodatkowe moduly
cstrike i csx
Jakbys go wgral to w pliku modules.ini powinny znalezc sie te 2 wpisy
cstrike
csx
Jesli masz juz je wgrane a jakims cudem nie dopisaly sie do modules.ini to wystarczy ze je dopiszesz tyko bez tego ";" na poczatku.
  • +
  • -
  • 1

#4 patryk1345

    Profesjonalista

  • Użytkownik

Reputacja: 62
Pomocny

  • Postów:156
  • Lokalizacja:Przemyśl
Offline

Napisano 08.07.2010 15:52

wgraj Counter Strike 1.6 addon i powinno byc ok
  • +
  • -
  • 0

#5 WarninG.

    Profesjonalista

  • Zbanowany

Reputacja: 11
Początkujący

  • Postów:203
  • GG:
  • Lokalizacja:Polska
Offline

Napisano 08.07.2010 16:05

Wgraj najlepiej amxx 1.8.1 bo może masz jakiś stary

#6 Change

    Super Hero

  • Użytkownik

Reputacja: 129
Zaawansowany

  • Postów:1161
  • Lokalizacja:Konin
Offline

Napisano 08.07.2010 16:19

Jak już nowy to wrzucaj 1.8.2 ^^
  • +
  • -
  • 0

#7 kajt

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 17
Początkujący

  • Postów:27
  • GG:
  • Lokalizacja:Wrocław
Offline

Napisano 08.07.2010 16:24

Amxx mam 1.8.1, za to mam ruskiego CS'a. Problem rozwiązany poprzez ręczne wpakowanie 4 plików, widzi moda, menu działa. Plusik dla Ziutka, ale jako, że klasa nie działa później będę dalej drążył temat.
  • +
  • -
  • 0

Lord Of Destruction Mod 100%

TES Mod 100%
New Lord Of Destruction Mod 100%

 

www.cs-lod.com.pl





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych