Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Serwer pada - brak logów.


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 Batonik

    Wszechpomocny

  • Użytkownik

Reputacja: 27
Życzliwy

  • Postów:372
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnobrzeg
Offline

Napisano 28.06.2010 12:40

Witam, otóż mam VPS z firmy logout.pl i następujący problem, serwer działa normalnie do czasu aż nie padnie, wchodzę w screen, mogę normalnie pisać żadnych logów lub coś ze serwer padł, ale nie można na niego wbić ani co. W logach nic nie ma i nie wiem co zrobić by zwiększyć jego uptime co może być tego przyczyną?
  • +
  • -
  • 0

#2 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 28.06.2010 12:51

Brak zasobów i serwer zwyczajnie się zawiesza? Rób reboota raz na 24h - crontab + automatyczne odpalanie serwera w rd.local i będzie okej.
  • +
  • -
  • 1

Dołączona grafika
IP: ts3.cserwerek.pl


#3 Batonik

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 27
Życzliwy

  • Postów:372
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnobrzeg
Offline

Napisano 28.06.2010 13:37

Aha czyli mam ustawić crontaba by restartował serwer i w rd.local ustawić przy crashu VPS-a zeby automatycznie stawiał serwer tak?

A powiedziałbyś mi jakiego skryptu użyć crontaba już spróbuje sam ustawić.

//edit

Czym może być spowodowany brak zasobów i jak to naprawic ?

Użytkownik Batonik edytował ten post 28.06.2010 13:39

  • +
  • -
  • 0

#4 ...

    Wszechmogący

  • Zbanowany

Reputacja: 166
Profesjonalista

  • Postów:612
  • Lokalizacja:Jasło
Offline

Napisano 28.06.2010 13:48

dodać ram/procesor...

28 czerwiec 2010 - 14:48:
ew. zmniejszyć obciążenie na serwerze (przykładowo usunąć zbędne pluginy z serwerów)

#5 Batonik

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 27
Życzliwy

  • Postów:372
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnobrzeg
Offline

Napisano 28.06.2010 16:51

@Kyku,
pamięc ram serwera zajmuje 11,7% a procek nie wiem czy nawet dochodzi do 2 %.

//edit

serwer bez amxx także się wiesze więc nie jest to wina słabego sprzętu bo powinien to urzymać.

Użytkownik Batonik edytował ten post 28.06.2010 16:58

  • +
  • -
  • 0

#6 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 28.06.2010 20:28

OpenVZ? Tak przeważnie przy niezamulonej maszynie widział będziesz właśnie to o czym piszesz :) Wirtualizacja niezbyt trafna jeśli chodzi o HL1, serwery mają to do siebie że zjadają pamięć RAM której potem nie oddają więc co za tym idą jedzą sporo zasobów na dłuższą metę. Do crona skrypt powiadasz?:

05 4 * * * /sbin/reboot

O 4:05 na serwerze chyba nikogo nie będzie? ;] Jeśli chodzi o odpalanie, nano/vi/mcedit /etc/rc.local, przed exit 0 wklepujesz sh /root/hlds_start, w katalogu ~ (root) tworzysz plik hlds_start a w nim coś takiego:

#!/bin/bash
# Serwer s1
cd /katalog/z/serwere/s1
screen -A -m -d -S servS1 ./hlds_run +ip 192.168.1.1 +port 27015 +map de_dust +exec server.cfg

# Serwer s2
cd /katalog/z/serwere/s2
screen -A -m -d -S servS2  ./hlds_run +ip 192.168.1.1 +port 27016 +map de_dust +exec server.cfg

itd.
  • +
  • -
  • 1

Dołączona grafika
IP: ts3.cserwerek.pl


#7 Batonik

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 27
Życzliwy

  • Postów:372
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnobrzeg
Offline

Napisano 29.06.2010 16:42

Ok, dzięki. Przy okazji wgrałem pliki serwerowe z firmy hostingowej, bo nie którym brakowało trochę kb i myślę, że przez to serwer crashował, ale jeszcze zobaczymy.

//edit

Hmm pomożecie co robię nie tak: w root/
hlds_start ( bez rozszerzenia ) a w nim:

#!/bin/bash
# Serwer s1
cd /home/serwery/ffa
screen -dmS FFA ./hlds_run -game cstrike +port 27016 +maxplayers 11 +exec server.cfg +map de_dust2

w /etc/rc.local
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
sh /root/hlds_start 
exit 0

serwer mam w katalogu:

home/serwery/ffa

29 czerwiec 2010 - 17:42:
Da radę wrzucić:
cd /home/serwery/ffa
screen -dmS FFA ./hlds_run -game cstrike +port 27016 +maxplayers 11 +exec server.cfg +map de_dust2
do rc.local by od razu odpalał a nie czytał?

Użytkownik Batonik edytował ten post 28.06.2010 21:55

  • +
  • -
  • 0

#8 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 29.06.2010 18:31

Da radę wrzucić:

cd /home/serwery/ffa
screen -dmS FFA ./hlds_run -game cstrike +port 27016 +maxplayers 11 +exec server.cfg +map de_dust2
do rc.local by od razu odpalał a nie czytał?


Jasne, napisałem tak dlatego że przy większej ilości serwerów tak jest po prostu wygodniej, dlaczego nie działa? Pewnie zabrakło komendy chmod +x hlds_start :)
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#9 Batonik

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 27
Życzliwy

  • Postów:372
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnobrzeg
Offline

Napisano 29.06.2010 20:55

Bardzo dziwne, nie odpala pliku rc.local inaczej odpalił by serwer.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych