Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z /klasa Nie ma Klasy :(


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 cooll vip

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:11
  • Lokalizacja:Bolków
Offline

Napisano 25.06.2010 19:34

Witam ma problem z klasami nie chcą sie włączać:
Oto moje sql.cfg:


// SQL configuration file
// File location: $moddir/addons/amxmodx/configs/sql.cfg

// *NOTE* Linux users may encounter problems if they specify "localhost" instead of "127.0.0.1"
// We recommend using your server IP address instead of its name

// *NOTE* amx_sql_type specifies the DEFAULT database type which admin.sma will use.

amx_sql_host "127.0.0.1"
amx_sql_user "root"
amx_sql_pass ""
amx_sql_db "amx"
amx_sql_table "admins"
amx_sql_type "mysql"

diablo_sql_host "dawcy-bani.zxy.me"
diablo_sql_user "dawcyban_cooll"
diablo_sql_pass "^^^^^^"
diablo_sql_database "dawcyban_diablomod"
diablo_sql_table "diablomod"
diablo_sql_save "0"
;0
;1
;2

A to logi:

L 06/25/2010 - 20:13:35: 06/25/2010 - 20:13:35 ### MAPA: cs_siege ###
L 06/25/2010 - 20:24:25: 06/25/2010 - 20:24:25 ### MAPA: de_dust2 ###
L 06/25/2010 - 20:28:53: Error on Table query: Access denied for user 'dawcyban_cooll'@'IP TU JEST' (using password: YES)
L 06/25/2010 - 20:28:53: Could not connect to SQL database.
L 06/25/2010 - 20:28:57: Error on Table query: Access denied for user 'dawcyban_cooll'@'IP TU JEST' (using password: YES)

Użytkownik cooll vip edytował ten post 25.06.2010 19:34

  • +
  • -
  • 0

#2 Juma

    Wszechpomocny

  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:373
  • GG:
  • Steam:steam
  • Imię:Arek
  • Lokalizacja:Haynau
Offline

Napisano 25.06.2010 20:46

"
diablo_sql_host "dawcy-bani.zxy.me"
diablo_sql_user "dawcyban_cooll"
diablo_sql_pass "^^^^^^"
diablo_sql_database "dawcyban_diablomod"
diablo_sql_table "diablomod"
diablo_sql_save "0"
;0
;1
;2
"

to nie ma być w sql.cfg tylko w amxx.cfg


A po drugie zezwoliłeś na połączenie zewnętrzne z bazy ?
  • +
  • -
  • 0

#3 cooll vip

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:11
  • Lokalizacja:Bolków
Offline

Napisano 25.06.2010 21:21

To było też już w amx.cfg i też to samo było a to zezwolenie dałem w cpanel dla IP serwera mojego tak i jak dalej?????
  • +
  • -
  • 0

#4 Juma

    Wszechpomocny

  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:373
  • GG:
  • Steam:steam
  • Imię:Arek
  • Lokalizacja:Haynau
Offline

Napisano 25.06.2010 21:49

tego dinksa dodałeś % ? To wildcard jest. Teraz wynajdź po dodaniu tego IP serwera na którym stoi hosting w cPanelu powinno gdzieś tam być, i jako diablo_sql_hostdasz zamiast tego co masz IP serwera ewent. maszyny i powinno śmigać ;)

Co masz za hosting ?

Użytkownik Juma edytował ten post 25.06.2010 21:50

  • +
  • -
  • 0

#5 cooll vip

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:11
  • Lokalizacja:Bolków
Offline

Napisano 25.06.2010 22:10

Mam hosting z głowanet jakoś tak mógłyś mi uzupełnić i gdzie to w końcu wkleić. Tam Aresa IP bazy danych jest :
94.23.230.207
  • +
  • -
  • 0

#6 Juma

    Wszechpomocny

  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:373
  • GG:
  • Steam:steam
  • Imię:Arek
  • Lokalizacja:Haynau
Offline

Napisano 26.06.2010 08:33

zamiast: diablo_sql_host "costamcostamiijeszczecostam"

daj: diablo_sql_host "94.23.230.207"


I powinno działać ;) Aaaa i pamiętaj nie do sql.cfg tylko do amxx.cfg
  • +
  • -
  • 0

#7 cooll vip

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:11
  • Lokalizacja:Bolków
Offline

Napisano 26.06.2010 15:24

Masz to mam w amxx.xfg i dalej nie działa logi te same:

//
// Default value: 12.0
amx_statsx_duration 12.0

// HUD-statistics display limit relative round freeze end
// Negative time will clear the HUD-statstics before the round freeze time has ended
//
// Default value: -2.0
amx_statsx_freeze -2.0

diablo_sql_host "94.23.230.207"
diablo_sql_user "dawcyban_cooll"
diablo_sql_pass ":::::::"
diablo_sql_database "dawcyban_diablomod"
diablo_sql_table "diablomod"
diablo_sql_save "0"

A te "" mają byc czy nie

Użytkownik cooll vip edytował ten post 26.06.2010 15:32

  • +
  • -
  • 0

#8 Juma

    Wszechpomocny

  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:373
  • GG:
  • Steam:steam
  • Imię:Arek
  • Lokalizacja:Haynau
Offline

Napisano 26.06.2010 20:26

Skoro nie działa to musiałeś podać albo złe dane, albo nie zezwoliłeś na połączenie z zewnątrz. I tyle.
  • +
  • -
  • 0

#9 Ojciec Dyrektor

    papa smerf.

  • Przyjaciel

Reputacja: 476
Wszechobecny

  • Postów:3035
  • Imię:Paweł
  • Lokalizacja:Rabka-Zdrój
Offline

Napisano 26.06.2010 21:45

sql.cfg źle skonfigurowane to po pierwsze (brakuje troche)
po drugie sprawdź czy masz odblokowane moduły?
po trzecie jak dopuściłeś w cpanelu?

// Juma i proszę nie wypowiadaj się jak czegoś nie wiesz bo

diablo_sql_host "dawcy-bani.zxy.me"
diablo_sql_user "dawcyban_cooll"
diablo_sql_pass "^^"
diablo_sql_database "dawcyban_diablomod"
diablo_sql_table "diablomod"
diablo_sql_save "0"
;0
;1
;2

to ma być w sql.cfg

Użytkownik Ojciec Dyrektor edytował ten post 27.06.2010 22:13

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych