Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

CoD - nowe klasy - problem+ za pomoc :)


  • Zamknięty Temat jest zamknięty
10 odpowiedzi w tym temacie

#1 Milek

    Powracam..

  • Power User

Reputacja: 96
Zaawansowany

  • Postów:528
  • GG:
  • Steam:steam
  • Lokalizacja:Anglia
Offline

Napisano 13.06.2010 15:15

Siemka.

Mam problem z przekomplikowaniem Sma CoD.

Dodalem nowe klasy i cos nie smiga ;/

proszę o pomoc i o poprawienie bledow.

z gory dziekuje :)

Błedy

Welcome to the AMX Mod X 1.8.1-300 Compiler.
Copyright © 1997-2006 ITB CompuPhase, AMX Mod X Team

QTMCodMod.sma(156) : error 001: expected token: "}", but found "-string-"
QTMCodMod.sma(161) : error 054: unmatched closing brace
QTMCodMod.sma(161) : error 010: invalid function or declaration
QTMCodMod.sma(179) : error 001: expected token: "}", but found "-string-"
QTMCodMod.sma(183) : error 010: invalid function or declaration
QTMCodMod.sma(476) : error 029: invalid expression, assumed zero
QTMCodMod.sma(477) : warning 215: expression has no effect
QTMCodMod.sma(480) : warning 209: function "Odrodzenie" should return a value
QTMCodMod.sma(481) : error 010: invalid function or declaration
QTMCodMod.sma(487) : error 010: invalid function or declaration
QTMCodMod.sma(495) : error 010: invalid function or declaration
QTMCodMod.sma(497) : warning 218: old style prototypes used with optional semicolumns
QTMCodMod.sma(498) : error 010: invalid function or declaration
QTMCodMod.sma(501) : error 010: invalid function or declaration
QTMCodMod.sma(502) : warning 218: old style prototypes used with optional semicolumns
QTMCodMod.sma(504) : error 010: invalid function or declaration
QTMCodMod.sma(507) : error 010: invalid function or declaration
QTMCodMod.sma(508) : warning 218: old style prototypes used with optional semicolumns
QTMCodMod.sma(510) : error 010: invalid function or declaration
QTMCodMod.sma(512) : error 010: invalid function or declaration
QTMCodMod.sma(515) : error 010: invalid function or declaration
QTMCodMod.sma(518) : error 010: invalid function or declaration
QTMCodMod.sma(521) : error 010: invalid function or declaration
QTMCodMod.sma(526) : error 021: symbol already defined: "get_user_weapons"
QTMCodMod.sma(527) : error 010: invalid function or declaration
QTMCodMod.sma(528) : error 010: invalid function or declaration
QTMCodMod.sma(529) : error 010: invalid function or declaration
QTMCodMod.sma(532) : error 010: invalid function or declaration
QTMCodMod.sma(536) : error 010: invalid function or declaration
QTMCodMod.sma(542) : error 010: invalid function or declaration
QTMCodMod.sma(548) : error 021: symbol already defined: "set_user_armor"

Compilation aborted.
26 Errors.
Done.


13 czerwiec 2010 - 15:15:
@ refresz ...

Sorry ale potrzebuje tego jak najszybciej :)

Załączone pliki


Użytkownik Milek edytował ten post 12.06.2010 20:12

  • +
  • -
  • 0

#2 SSB

    Pomocny

  • Użytkownik

Reputacja: 17
Początkujący

  • Postów:56
  • Lokalizacja:to jest? :|
Offline

Napisano 13.06.2010 23:11

Po 1.

new const nazwy_klas[][] = {"Brak",
"Snajper",
"Komandos",
"Strzelec wyborowy",
"Obronca",
"Medyk",
"Wsparcie ogniowe",
"Saper",
"Demolitions",
"Rusher",
"Rambo",
"Nocny Jastrzab",
"Partyzant",
"Zolnierz",
"SWAT",
"Kamikadze"
"Szturmowiec",
"Grenadier",
"Lacznik",
"Piechociarz"

};


	"Kamikadze"

A przecinek zjadło się widzę?

Tak samo troszkę niżej
	"Dostaje auto-kampy, flesha i HE, 60 hp bazowe; 70% biegu, 125 pancerza"


Linia 475

case Grenadier:
}
give_item(id, "weapon_m4a1");
give_item(id, "weapon_elite");
give_item(id, "weapon_hegrenade");
}

Zamykasz i zamykasz... WTF?
Zamien na

case Grenadier:
{
give_item(id, "weapon_m4a1");
give_item(id, "weapon_elite");
give_item(id, "weapon_hegrenade");
}

Reszty błędo wtedy nie powinno być
  • +
  • -
  • 1

#3 Milek

    Powracam..

  • Autor tematu
  • Power User

Reputacja: 96
Zaawansowany

  • Postów:528
  • GG:
  • Steam:steam
  • Lokalizacja:Anglia
Offline

Napisano 14.06.2010 00:07

dzięki wielkie :)

Byly jeszcze 2 bledy :P
ale juz sie uporalem xD

+ dla Ciebie :)

Mozna Zamknac :)

@edit


Wgralem i zmienilem na inna mapke i crasz.

Za kazdym razem kiedy wlacze serwer.

wicinek z Consoli

stray key in process_key: item_getiteminfo 63
[DPROTO]: Version 0.4.8 Linux
[DPROTO]: Loading config './dproto.cfg'
[DPROTO]: LoggingMode = 2
[DPROTO]: Config sucessfully loaded.
[DPROTO]: Done.
scandir failed:/home/servers/s3790/./platform/SAVE
L 06/14/2010 - 01:34:33: -------- Mapchange to de_dust2 --------
L 06/14/2010 - 01:34:33: [AMXX] Failed to initialize plugin (24) (plugin "QTM_CodMod.amxx")
./hlds_run: line 321: 31253 Segmentation fault (core dumped) $HL_CMD
./hlds_run: line 207: gdb: command not found
email debug.log to linux@valvesoftware.com
Mon Jun 14 01:34:33 CEST 2010: Server restart in 10 seconds


Moze ktos pomoc ?

Użytkownik Milek edytował ten post 14.06.2010 00:36

  • +
  • -
  • 0

#4 fsd

    Pomocny

  • Użytkownik

Reputacja: 7
Nowy

  • Postów:54
  • Lokalizacja:Toruń
Offline

Napisano 14.06.2010 13:10

Dokładnie się nie znam lecz podaj:
Aktualny plik .sma
Skopiuj zawartość plugins.ini
Jaki hosting i wersja AMXX
  • +
  • -
  • 0

#5 AmD

    aemde

  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 14.06.2010 13:13

daj error logi z .../logs
  • +
  • -
  • 0

#6 SSB

    Pomocny

  • Użytkownik

Reputacja: 17
Początkujący

  • Postów:56
  • Lokalizacja:to jest? :|
Offline

Napisano 14.06.2010 16:14

Otwórz plik plugins.ini

Jak masz napisane
QTM_CodMod.amxx
(czy jakoś tak), to zrób żeby to było tak
QTM_CodMod.amxx debug
I wtedy daj logi
  • +
  • -
  • 0

#7 Milek

    Powracam..

  • Autor tematu
  • Power User

Reputacja: 96
Zaawansowany

  • Postów:528
  • GG:
  • Steam:steam
  • Lokalizacja:Anglia
Offline

Napisano 14.06.2010 17:37

dzięki :) jednak przepisalem go nanowo :) i pomoglo :D a jeszcze 1 pytanko mam :D bo wgralem nowe klasy i one nie amja magazynak ;/ jak to zrobic ?
  • +
  • -
  • 0

#8 AmD

    aemde

  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 15.06.2010 13:39

Dokumentacja AMXX.pl - Nieoficjalny polski support AMX Mod X
  • +
  • -
  • 0

#9 Milek

    Powracam..

  • Autor tematu
  • Power User

Reputacja: 96
Zaawansowany

  • Postów:528
  • GG:
  • Steam:steam
  • Lokalizacja:Anglia
Offline

Napisano 15.06.2010 13:45

dzięki juz sie oradzilem z ALL :)
  • +
  • -
  • 0

#10 Szaiba

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:45
  • Lokalizacja:Poznań
Offline

Napisano 15.06.2010 16:00

Witam. Mam taki problem, a mianowicie zrobilem 3 nowe klasy w tym jedna premium. 2 Klasy bez premium dzialaja prawidlowo, natomiast klasa Premium cos nie trybi. Co przez to mozna rozumiec?
1. Klasie Premium nie wyskakuje po awansowaniu na lvl okno do rozdawania punktow,
2. Dalem Klasie Premium M4A1, Elity. Niestety tylko M4A1 sie wyswietla ale ma tylko 30 naboi w magazynku.
3. Dalem jej rowniez widocznosc zredukowana do 30.. Nie Dziala.
4. Tak samo jest z HP [ 120 dostala] a ma 100, [ pancerza 100] a ma 0....
Klasa premium nazywa sie Pulkownik,


## Kolejny problem jest taki, ze mam na serwerze max lvl 4001, lecz od poziomu 1001 exp rosnie lecz lvl nie -.-''. Przyklad: 21000/20000, lecz ani stat ani lvl up.

Wszystkie inne klasy dzialaja nowe tylko nie ta premium.

proszę o pomoc.


Chcialbym sie rowniez dowiedziec jak zrobic komandosowi zeby mial 1/3 z noza a nie 1/1...
  • +
  • -
  • 0

#11 Milek

    Powracam..

  • Autor tematu
  • Power User

Reputacja: 96
Zaawansowany

  • Postów:528
  • GG:
  • Steam:steam
  • Lokalizacja:Anglia
Offline

Napisano 15.06.2010 17:15

Masz juz taki temat to po co spamujesz w moim ?

Moje juz wyjasnione :)

Mozna Zamknac :)
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych