Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

HLDS a AMD


  • Zamknięty Temat jest zamknięty
Brak odpowiedzi do tego tematu

#1 Gutaj

    I Can Fly

  • Power User

Reputacja: 157
Profesjonalista

  • Postów:667
  • GG:
  • Steam:steam
  • Imię:Patrick
  • Lokalizacja:Warszawa
Offline

Napisano 03.06.2010 16:53

Witam,
posiadam serwer dedykowany z procesorem AMD Athlon II X2 245, na którym trzymam serwery Counter Strike'a 1.6. Wszystko opiera się na Debianie Lennym. Mamy problem z HLDS pod względem crashów i zawieszania się. O ile jednorazowe crashe co około 24 godziny mogliśmy przeżyć, o tyle ostatnie wieszanie się HLDS co 20 minut jest uciążliwe i nieprzyjemne. Wiesza się na jakieś 5 minut przed mapą, a po tych 5 minutach mapa się zmienia, jak gdyby nigdy nic. Wyczytałem w Internecie, że HLDS niezbyt się lubi z AMDkami. Czy to może być przyczyną tych problemów?
Dodam, że próbowałem na binarkach i686 i amd, na obydwu to samo, a nawet na tych od amd serwer zawiesza się wcześniej. Wczoraj odpaliłem HLDS i AMXX w trybie debugowania oraz wyłączeniu rejestrowania się w master serwerach i czas przyblokowania zmienił się z jakichś 5 minut do 20 sekund, co na szczęście nie powoduje zerwania połączenia z graczami i gra może być kontynuowana. Aktualizowałem HLDS przez Steam'a i ciągle to samo. Jądro Linuksa posiadam standardowe. Problemy zaczęły się same z siebie. Już wcześniej mieliśmy taki problem, ale trwał on kilka godzin i sam się naprawił, a teraz trwa 3 dni, ciągle to samo, użytkownicy się irytują i odchodzą, a my nie możemy się uporać z problemem. Może zamiana dedyka na coś z Intelem pomoże?
W syslogu nie ma żadnych błędów, ani w żadnym innym - sprawdziłem to od razu. Jedynie przy crashach wywala się na linijce z deklaracją funkcji run() w hlds_run, ale wątpię, aby to się wiązało z samym wieszaniem się.W konsoli zero, nie reaguje na stdin(wejście), po prostu się wiesza. Wszystkie pluginy AMXX też się wieszają.
Mam dproto, w wersji najnowszej, i386.

Z góry dziękuję,
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych