Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

play welcome message


  • Zamknięty Temat jest zamknięty
12 odpowiedzi w tym temacie

#1 Duffnexter

    Profesjonalista

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:191
  • Lokalizacja:Oak Forest
Offline

Napisano 23.05.2010 16:12

szukam pluginu dzięki ktoremu będę mógł ustawic sobie welcome muzyke kazdy gracz ktory wchodzi na server bedzie ja slyszal na poczatku pomysl powstal na przykladzie HEV suit emulation - AlliedModders ten plugin gra dla gracza ktory wchodzi na server welcome message o cos takiego mi chodzi tylko za wav bedzie zrobiona przezemnie.
  • +
  • -
  • 0

#2 Harsay

    Harsayus pospolitus

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:274
  • Imię:Michał
  • Lokalizacja:Bydgoszcz
Offline

Napisano 23.05.2010 16:19

public client_putinserver(id){
client_cmd(id,"spk lokalizacjapliku",sound)
}

Proszę bardzo.

@edit
Cały plugin.
#include <amxmodx>
#include <amxmisc>

#define PLUGIN "Welcome Sound"
#define VERSION "1.0"
#define AUTHOR "Harsay"


public plugin_init() {
	register_plugin(PLUGIN, VERSION, AUTHOR)
		
}

public client_putinserver(id){
	client_cmd(id,"spk misc/x.wav",sound)
}

misc/x.wav <- Jest to lokalizacja dzwięku

Użytkownik Harsay edytował ten post 23.05.2010 16:21

  • +
  • -
  • 0

#3 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 23.05.2010 16:19

łapaj :http://amxx.pl/loading-music-t6618.html

#4 Harsay

    Harsayus pospolitus

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:274
  • Imię:Michał
  • Lokalizacja:Bydgoszcz
Offline

Napisano 23.05.2010 16:27

Hardbot, nie chodziło mu o włączanie muzyki podczas loadingu tylko wtedy gdy już widzi mapę.
  • +
  • -
  • 0

#5 Duffnexter

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:191
  • Lokalizacja:Oak Forest
Offline

Napisano 23.05.2010 17:28

ok czyli musze sobie zrobic wav i wstawic go do sounds/misc czy musi byc jakas specjalna nazwa tego wav?

23 maj 2010 - 18:30:
jest 1 error w tym kodzie client_cmd(id,"spk misc/x.wav",sound) niemoge przez niego zrobic amx
  • +
  • -
  • 0

#6 Harsay

    Harsayus pospolitus

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:274
  • Imię:Michał
  • Lokalizacja:Bydgoszcz
Offline

Napisano 23.05.2010 17:54

Napisz jaki jest ten błąd ale chyba chodzi o to:

zamiast:
client_cmd(id,"spk misc/x.wav",sound)

client_cmd(id, "spk misc/x.wav", sound)
Chyba trzeba użyć spacji.

Jak to nie pomoże:
client_cmd(id, "spk misc/x.wav")

Dawno tego nie używałem więc nie daje 100% pewności że zadziała.
  • +
  • -
  • 0

#7 Duffnexter

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:191
  • Lokalizacja:Oak Forest
Offline

Napisano 23.05.2010 18:52

client_cmd(id, "spk misc/x.wav")
jak dam to to zrobie amxx ale on niedziala dalem x.wav do sounds i tez do sounds/misc i niedziala
  • +
  • -
  • 0

#8 Harsay

    Harsayus pospolitus

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:274
  • Imię:Michał
  • Lokalizacja:Bydgoszcz
Offline

Napisano 23.05.2010 18:54

a zrobiłeś dobry format pliku .wav?
tzn. kb/s itp.
  • +
  • -
  • 0

#9 Duffnexter

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:191
  • Lokalizacja:Oak Forest
Offline

Napisano 23.05.2010 18:59

wziąłem inny wav ktory byl w jednych z pluginów na probe i nazwalem go x.wav wiec musi dzialac
  • +
  • -
  • 0

#10 Harsay

    Harsayus pospolitus

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:274
  • Imię:Michał
  • Lokalizacja:Bydgoszcz
Offline

Napisano 23.05.2010 19:25

Akurat gdy plik się kopiuje to się może "zwalić" (xD) użyj tego pliku.

mod_godlike.wav
  • +
  • -
  • 0

#11 Duffnexter

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:191
  • Lokalizacja:Oak Forest
Offline

Napisano 23.05.2010 19:37

niedziala
  • +
  • -
  • 0

#12 hardbot

    Banned

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:3049
Offline

Napisano 23.05.2010 20:01

Łapaj to musi działać ;] 2 wersie w mp3 i wav

mp3

#include <amxmodx>
#include <amxmisc>

#define PLUGIN "Witaj"
#define VERSION "1.0"
#define AUTHOR "[H]ARDBO[T]"

public plugin_init()
register_plugin(PLUGIN, VERSION, AUTHOR)

public client_putinserver(id)
{
client_cmd(id, "mp3 play sound/misc/twoj-sound")
}

public plugin_precache()
{
precache_sound("sound/misc/twoj-sound.mp3")
}


wav


#include <amxmodx>
#include <amxmisc>

#define PLUGIN "Witaj"
#define VERSION "1.0"
#define AUTHOR "[H]ARDBO[T]"

public plugin_init()
register_plugin(PLUGIN, VERSION, AUTHOR)

public client_putinserver(id)
{
client_cmd(id, "spk misc/twoj-sound")
}

public plugin_precache()
{
precache_sound("misc/twoj-sound.wav")
}


#13 Duffnexter

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:191
  • Lokalizacja:Oak Forest
Offline

Napisano 24.05.2010 03:22

zaden niedziala a to mam w consoli po dodaniu tego z mp3
Missing RIFF/WAVE chunks
sciaga sound ale nie wlancza sie jak wchodze
co do wav to jest tam blad pisze w consoli ze nie można znależć pliku w sounds/sounds/misc/x.wav wiec zrobilem extra foldery i wszedlo ale nie gra nadal
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych