Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

TAKEDAMAGE


  • Zamknięty Temat jest zamknięty
5 odpowiedzi w tym temacie

#1 Kubaczek <3

    Zaawansowany

  • Użytkownik

Reputacja: 17
Początkujący

  • Postów:116
  • Steam:steam
  • Lokalizacja::)
Offline

Napisano 11.05.2010 19:08

Link do poprzedniego tematu: TakeDamage - Jak używać? - Nieoficjalny polski support AMX Mod X
Mam problem nie wiem jak zarejestrować to jako post a nie pre? Pomoże ktoś?
  • +
  • -
  • 0

#2 Vertricus

    Godlike

  • Przyjaciel

Reputacja: 426
Wszechobecny

  • Postów:1549
  • Lokalizacja:.
Offline

Napisano 11.05.2010 19:37

Jak masz plugin_init i tam rejstruresz ten Forward to zamiast zero daj 1 :> bądź jeśli nie masz nic to dopisz ",1"
Przykłady (ty tak ze swoim zróB):
	register_forward(FM_Touch, 		"fwd_touch", 0)
na:
register_forward(FM_Touch, "fwd_touch", 1)
=================================
register_forward(FM_Touch, "fwd_touch")
na:
register_forward(FM_Touch, "fwd_touch", 1)

Nie sugeruj się typem forwardu oraz callbackiem zrób u siebie tak z twoją funkcją (nie mam kodu dlatego przykład losowy)
  • +
  • -
  • 1

#3 Kubaczek <3

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 17
Początkujący

  • Postów:116
  • Steam:steam
  • Lokalizacja::)
Offline

Napisano 13.05.2010 11:38

Niestety od początku tak miałem:
g_iRegisterSpawn = register_forward( FM_Spawn, "fwdSpawn", 1 );

w plugin_precache
@EDIT Dałem to w plugin_init i działa. Dzięki.
@EDIT2 Jednak teraz enty się nie usuwają :/
@EDIT3 Gdy zmienie na twoją komendę(zmieniajac fwd_touch na fwdSpawn) nadal nie dziala, ale bledow nie ma.
@EDIT4(xD) Jednak działa ale nie usuwa modeli, trzeba wejsc w obiekt aby sie usunal.

Użytkownik kubaku4 edytował ten post 13.05.2010 11:44

  • +
  • -
  • 0

#4 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 13.05.2010 11:48

Możesz powiedzieć co chcesz osiągnąć w tym temacie ?
Bo rejestrację post już masz...
  • +
  • -
  • 0

#5 Kubaczek <3

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 17
Początkujący

  • Postów:116
  • Steam:steam
  • Lokalizacja::)
Offline

Napisano 13.05.2010 11:56

Chcę aby to poprawnie działało jeszcze...
  • +
  • -
  • 0

#6 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 13.05.2010 12:02

Pokaż jaki masz kod
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych