Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Niedziałające pluginy na ZombieMod


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 SzyjaN

    Zaawansowany

  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:131
  • GG:
  • Lokalizacja:Katowice
Offline

Napisano 02.05.2010 14:18

Witam. Mam dość spory problem z moim serwerem ZombieMod. Na serwerze mam wgrane takie pluginy:

;zp_rounddraw_blast.amxx
zp_zclasses40.amxx
zombie_plague40.amxx
zm_vip.amxx
public_rules.amxx
;zp_zclass_regeneration.amxx
;zp_class_flame.amxx
zp_extra_invisible.amxx
zp_extra_candle.amxx
zp_extra_zspawn.amxx
zp_extra_parachute.amxx
showmsg.amxx
zp_unlimited_clip.amxx
zp_extra_speed_boost.amxx
zp_extra_lasermine.amxx
zp_zclass_super_zombie.amxx
zp_extra_3rdview.amxx
zp_extra_human_armor.amxx
zp_extra_parachute.amxx
zp_hostname_modes.amxx
zp_reloaded_player.amxx
zp_extra_low_gravity.amxx
zp_extra_healt.amxx
descriptive_fire_in_the_hole.amxx
GHW_Weapon_Replacement.amxx
;zp_bank.amxx
zp_class_tight10c.amxx
zp_angel_zombie.amxx
parachute.amxx
;zp_bank_sql.amxx
serwer.amxx
simple_redirect.amxx
Admin_chat_colors.amxx
galileo.amxx
powitanie.amxx
amx_gag.amxx
abd.amxx
amx_ssban_reasonmenu.amxx
server.amxx
Reklama.amxx
mutemenu.amxx
poprawne_rate.amxx
zp_no_crosshair.amxx
zp_radio.amxx
zm_vip_extra_flamethrower.amxx
zm_vip_extra_human_armor.amxx
zm_vip_extra_goldendg.amxx
zm_extra_unlimited_clip.amxx
zm_extra_playeraura.amxx 
zm_extra_buy_survnem.amxx

Większość z nich działa bez zarzutu, ale niektóre z nieznanych mi przyczyn nie działają w ogóle. Daję tutaj część logów serwera z błędami tych nie działających:

[AMXX] Run time error 10 (plugin "zm_vip.amxx") (native "ArrayPushArray") - debug not enabled!
L 05/02/2010 - 01:18:18: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 05/02/2010 - 01:18:18: Unhandled dynamic native error
L 05/02/2010 - 01:18:18: [AMXX] Run time error 10 (plugin "zm_vip_extra_goldendg.amxx") (native "zv_register_extra_item") - debug not enabled!
L 05/02/2010 - 01:18:18: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 05/02/2010 - 01:18:18: Invalid array handle provided (0)
L 05/02/2010 - 01:18:18: [AMXX] Run time error 10 (plugin "zm_vip.amxx") (native "ArrayPushArray") - debug not enabled!
L 05/02/2010 - 01:18:18: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 05/02/2010 - 01:18:18: Unhandled dynamic native error
L 05/02/2010 - 01:18:18: [AMXX] Run time error 10 (plugin "zm_extra_unlimited_clip.amxx") (native "zv_register_extra_item") - debug not enabled!
L 05/02/2010 - 01:18:18: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 05/02/2010 - 01:43:39: Start of error session.
L 05/02/2010 - 01:43:39: Info (map "zm_underwater") (file "addons/amxmodx/logs/error_20100502.log")
L 05/02/2010 - 01:43:39: [AMXX] Invalid Plugin (plugin "zp_extra_candle.amxx")
L 05/02/2010 - 01:43:39: [AMXX] Plugin file open error (plugin "showmsg.amxx")
L 05/02/2010 - 01:43:39: [AMXX] Plugin file open error (plugin "zp_unlimited_clip.amxx")
L 05/02/2010 - 01:43:39: [AMXX] Plugin file open error (plugin "Admin_chat_colors.amxx")
L 05/02/2010 - 01:43:39: [AMXX] Plugin file open error (plugin "zp_radio.amxx")
L 05/02/2010 - 01:43:39: Invalid array handle provided (0)
L 05/02/2010 - 01:43:39: [AMXX] Run time error 10 (plugin "zm_vip.amxx") (native "ArrayPushArray") - debug not enabled!
L 05/02/2010 - 01:43:39: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 05/02/2010 - 01:43:39: Unhandled dynamic native error
L 05/02/2010 - 01:43:39: [AMXX] Run time error 10 (plugin "zm_vip_extra_flamethrower.amxx") (native "zv_register_extra_item") - debug not enabled!
L 05/02/2010 - 01:43:39: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 05/02/2010 - 01:43:39: Invalid array handle provided (0)
L 05/02/2010 - 01:43:39: [AMXX] Run time error 10 (plugin "zm_vip.amxx") (native "ArrayPushArray") - debug not enabled!
L 05/02/2010 - 01:43:39: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 05/02/2010 - 01:43:39: Unhandled dynamic native error
L 05/02/2010 - 01:43:39: [AMXX] Run time error 10 (plugin "zm_vip_extra_human_armor.amxx") (native "zv_register_extra_item") - debug not enabled!
L 05/02/2010 - 01:43:39: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

Proszę o jakąś pomoc z tym bo nie mam pojęcia o co może chodzić, jeśli będą potrzebne sma tych pluginów to od razu podam. Najbardziej zależy mi na działaniu poprawnym:
zm_vip_extra_human_armor
zm_vip
zp_radio
zp_unlimited_clip
zm_extra_unlimited_clip
zp_extra_candle
zm_vip_extra_goldendg
  • +
  • -
  • 0

#2 Kusek

    z Wikipedii

  • Power User

Reputacja: 445
Wszechobecny

  • Postów:1655
  • Imię:Krystian
  • Lokalizacja:Nowa Dęba
Offline

Napisano 02.05.2010 14:53

zm_vip.amxx debug ----->tak to powinno wyglądać
zm_extra_unlimited_clip.amxx debug to też tak
zm_vip_extra_goldendg.amxx debug to również
zm_vip_extra_flamethrower.amxx debug to też tak
zm_vip_extra_human_armor.amxx debug to też


L 05/02/2010 - 01:43:39: [AMXX] Invalid Plugin (plugin "zp_extra_candle.amxx")
L 05/02/2010 - 01:43:39: [AMXX] Plugin file open error (plugin "showmsg.amxx")
L 05/02/2010 - 01:43:39: [AMXX] Plugin file open error (plugin "zp_unlimited_clip.amxx")
L 05/02/2010 - 01:43:39: [AMXX] Plugin file open error (plugin "Admin_chat_colors.amxx")
L 05/02/2010 - 01:43:39: [AMXX] Plugin file open error (plugin "zp_radio.amxx")


nie wrzuciłeś od tych pluginów plików prawdopodobnie



najlepiej zapodaj strony skąd pobrałeś te pluginy
zm_vip_extra_human_armor
zm_vip
zp_radio
zp_unlimited_clip
zm_extra_unlimited_clip
zp_extra_candle
zm_vip_extra_goldendg

Użytkownik Frajer edytował ten post 02.05.2010 14:53

  • +
  • -
  • 0

#3 SzyjaN

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:131
  • GG:
  • Lokalizacja:Katowice
Offline

Napisano 02.05.2010 15:13

[ZP] Zombie VIP 1.6 - AlliedModders - zm_vip i wszystkie dodatki do tego pluginu (zm_extra_unlimited_clip.amxx, zm_vip_extra_goldendg.amxx, zm_vip_extra_human_armor.amxx)
[ZP][Addon] Simple Zombie Radio - AlliedModders - zp_radio
Admin Chat Color - Nieoficjalny polski support AMX Mod X - admin chat colors
[ZP] Extra Item : Candle Bomb - AlliedModders - zp_extra_candle

Debug już dodaję, zaraz napiszę co z tego wyjdzie
  • +
  • -
  • 0

#4 Kusek

    z Wikipedii

  • Power User

Reputacja: 445
Wszechobecny

  • Postów:1655
  • Imię:Krystian
  • Lokalizacja:Nowa Dęba
Offline

Napisano 02.05.2010 15:16

masz odblokowane moduły w modules.ini??


czy wgrałeś wszystkie pliki z pluginy vip??
z folderu tego
addons\amxmodx\configs
i tego
addons\amxmodx\data



czy z radia wgrałeś sound wszystkie??
czyli tą muzykę z tego folderu?
sound\zombie_plague\radio

Użytkownik Frajer edytował ten post 02.05.2010 15:19

  • +
  • -
  • 0

#5 SzyjaN

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:131
  • GG:
  • Lokalizacja:Katowice
Offline

Napisano 02.05.2010 15:21

Tak, to nie jest takie trudne więc tu błędu nie popełniłem ;) nie jestem pewien czy to nie wina kodu

[AMXX] Plugin "zm_extra_buy_survnem.amxx" failed to load: Plugin uses an unknown function (name "zp_make_user_survivor") - check your modules.ini.

Tu jest kolejna linijka tyle że z konsoli serwa

Użytkownik *Szyjanq* edytował ten post 02.05.2010 15:24

  • +
  • -
  • 0

#6 Kusek

    z Wikipedii

  • Power User

Reputacja: 445
Wszechobecny

  • Postów:1655
  • Imię:Krystian
  • Lokalizacja:Nowa Dęba
Offline

Napisano 02.05.2010 15:23

jak czytałem posty do plugin działa, może gryzą się ze sobą?? , a z tymi modułami sprawdziłeś?
  • +
  • -
  • 0

#7 SzyjaN

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:131
  • GG:
  • Lokalizacja:Katowice
Offline

Napisano 02.05.2010 15:29

Nie wiem do końca co mam zrobić z tymi modułami bo tego jeszcze nie robiłem, jeśli możesz to mi napisz
  • +
  • -
  • 0

#8 Kusek

    z Wikipedii

  • Power User

Reputacja: 445
Wszechobecny

  • Postów:1655
  • Imię:Krystian
  • Lokalizacja:Nowa Dęba
Offline

Napisano 02.05.2010 15:33

odblokuj moduły w modules.ini aby ten plik wyglądał mniej więcej tak
;;;
; To enable a module, remove the semi-colon (<img src='http://amxx.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' /> in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time.  Use      ;;
;;  amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

;mysql
;sqlite

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here.              ;;
;; You can just list their names, without the _amxx ;;
;;  or file extension.                              ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; These modules will be auto-detected and loaded   ;;
;;  as needed.  You do not need to enable them here ;;
;;  unless you have problems.                       ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

fun
engine
fakemeta
geoip
sockets
regex
nvault
cstrike
csx
hamsandwich

  • +
  • -
  • 0

#9 SzyjaN

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:131
  • GG:
  • Lokalizacja:Katowice
Offline

Napisano 02.05.2010 18:12

Odblokowałem tak jak ty teraz, ale nic to nie dało, dalej nie działają
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych