Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Nie można uruchomić serwa...


  • Zamknięty Temat jest zamknięty
10 odpowiedzi w tym temacie

#1 EmPeTrzy

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:38
  • GG:
  • Lokalizacja:Międzyzdroje.
Offline

Napisano 25.08.2008 07:48

Mam takowy problem:
Gdy uruchamiam to w konsoli wyskakuje :

Add "-debug" to the ./hlds_run command line to generate a debug.log to
help with solving this problem
Mon Aug 25 04:41:51 CEST 2008: Server restart in 10 seconds
Error:libSteamValidateUserIDTickets_i386.so: cannot open shared object
file: No such file or directory
Unable to load engine, image is corrupt.


Nie iwem co już zrobić...
  • +
  • -
  • 0

#2 Marta

    Profesjonalista

  • Użytkownik

Reputacja: 28
Życzliwy

  • Postów:172
Offline

Napisano 25.08.2008 07:51

A masz coś w logach ?
  • +
  • -
  • 0

#3 EmPeTrzy

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:38
  • GG:
  • Lokalizacja:Międzyzdroje.
Offline

Napisano 25.08.2008 08:17

Matra, agdzie są te logi, bo ja jestem kuzynem empetrzy i mam dostęp do tego konta i serwera.
  • +
  • -
  • 0

#4 choyrack

    Wszechpomocny

  • Użytkownik

Reputacja: 64
Pomocny

  • Postów:369
  • GG:
  • Lokalizacja:Wrocław
Offline

Napisano 25.08.2008 09:48

EmPeTrzy, spróbuj przed uruchomieniem hlds_run
użyć tego:
LD_LIBARARY_PATH=$PWD:$LD_LIBRARY_PATH
i potem normalnie uruchamiasz hlds. Ważnie żebyś podczas wpisywania tego co masz wyżej był w katalogu gdzie masz plik hlds_run.
  • +
  • -
  • 0

#5 Gość__*

  • Gość

Reputacja: 0

Offline

Napisano 25.08.2008 11:12

Matra, agdzie są te logi, bo ja jestem kuzynem empetrzy i mam dostęp do tego konta i serwera.

http://amxx.pl/viewtopic.php?t=2106

#6 jerry

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:5
  • Lokalizacja:Kraków
Offline

Napisano 25.08.2008 13:05

Witam. Mam podobny problem... Otóż mam cs'a no-steama, zainstalowałem wszystko jak trzeba, i gdy daje new game, serwer startuje, ale gdy powinna pojawić się już mapa, wywala mi bład, że HL spowodował błąd :| Gdy wcześniej bawiłem się no-steamem, mape odpalało ale po wybraniu teamu nie pajawiałem się na niej. To samo z botami. Teraz nie chce nawet wczytać mapy :X

w logach mam coś takiego:
L 08/25/2008 - 13:43:54: -------- Mapchange to de_aztec --------
L 08/25/2008 - 13:43:55: [AMXX] Plugin "csdm_main.amxx" failed to load: Plugin uses an unknown function (name "csdm_respawn") - check your modules.ini.
L 08/25/2008 - 13:43:55: [AMXX] Plugin "csdm_equip.amxx" failed to load: Plugin uses an unknown function (name "csdm_active") - check your modules.ini.
L 08/25/2008 - 13:43:55: [AMXX] Plugin "csdm_spawn_preset.amxx" failed to load: Plugin uses an unknown function (name "csdm_trace_hull") - check your modules.ini.
L 08/25/2008 - 13:43:55: [AMXX] Plugin "csdm_misc.amxx" failed to load: Plugin uses an unknown function (name "csdm_active") - check your modules.ini.
L 08/25/2008 - 13:43:55: [AMXX] Plugin "csdm_protection.amxx" failed to load: Plugin uses an unknown function (name "csdm_active") - check your modules.ini.
L 08/25/2008 - 13:44:06: [CSDM2] CSDM failed to load, contact author...

nie mam tego pluginu w plugins.ini ... patrzyłem do modules.ini ale nie ma tam nic ciekawego ;P
plik liblist.gam zamieniłem wg wzoru:
game "Counter-Strike 1.6" 
url_info "www.counter-strike.net" 
url_dl "" 
version "1.6" 
size "184000000" 
svonly "0" 
secure "0" 
type "multiplayer_only" 
cldll "1" 
hlversion "1111" 
nomodels "1" 
nohimodel "1" 
mpentity "info_player_start" 
#gamedll "dllsmp.dll" 
gamedll "addons/metamod/dlls/metamod.dll" 
#gamedll_linux "dlls/cs_i386.so" 
gamedll_linux "addons/metamod/dlls/metamod_i386.so" 
trainmap "tr_1"

:help:
  • +
  • -
  • 0

#7 Marta

    Profesjonalista

  • Użytkownik

Reputacja: 28
Życzliwy

  • Postów:172
Offline

Napisano 25.08.2008 13:14

Pokaż modules.ini
  • +
  • -
  • 0

#8 jerry

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:5
  • Lokalizacja:Kraków
Offline

Napisano 25.08.2008 13:36

modules.ini

;;;
; To enable a module, remove the semi-colon (<img src='http://amxx.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' /> in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time.  Use      ;;
;;  amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

;mysql
;sqlite

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here.              ;;
;; You can just list their names, without the _amxx ;;
;;  or file extension.                              ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; These modules will be auto-detected and loaded   ;;
;;  as needed.  You do not need to enable them here ;;
;;  unless you have problems.                       ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

fun
;engine
;fakemeta
;geoip
;sockets
;regex
;nvault
cstrike
csx

teraz, gdy usunąłem te pluginy csdm~

L 08/25/2008 - 14:30:56: Start of error session.
L 08/25/2008 - 14:30:56: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20080825.log")
L 08/25/2008 - 14:30:56: [AMXX] Plugin file open error (plugin "csdm_main.amxx")
L 08/25/2008 - 14:30:56: [AMXX] Plugin file open error (plugin "csdm_equip.amxx")
L 08/25/2008 - 14:30:56: [AMXX] Plugin file open error (plugin "csdm_spawn_preset.amxx")
L 08/25/2008 - 14:30:56: [AMXX] Plugin file open error (plugin "csdm_misc.amxx")
L 08/25/2008 - 14:30:56: [AMXX] Plugin file open error (plugin "csdm_protection.amxx")
L 08/25/2008 - 14:30:56: [AMXX] Plugin file open error (plugin "csdm_ffa.amxx")

ciekawi mnie tylko, dlaczego amxx chce załadować te pluginy, skoro ich nie mam nigdzie wpisanych o_O?
  • +
  • -
  • 0

#9 Marta

    Profesjonalista

  • Użytkownik

Reputacja: 28
Życzliwy

  • Postów:172
Offline

Napisano 25.08.2008 14:03

a nie masz w plugins.ini ich nazw wpisanych ? :/
  • +
  • -
  • 0

#10 jerry

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:5
  • Lokalizacja:Kraków
Offline

Napisano 25.08.2008 14:05

Nie mam. Sprawdzałem kilka razy. Ale nie wiem czy ma to jakiś związek z crashem serwa... wiem że jak zainstalowałem amxx na steamie, to serw działał. Czyli jest to kwestia jakiś ustawień/wartości :/ :help:

//EDIT: przy tworzeniu serwera, pasek postępu dochodzi do "parsing game info..." i błąd :(

//EDIT2: lol, był plik plugins-csdm.ini i z niego czytał te pluginy, zmieniłem nazwe i w logach już się o niego nie pyta. Włączyłem inny plugin (predator) i ładnie pięknie wszystko ładuje, ale dalej wywala błąd przy startowaniu serwa :X
  • +
  • -
  • 0

#11 Knnube

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:4
Offline

Napisano 26.08.2008 21:45

Odpal serwera na czystym amxx'sie i potem dodawaj potrzebne pluginy a nie jakiś syf z neta pakować.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych