Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z nowym menu


  • Zamknięty Temat jest zamknięty
1 odpowiedź w tym temacie

#1 vDev

    Nowy

  • Pijawka

Reputacja: 0
zer0.

  • Postów:1
  • Lokalizacja:Slask
Offline

Napisano 03.04.2010 22:20

Cześć,

Piszę tu, ponieważ posiadam problem z "nowym menu". Menu się tworzy wszystko ładnie.. Działa.. Menu tworzę przez komendę, ale mogę ją wywołać tylko 1 raz, później nie działa. Nie występuje żaden błąd w logach amxmodx.

Zamieszczam mój kod:
public wybierz_klase(id)
{
	new WybierzKlase=menu_create("Wybierz klase:","lista_wyboru")
	
	menu_setprop(WybierzKlase, MPROP_PERPAGE, 7)
	menu_setprop(WybierzKlase, MPROP_BACKNAME, "Wstecz")
	menu_setprop(WybierzKlase, MPROP_NEXTNAME, "Dalej")
	menu_setprop(WybierzKlase, MPROP_EXITNAME, "Wyjscie")
	menu_setprop(WybierzKlase, MPROP_TITLE, "Wybierz klase:")
	menu_setprop(WybierzKlase, MPROP_EXIT, MEXIT_ALL)
		
	menu_additem(WybierzKlase,"Pierwsza klasa")
	menu_additem(WybierzKlase,"inna klasa")
	menu_additem(WybierzKlase,"nastepna klasa")
	menu_additem(WybierzKlase,"jakas w ogole klasa")
	menu_additem(WybierzKlase,"hah klasa")
	
	menu_display(id, WybierzKlase,0);
	
	return PLUGIN_HANDLED;
}

public lista_wyboru(id, menu, key) 
{ 
	switch(key) 
	{ 
		case 0: 
		{	
			client_print(id,print_chat, "Witaj1")
			menu_destroy(menu)
		}
		case 1: 
		{	
			client_print(id,print_chat, "Witaj2")
			menu_destroy(menu)
		}
		case 2: 
		{	
			client_print(id,print_chat, "Witaj3")
			menu_destroy(menu)
		}
		case 3: 
		{	
			client_print(id,print_chat, "Witaj4")
			menu_destroy(menu)
		}
		case 4: 
		{	
			client_print(id,print_chat, "Witaj5")
			menu_destroy(menu)
		}
	}
	return PLUGIN_HANDLED;
}

Za pierwszym razem działa ale, gdy drugi raz wywołuję wybierz_klase(id) to nic się nie dzieje!

Pomocy!

03 kwiecień 2010 - 22:20:
Dobra naprawione.. :P Do kasacji

Użytkownik vDev edytował ten post 03.04.2010 21:35

  • +
  • -
  • 0

#2 Adminek AMXX.PL

    Admin :)

  • Bot

Reputacja: 156
Profesjonalista

  • Postów:7178
  • Lokalizacja:AMXX.PL
Offline

Napisano 03.04.2010 23:07

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: "Dobra naprawione.. :P"

Jeśli się z tym nie zgadzasz, Dołączona grafika raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych