Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

dproto - żadna wersja nie działa


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 BlueMan

    Życzliwy

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:21
  • Lokalizacja:Sosnowiec
Offline

Napisano 25.03.2010 23:37

Mam problem z instalacją dproto. Nie jest to mój pierwszy serwer CS, ale akurat teraz napotkałem na problem :/

Próbowałem z najnowszą wersja 0.4.7 ale niestety po wpisaniu meta list wyświetla mi się
meta list
Currently loaded plugins:
      description      stat pend  file              vers      src  load  unlod
 [ 1] AMX Mod X        RUN   -    amxmodx_mm_i386.  v1.8.1.3  ini  Start ANY
 [ 2] <dproto_i386.so  badf load  dproto_i386.so    v -       ini   -     -
 [ 3] Fun              RUN   -    fun_amxx_i386.so  v1.8.1.3  pl1  ANY   ANY
 [ 4] FakeMeta         RUN   -    fakemeta_amxx_i3  v1.8.1.3  pl1  ANY   ANY
 [ 5] CStrike          RUN   -    cstrike_amxx_i38  v1.8.1.3  pl1  ANY   ANY
 [ 6] CSX              RUN   -    csx_amxx_i386.so  v1.8.1.3  pl1  ANY   ANY
 [ 7] Ham Sandwich     RUN   -    hamsandwich_amxx  v1.8.1.3  pl1  ANY   ANY
7 plugins, 6 running
Konsola z błędami mów wtedy:
L 03/25/2010 - 22:32:31: [META] ERROR: dll: Failed query plugin '<dproto_i386.so>'; Couldn't open file '/home/csteam/hlds/cstrike/addons/dproto/dproto_i386.so': libstdc++.so.6: cannot open shared object file: No such file or directory
L 03/25/2010 - 22:32:31: [META] ERROR: dll: Skipping plugin '<dproto_i386.so>'; couldn't query

L 03/25/2010 - 22:32:33: [META] ERROR: ini: Plugin '<dproto_i386.so>' has newer file, but unexpected status (badfile)
L 03/25/2010 - 22:32:33: [META] ini: Read plugin config for: <dproto_i386.so>

L 03/25/2010 - 22:32:33: [META] ERROR: dll: Failed query plugin '<dproto_i386.so>'; Couldn't open file '/home/csteam/hlds/cstrike/addons/dproto/dproto_i386.so': libstdc++.so.6: cannot open shared object file: No such file or directory
L 03/25/2010 - 22:32:33: [META] ERROR: dll: Skipping plugin '<dproto_i386.so>'; couldn't query
L 03/25/2010 - 22:32:33: [META] dll: Finished updating 7 plugins; kept 1, loaded 0, unloaded 0, reloaded 0, delayed 0
A przy zamykaniu serwera (exit) konsola wypluwa:
L 03/25/2010 - 22:35:37: [META] ERROR: ini: Plugin '<dproto_i386.so>' has newer file, but unexpected status (badfile)
L 03/25/2010 - 22:35:37: [META] ini: Read plugin config for: <dproto_i386.so>
L 03/25/2010 - 22:35:37: [META] ini: Finished reading plugins list: /home/csteam/hlds/cstrike/addons/metamod/plugins.ini; Found 2 plugins
L 03/25/2010 - 22:35:37: [META] dll: Updating plugins...
L 03/25/2010 - 22:35:37: [META] ERROR: dll: Failed query plugin '<dproto_i386.so>'; Couldn't open file '/home/csteam/hlds/cstrike/addons/dproto/dproto_i386.so': libstdc++.so.6: cannot open shared object file: No such file or directory
L 03/25/2010 - 22:35:37: [META] ERROR: dll: Skipping plugin '<dproto_i386.so>'; couldn't query
L 03/25/2010 - 22:35:37: [META] dll: Finished updating 7 plugins; kept 1, loaded 0, unloaded 0, reloaded 0, delayed 0
L 03/25/2010 - 22:35:37: Server shutdown

Gdy załaduję na serwer plik SO i CFG z wersji 0.3.7 to pojawia się
meta list
Currently loaded plugins:
      description      stat pend  file              vers      src  load  unlod
 [ 1] AMX Mod X        RUN   -    amxmodx_mm_i386.  v1.8.1.3  ini  Start ANY
 [ 2] dproto           fail  -    dproto_i386.so    v0.3.7    ini  Start Never
 [ 3] Fun              RUN   -    fun_amxx_i386.so  v1.8.1.3  pl1  ANY   ANY
 [ 4] FakeMeta         RUN   -    fakemeta_amxx_i3  v1.8.1.3  pl1  ANY   ANY
 [ 5] CStrike          RUN   -    cstrike_amxx_i38  v1.8.1.3  pl1  ANY   ANY
 [ 6] CSX              RUN   -    csx_amxx_i386.so  v1.8.1.3  pl1  ANY   ANY
 [ 7] Ham Sandwich     RUN   -    hamsandwich_amxx  v1.8.1.3  pl1  ANY   ANY
7 plugins, 6 running
Konsola z błędami mówi:
[DPROTO]: Version 0.3.7 Linux
L 03/25/2010 - 22:29:15: [DPROTO]: Version 0.3.7 Linux
[DPROTO]:  Loading config './dproto.cfg'
L 03/25/2010 - 22:29:15: [DPROTO]:  Loading config './dproto.cfg'
[DPROTO]:  LoggingMode = 2
L 03/25/2010 - 22:29:15: [DPROTO]:  LoggingMode = 2
L 03/25/2010 - 22:29:15: [DPROTO]: User Info Verification Mode: 3
L 03/25/2010 - 22:29:15: [DPROTO]:  MaxUserInfoSize = 230
L 03/25/2010 - 22:29:15: [DPROTO]: AuthID for HLTV: HLTV
L 03/25/2010 - 22:29:15: [DPROTO]: AuthID for No-steam p47 clients: STEAM_ID_LAN
L 03/25/2010 - 22:29:15: [DPROTO]: AuthID for No-steam p48 clients: VALVE_ID_LAN
L 03/25/2010 - 22:29:15: [DPROTO]: AuthID for steam clients: Real STEAM_x:x:x
L 03/25/2010 - 22:29:15: [DPROTO]: AuthID for steam unauthorized clients: STEAM_ID_PENDING
L 03/25/2010 - 22:29:15: [DPROTO]: AuthID for RevEmu clients: Real STEAM_x:x:x
L 03/25/2010 - 22:29:15: [DPROTO]: AuthID for Old RevEmu clients: Real STEAM_x:x:x
L 03/25/2010 - 22:29:15: [DPROTO]: AuthID for SteamEmu clients: Real STEAM_x:x:x
L 03/25/2010 - 22:29:15: [DPROTO]: AuthID for SETTI server scanner: STEAM id generated by ip
L 03/25/2010 - 22:29:15: [DPROTO]: p47 Emus SteamEmuCompatMode : ON
L 03/25/2010 - 22:29:15: [DPROTO]: Disable fix for steamids generated by eST in 0.3.1 version: No
L 03/25/2010 - 22:29:15: [DPROTO]:  First prefix of authids genrated by ip: 0
L 03/25/2010 - 22:29:15: [DPROTO]:  Second prefix of authids genrated by ip: 4
L 03/25/2010 - 22:29:15: [DPROTO]:  Disable Native Auth (Steam/Valve): OFF
L 03/25/2010 - 22:29:15: [DPROTO]:  ServerInfo answer type: Hybrid
L 03/25/2010 - 22:29:15: [DPROTO]:  Enable master-client emulation on primary port: OFF
L 03/25/2010 - 22:29:15: [DPROTO]: This version of game will be used by master-client to send to master-servers: '1.1.2.6/Stdio'
L 03/25/2010 - 22:29:15: [DPROTO]:  Enable secondary redirect-server: OFF
L 03/25/2010 - 22:29:15: [DPROTO]:  Secondary server port: 28015
L 03/25/2010 - 22:29:15: [DPROTO]:  Enable master client on secondary server: OFF
L 03/25/2010 - 22:29:15: [DPROTO]:  Secondary server ServerInfo answer type: New Style (Source)
L 03/25/2010 - 22:29:15: [DPROTO]:  Secondary server will execute this in connecting clients: 'connect 169.254.141.3:27015'
L 03/25/2010 - 22:29:15: [DPROTO]:  Secondary server ip: 0.0.0.0
L 03/25/2010 - 22:29:15: [DPROTO]: Setting game name to: (Native game name)
L 03/25/2010 - 22:29:15: [DPROTO]:  Enable Fix for player ids on hlstats monitoring: OFF
L 03/25/2010 - 22:29:15: [DPROTO]: dp_version cvar will be exported: Yes
[DPROTO]:  Config sucessfully loaded.
L 03/25/2010 - 22:29:15: [DPROTO]:  Config sucessfully loaded.
L 03/25/2010 - 22:29:15: [DPROTO]: Server port: 27015
L 03/25/2010 - 22:29:15: [DPROTO]: engine_i686.so found at 0xf783a000
Sorry, this version of engine isnt supported
L 03/25/2010 - 22:29:15: Sorry, this version of engine isnt supported

Co jest nie tak? Co robię źle? :|
Ścieżka do configa i pliku dproto_i386.so jest prawidłowa, bo jak podmienię na starszą wersje to plik wczytuje, ale wywala błąd nikompatybilności.
  • +
  • -
  • 0

#2 ussama

    Zaawansowany

  • Użytkownik

Reputacja: 6
Nowy

  • Postów:94
  • Lokalizacja:częstochowa
Offline

Napisano 26.03.2010 11:39

L 03/25/2010 - 22:35:37: [META] ERROR: dll: Failed query plugin '<dproto_i386.so>'; Couldn't open file '/home/csteam/hlds/cstrike/addons/dproto/dproto_i386.so': libstdc++.so.6: cannot open shared object file: No such file or directory


Twoj linux nie posiada biblioteki w systemie wymaganej do dzialania dproto 0.4.7

[DPROTO]: Config sucessfully loaded.
L 03/25/2010 - 22:29:15: [DPROTO]: Config sucessfully loaded.
L 03/25/2010 - 22:29:15: [DPROTO]: Server port: 27015
L 03/25/2010 - 22:29:15: [DPROTO]: engine_i686.so found at 0xf783a000
Sorry, this version of engine isnt supported
L 03/25/2010 - 22:29:15: Sorry, this version of engine isnt supported



Dproto 0.3.7 nie dziala z twoim silniekiem serwerowym, by dzialalo 0.3.7 musisz uzyc silniku max w wersji 4617.

PS jest juz wersja 0.4.8 dproto jednak nie bedzie ona wspierana bez bibliotek o ktorych pisalem i tak.
  • +
  • -
  • 1

#3 BlueMan

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:21
  • Lokalizacja:Sosnowiec
Offline

Napisano 26.03.2010 11:54

faktycznie :) nie widziałem tego wpisu :)

Zainstalowałem co trzeba i śmiga ;]
Dzięki wielkie!

Użytkownik BlueMan edytował ten post 26.03.2010 11:54

  • +
  • -
  • 0

#4 XQS

    Początkujący

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:17
  • Lokalizacja:Lublin
Offline

Napisano 01.04.2010 18:28

Co zainstalowaleś ?Bo mam taki sam problem i nie wiem jak go rozwiązać.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych