Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Dodawanie nowej klasy


  • Zamknięty Temat jest zamknięty
7 odpowiedzi w tym temacie

#1 ReDDi

    Profesjonalista

  • Użytkownik

Reputacja: 13
Początkujący

  • Postów:224
  • GG:
  • Lokalizacja:Szczecin
Offline

Napisano 14.03.2010 16:21

Witam chciałem dodać nową klasę na serwer DiabloMod zrobiłem wszystko tak jak w poradniku wgrałem na serwa .sma ale nie ma tej klasy przy wyborze ani nic zupełnie jakbym jej nie dodał. Dołączam mój .sma z tą klasą używam ddmod 5.9l klasa nazywa się tak jak w poradniku: Cziter. Jakby ktos mogł zobaczyć i powiedzieć co zrobiłem nie tak byłbym wdzieczny :) , lub też poprawić.
  • +
  • -
  • 0

#2 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 14.03.2010 16:25

wgrałem na serwa .sma


.sma nic na serwerze nie robi. Moze go nawet nie być.

Właściwy plik to jego komilacja, czyli plik .amxx.
  • +
  • -
  • 0

#3 ReDDi

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 13
Początkujący

  • Postów:224
  • GG:
  • Lokalizacja:Szczecin
Offline

Napisano 14.03.2010 16:27

Ale mówili że to all się robi w .sma noto jak mam dodać nową klasę??
  • +
  • -
  • 0

#4 Dave12

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:54
  • Lokalizacja:Bielsko-Biała
Offline

Napisano 14.03.2010 18:21

no musisz skompilować plik sma żeby powstał amxx i wrzucić na serwer do folderu plugins.

Użyj jakiegoś kompilatora gdzieś na forum można pobrać
  • +
  • -
  • 0

#5 RyanAner

    Pomocny

  • Użytkownik

Reputacja: 3
Nowy

  • Postów:61
  • GG:
  • Lokalizacja:Jastrzębie Zdrój
Offline

Napisano 14.03.2010 18:25

http://amxx.pl/kompilator.html

  • +
  • -
  • 0

#6 ReDDi

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 13
Początkujący

  • Postów:224
  • GG:
  • Lokalizacja:Szczecin
Offline

Napisano 14.03.2010 18:40

Włąsnie sie 20minut temu o tym dowiedziałem :P ale mam problem z tymi kompilatorami, ponieważ zawsze nie udaje się skompilować jest błąd :/

14 marzec 2010 - 18:40:
Nie udało się skompilować pluginu.
Przeczytaj poniższy bład:
Welcome to the AMX Mod X 1.8.1-300 Compiler.
Copyright © 1997-2006 ITB CompuPhase, AMX Mod X Team

/groups/amxmodx/tmp3/textjnZuOe.sma(896) : error 017: undefined symbol "player_xp_old"
/groups/amxmodx/tmp3/textjnZuOe.sma(896) : warning 215: expression has no effect
/groups/amxmodx/tmp3/textjnZuOe.sma(896) : error 001: expected token: ";", but found "]"
/groups/amxmodx/tmp3/textjnZuOe.sma(896) : error 029: invalid expression, assumed zero
/groups/amxmodx/tmp3/textjnZuOe.sma(896) : fatal error 107: too many error messages on one line

Compilation aborted.
4 Errors.

Tu mam takie błędy <_< . Dołączam mój .sma
Załączony plik  dbmod_5.9l.sma   228,11 KB  17 Ilość pobrań
  dbmod_5.9l.amxx

Użytkownik ReDDi edytował ten post 14.03.2010 18:43

  • +
  • -
  • 0

#7 ToskaFFke.?

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Lokalizacja:Wieluń
Offline

Napisano 14.03.2010 19:06

Przylaczam sie do prosby, lecz u mnie wyglad to troszke inaczej :
Nie udało się skompilować pluginu.
Przeczytaj poniższy bład:
Welcome to the AMX Mod X 1.8.1-300 Compiler.
Copyright (c) 1997-2006 ITB CompuPhase, AMX Mod X Team

/groups/amxmodx/tmp3/text9ayVLy.sma(265) : error 052: multi-dimensional arrays must be fully initialized
/groups/amxmodx/tmp3/text9ayVLy.sma(8178) : error 002: only a single statement (or expression) can follow each "case"
/groups/amxmodx/tmp3/text9ayVLy.sma(8179) : error 014: invalid statement; not in switch
/groups/amxmodx/tmp3/text9ayVLy.sma(8180) : warning 203: symbol is never used: "Ohroniarz"
/groups/amxmodx/tmp3/text9ayVLy.sma(8181) : error 054: unmatched closing brace

4 Errors.
Could not locate output file /home/groups/amxmodx/public_html/websc3/text9ayVLy.amx (compile failed).

  • +
  • -
  • 0

#8 ReDDi

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 13
Początkujący

  • Postów:224
  • GG:
  • Lokalizacja:Szczecin
Offline

Napisano 14.03.2010 19:14

ja tu ogarniam tylko to że cos zle jest zrobione i ten kompilator tego nie bierze : /
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych