Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.
  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

menu klas


  • Zamknięty Temat jest zamknięty
1 odpowiedź w tym temacie

#1 G[o]Q

    I'm G[o]Q

  • Przyjaciel

Reputacja: 1340
Godlike

  • Postów:3556
  • Steam:steam
  • Imię:Krzysiek
  • Lokalizacja:C: / program Files / Valve / Cstrike / G[o]Q.dem
Offline

Napisano 08.02.2010 21:01

pisze tutaj bo dotyczy to modyfikacji diablo :D wiec tak dodalem new klasy zrobilem menu i wszystko ladnie pieknie ale mam jeden problem ze nie wyswietla mi lvl'u na nowych klasach w menu

w standardzie jest tak

public select_class(id,lx[])
{
	if(is_user_bot(id)) return
	new flags[12]
	get_cvar_string("diablo_classes",flags,12)
	new text[512]
	//new keys = read_flags(flags)
	
	asked_klass[id]=0
	
	format(text, 511,"\yWybierz Klase - ^n")
	
	for(new i=0;i<8;i++)
	{
		format(text, 511,"%s%s%d. %s  Level :%d ^n",text,(keyss)&(1<<i)?"\w":"\d",i+1,Race[i+1], lx[i+1])
	}
	
	show_menu(id, keyss, text) 
	
}



ja dodajac kolejna strone zrobilem takie cos :

public ShowKlasy(id,lx[]) {
	new text2[512]
	format(text2, 511,"\yWybierz klase - ^n\w1. klasa1   Level :%d^n2. klasa2   Level :%d^n3. klasa3   Level :%d^n^n0.Wstecz^n",lx[8],lx[9],lx[10])
	
	show_menu(id, KeysKlasy,text2, -1, "Klasy")
	
	
	}



w standardzie

lx[i+1]



odpowiada za wyswietlenie wiec co robie zle??

PS
jest tutaj podany sposob na dodanie 2 menu przy tworzeniu new klas wiec jesli ktos pomoze rozwiazac ten problem to udostepnie cale menu jak zrobic :D

Refresh :!: :!:
  • +
  • -
  • 0
Manual ponad wszystko, konsola ponad manual :D :&

Chcesz wysłać do mnie PW ? użyj nazwy GoQ zamiast G[o]Q
Chcesz Kupić moduł płatności via Pukawka,Tserwery, Gamesol, Zabijaka do mojego sklepu? napisz PW cena to tylko 10 zł/sztuka

GG:6022845 (nie pomagam za free osobom ponizej rangi MoD) :D

#2 Nosek

    Zaawansowany

  • Użytkownik

Reputacja: 20
Życzliwy

  • Postów:101
  • Lokalizacja:Dom
Offline

Napisano 13.02.2010 12:36

Tak na moje to:

get_cvar_string("diablo_classes",flags,12)

asked_klass[id]=0

pobiera dane z bazy.

Probowales to dopisac do menu2?

Użytkownik Nosek edytował ten post 13.02.2010 12:37

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych