Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Diablo mod - Błąd


  • Zamknięty Temat jest zamknięty
19 odpowiedzi w tym temacie

#1 fifiakurat

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:60
  • Lokalizacja:etuy
Offline

Napisano 30.01.2010 14:36

Nie działa mi /klasa, z tego co widzę jest coś źle z połączeniem mysql.
Oto logi:
(2)L 01/30/2010 - 14:08:18: Could not connect to SQL database.
L 01/30/2010 - 14:10:34: Error on Table query: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
L 01/30/2010 - 14:10:34: Could not connect to SQL database.

Cvary z amxx.cfg:
diablo_xpbonus 7 // ilość expa za zabicie standardowo ustawione na 7
diablo_xpbonus2 40 //ilość expa za wykonania celu misji standardowo ustawione na 50
diablo_durability 3 //Tracisz wytrzymałość za każde obrażenia ? Ile za każdym razem
diablo_saveitems 1 // włącza zapisywanie itemów podczas zmiany mapy
diablo_spawnchance 1/50 // szansa na zrespienia worka
SaveXp 1 //zapisywanie doświadczenia
diablo_classes abcdefgh //- które klasy maja być dostępne
diablo_avg 0 //- zaczynanie od sredniej serwera (liczonego od lvl 1)
diablo_dmg_exp 30 //- za ile zabranego hp wrogowi dostaje sie 1 exp (domyslnie 20

sql.cfg:
amx_sql_host "www.botypolskie.pl"
amx_sql_user "botypols_fifi"
amx_sql_pass "moje haslo"
amx_sql_db "botypols_dbmod"
amx_sql_table "diablo"
amx_sql_type "mysql"
  • +
  • -
  • 0

#2 Arct

    Zaawansowany

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:104
  • Lokalizacja:Szczecin
Offline

Napisano 30.01.2010 14:55

hosta podajesz bez www czyli samo amx_sql_host "botypolskie.pl"
  • +
  • -
  • 0

#3 fifiakurat

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:60
  • Lokalizacja:etuy
Offline

Napisano 30.01.2010 14:59

Zmieniłem, nic nie dało, ale na innym serwerze też mam połączenie do MySQL i jest www i działa, tylko że tamten to po prostu ma połączenie do amxbans, a tu potrzebuje do diablo.
Proszę o pomoc.
  • +
  • -
  • 0

#4 BraUn878

    Pomocny

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:67
  • Lokalizacja:Police
Offline

Napisano 30.01.2010 19:57

Do sql.cfg masz nic nie dodawać tylko do amxx.cfg to po pierwsze.
A po drugie tak mają wyglądać cvary do diablo moda:
diablo_sql_host
diablo_sql_user 
diablo_sql_pass 
diablo_sql_database 
diablo_sql_table 
diablo_sql_save

W moim przypadku wygląda to tak:
diablo_sql_host "cs-urwisek.xaa.pl"
diablo_sql_user "csurwise_diablo"
diablo_sql_pass "********"
diablo_sql_database "csurwise_forum"
diablo_sql_table "diablo_"
diablo_sql_save "1"

Użytkownik Pavulon edytował ten post 30.01.2010 20:01

  • +
  • -
  • 2

#5 fifiakurat

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:60
  • Lokalizacja:etuy
Offline

Napisano 30.01.2010 20:54

dzięki, a za co odpowiada: diablo_sql_save i jakie są opcje 0 - wyłącza 1- ?? 2- ??

/klasa niestety nadal nie działa. :/

Użytkownik fifiakurat edytował ten post 30.01.2010 21:20

  • +
  • -
  • 0

#6 BraUn878

    Pomocny

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:67
  • Lokalizacja:Police
Offline

Napisano 30.01.2010 21:15

Zapisywanie exp na:
0 - nick
1 - ip
2 - steam id

//Nie prosimy o reputację (Patrz. Regulamin)
//Pavulon

Użytkownik Pavulon edytował ten post 30.01.2010 22:03

  • +
  • -
  • -1

#7 fifiakurat

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:60
  • Lokalizacja:etuy
Offline

Napisano 30.01.2010 22:13

Jeszcze mi powiedz, czemu mi nadal te klasy nie działają? :D
Oczywiście, jeżeli będzie mi działało reputacja będzie.
  • +
  • -
  • 0

#8 Insajdzik

    Nowy

  • Pijawka

Reputacja: -1
Mniej niż zer0.

  • Postów:3
  • Lokalizacja:Police
Offline

Napisano 31.01.2010 14:11

może zły diablo mod?

Użytkownik Insajdzik edytował ten post 31.01.2010 14:12

  • +
  • -
  • -1

#9 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 31.01.2010 14:38

Daj aktualne logi po tych zmianach :rolleyes:
  • +
  • -
  • 0

#10 fifiakurat

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:60
  • Lokalizacja:etuy
Offline

Napisano 31.01.2010 17:24

L 01/31/2010 - 17:16:58: 01/31/2010 - 17:16:58 ### MAPA: de_dust2 ###
L 01/31/2010 - 17:17:15: Error on Table query: Access denied for user 'botypols_diablo'@'ks309357.kimsufi.com' (using password: YES)
L 01/31/2010 - 17:17:15: Could not connect to SQL database.
L 01/31/2010 - 17:17:23: Error on Table query: Access denied for user 'botypols_diablo'@'ks309357.kimsufi.com' (using password: YES)
L 01/31/2010 - 17:17:23: Could not connect to SQL database.
L 01/31/2010 - 17:17:23: Error on Table query: Access denied for user 'botypols_diablo'@'ks309357.kimsufi.com' (using password: YES)
L 01/31/2010 - 17:17:23: Could not connect to SQL database.


amxx.cfg:
diablo_sql_host "botypolskie.pl"
diablo_sql_user "botypols_FiFi"
diablo_sql_pass "********"
diablo_sql_database "botypols_diablo"
diablo_sql_table "diablo"
diablo_sql_save "0"

To na pewno ma być w amxx.cfg, a nie w sql.cfg??

Użytkownik fifiakurat edytował ten post 31.01.2010 17:26

  • +
  • -
  • 0

#11 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 31.01.2010 17:29

Odmowa dostepu, albo baza danych nie zezwala na dostep z zewnatrz albo zle dane podales O:)
  • +
  • -
  • 0

#12 fifiakurat

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:60
  • Lokalizacja:etuy
Offline

Napisano 31.01.2010 17:37

Zrobiłem jeszcze raz baze, tak dla pewności: Użytkownik botypols_FiFi został dodany do bazy danych botypols_diablo.
Czyli baza jest. Ponawiam pytanie, czy to trzeba na pewno do amxx.cfg, czy do sql.cfg?

W modules.ini wszystko odblokowane.

Użytkownik fifiakurat edytował ten post 31.01.2010 17:43

  • +
  • -
  • 0

#13 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 31.01.2010 18:13

do amxx.cfg
  • +
  • -
  • 0

#14 Arct

    Zaawansowany

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:104
  • Lokalizacja:Szczecin
Offline

Napisano 31.01.2010 19:16

1) daj dostep do bazy danych dla tego IP 94.23.245.84 lub wpisz "ks309357.kimsufi.com" (jesli dales to sprawdz czy dobre dane sa wpisane)
moze tez poprsotu hosting nie udostepnia prawa zewnetrznym polaczenia

2) gdzie dodasz wartosci
diablo_sql_host
diablo_sql_user 
diablo_sql_pass 
diablo_sql_database 
diablo_sql_table 
diablo_sql_save

jest to obojetne czy amxx.cfg czy sql.cfg
musisz miec tylko dobrze wpisane tam dane i odblokowany modul mysql/sqlite
  • +
  • -
  • 0

#15 fifiakurat

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:60
  • Lokalizacja:etuy
Offline

Napisano 31.01.2010 21:26

Próbowałem tego wszystkiego.
Aktualne logi z diablo:
### MAPA: de_dust2 ###
L 01/31/2010 - 21:14:20: Error on Table query: Can't connect to MySQL server on 'ks309357.kimsufi.com' (111)
L 01/31/2010 - 21:14:20: Could not connect to SQL database.
L 01/31/2010 - 21:14:29: Error on Table query: Can't connect to MySQL server on 'ks309357.kimsufi.com' (111)
L 01/31/2010 - 21:14:29: Could not connect to SQL database.
L 01/31/2010 - 21:14:29: Error on Table query: Can't connect to MySQL server on 'ks309357.kimsufi.com' (111)
L 01/31/2010 - 21:14:29: Could not connect to SQL database.

Mam hosting prohost.pl działa na nim amxbans na moim drugim serwerze, jeszcze mam tam do wykorzystania 5 baz MySQL, próbowałem, zakładałem inne bazy, ale jest tak jak widzicie. :/ Robiłem jakieś 5 razy reinstal serwera. Nadal tak samo, wszystkie pliki dodane.

//Edit
/Klasa działa, nowa baza MySQL dała rade, ale expa nie nalicza :/ Pisze, że 40 expa za podłożenie bomby, a i tak nie nalicza tego.

Użytkownik fifiakurat edytował ten post 31.01.2010 21:37

  • +
  • -
  • 0

#16 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 31.01.2010 21:48

fifiakurat nie testuj sam tylko w pare osob :F bo nie pozwala na expienie z paki gdy jest sie samemu ;)
  • +
  • -
  • 1

#17 fifiakurat

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:60
  • Lokalizacja:etuy
Offline

Napisano 01.02.2010 15:47

Dzięki wielkie, działa. :)
Tylko mam jeszcze pytanie, czemu nie zawsze włącza się ta /klasa po wejściu na serwer, a niektórym wpisanie /klasa nic nie daje? Jest na to jakiś sposób, plugin, czy coś w tym guście?

Użytkownik fifiakurat edytował ten post 01.02.2010 15:48

  • +
  • -
  • 0

#18 BraUn878

    Pomocny

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:67
  • Lokalizacja:Police
Offline

Napisano 01.02.2010 16:13

Z tego co wiem to nie raz na jakiejś mapie komuś nie działa /klasa ale to błąd którego raczej jeszcze nie rozwiązano :/
  • +
  • -
  • 0

#19 fifiakurat

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:60
  • Lokalizacja:etuy
Offline

Napisano 01.02.2010 16:42

Ale właśnie to bardzo częsty bład :/
  • +
  • -
  • 0

#20 BraUn878

    Pomocny

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:67
  • Lokalizacja:Police
Offline

Napisano 01.02.2010 16:57

No to musimy chyba poczekać na pomoc autorów diablo moda :confused:
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych