Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Plugin Vipanie wymusza zminy modelu


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 warmia

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Lokalizacja:warmia
Offline

Napisano 29.01.2010 10:35

Problem mam taki nie wymusza zmiany modelu co jest nie tak ?Wszystko sie sciaga ale nie wymusza zmiany modelu jka w np. admin i dziewczyny :)

#include <amxmodx>
#include <amxmisc>
#include <cstrike>

public plugin_init() {
register_plugin("Modele", "0.1", "vip")
register_event("ResetHUD", "resetModel","a")
return PLUGIN_CONTINUE
}

public plugin_precache()
{
precache_model("models/player/vip_ct/urban.mdl")
precache_model("models/player/vip_te/leet.mdl")

return PLUGIN_CONTINUE
}

public resetModel(id, level, cid) {
if (get_user_flags(id) ) {
new CsTeams:userTeam = cs_get_user_team(id)
if (userTeam == CS_TEAM_T) {
cs_set_user_model(id, "vip_te")
}
else if(userTeam == CS_TEAM_CT) {
cs_set_user_model(id, "vip_ct")
}
else {
cs_reset_user_model(id)

}
}
return PLUGIN_CONTINUE
}

co tu jest zle?
  • +
  • -
  • 0

#2 Abes Mapper

    Repulsion Gel

  • Przyjaciel

Reputacja: 1996
Godlike

  • Postów:7356
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Sulejówek
Offline

Napisano 29.01.2010 10:48

1. Skąd plugin ma wiedzieć co to "vip_ct" i "vip_te" ?
2.

models/player/vip_ct/urban.mdl

to powinno być tak:
models/player/vip_ct/vip_ct.mdl

  • +
  • -
  • 0

#3 warmia

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Lokalizacja:warmia
Offline

Napisano 29.01.2010 19:03

zmieniłem w programie nawet nazwe i dalej lipa nie zamienia modelu pod literka a co robię źle dalej ścieżki pasują bo się ścigają :)

Użytkownik Pavulon edytował ten post 30.01.2010 16:07
ten CAPSLOCK był ci do niczego nie potrzebny

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych