Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

xRedirectOpcja wyświetlania pod radarem.


  • Zamknięty Temat jest zamknięty
5 odpowiedzi w tym temacie

#1 kasza

    Godlike

  • Przyjaciel

Reputacja: 887
Czempion

  • Postów:4102
  • GG:
  • Steam:steam
  • Imię:Imię
  • Lokalizacja:Lokalizacja
Offline

Napisano 21.01.2010 23:37

Cześć. Chdozi mi o to żeby w Xredirect hud wyświetlany był pod radarem. Próbowałem ustawiać cvarami

redirect_announce_alivepos_x
redirect_announce_alivepos_y
redirect_announce_deadpos_x
redirect_announce_deadpos_y


Z tego co się dowiedziałem to :


Wartość
-1.0 oznacza wycentrowanie.
0.0 - lewa strona;
1.0 - prawa strona;
Podaje się to w procentach (np. 0.2)

Próbowałem według tej teorii, ale za każdym razem jak zmieniłem cvar'a HUD się wcale nie pojawiał...

Próbowałem też zmieniać w sma, ale nic nie dało...

Jest w stanie mi ktoś pomóc ? Załączam też sms.

Załączone pliki


Użytkownik kasza edytował ten post 21.01.2010 23:38

  • +
  • -
  • 0

Skillownia.com

 

 #3 [UWC3NG] Skillownia.com - 213.189.52.253:27301

 


#2 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 21.01.2010 23:46

Nie ma powód dla których miałby nie działać.
	cvar_announce_alivepos_x = register_cvar("redirect_announce_alivepos_x", "-1.0")
cvar_announce_alivepos_y = register_cvar("redirect_announce_alivepos_y", "0.01")
cvar_announce_deadpos_x = register_cvar("redirect_announce_deadpos_x", "-1.0")
cvar_announce_deadpos_y = register_cvar("redirect_announce_deadpos_y", "0.35")


Potem są normalnie pobierane:
set_hudmessage(000, 100, 255, get_pcvar_float(cvar_announce_alivepos_x), get_pcvar_float(cvar_announce_alivepos_y), 0, 0.0, 10.0, 0.5, 0.10, 1)
set_hudmessage(000, 100, 255, get_pcvar_float(cvar_announce_deadpos_x), get_pcvar_float(cvar_announce_deadpos_y), 0, 0.0, 10.0, 0.5, 0.10, 1) // show list at lower position for them so it is not covered by the "spectator bars"


Popróbuj sprawdzone lub różne (np W AMXX-Studio Hudmessage Generator) pozycje bo musi działać.
  • +
  • -
  • 1

#3 kasza

    Godlike

  • Autor tematu
  • Przyjaciel

Reputacja: 887
Czempion

  • Postów:4102
  • GG:
  • Steam:steam
  • Imię:Imię
  • Lokalizacja:Lokalizacja
Offline

Napisano 22.01.2010 18:20

Z tym że nie wyświetlał się hud to jakiś plugin to blokował...

Teraz jak już działa ustawilem :

redirect_announce_alivepos_x 0,0
redirect_announce_alivepos_y 0,9
redirect_announce_deadpos_x 0,0
redirect_announce_deadpos_y 0,9

W hud generatorze wart. 0.9 to jest tuż nad HP a mi dalej wyświeta wiad. na radarze. Dlaczego ?
  • +
  • -
  • 0

Skillownia.com

 

 #3 [UWC3NG] Skillownia.com - 213.189.52.253:27301

 


#4 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 22.01.2010 18:29

wpisz może lepiej:
redirect_announce_alivepos_x "0.0"
redirect_announce_alivepos_y "0.9"
redirect_announce_deadpos_x "0.0"
redirect_announce_deadpos_y "0.9"

A co do generatora to nie można całkiem się na nim opierać. Skoro to tylko cvar to możesz testować w grze bez modyfikacji kodu.
  • +
  • -
  • 0

#5 kasza

    Godlike

  • Autor tematu
  • Przyjaciel

Reputacja: 887
Czempion

  • Postów:4102
  • GG:
  • Steam:steam
  • Imię:Imię
  • Lokalizacja:Lokalizacja
Offline

Napisano 23.01.2010 02:52

Pav i za każdym razem jak zmieniałem cvary w grze, to nawet po minimalnej zmianie to się hud nie pojawiał...
Potestuje jeszcze i napisze.

Ok wszystko działa. Na #2 okazalo sie ze mialem za ip serwa dodane tab i nie wczytywalo serwa. Zmieniłem i od razu śmiga.

Użytkownik kasza edytował ten post 22.01.2010 18:47

  • +
  • -
  • 0

Skillownia.com

 

 #3 [UWC3NG] Skillownia.com - 213.189.52.253:27301

 


#6 Adminek AMXX.PL

    Admin :)

  • Bot

Reputacja: 156
Profesjonalista

  • Postów:7178
  • Lokalizacja:AMXX.PL
Offline

Napisano 24.01.2010 12:54

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Problem rozwiązany

Jeśli się z tym nie zgadzasz, Dołączona grafika raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych