Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

get_user_attackproblem


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 c1rca

    Wszechwidzący

  • Użytkownik

Reputacja: 13
Początkujący

  • Postów:227
  • GG:
  • Steam:steam
  • Lokalizacja:Częstochowa
Offline

Napisano 19.01.2010 15:20

Witajcie, mam problem z DiabloModem - a dokładnie z błędem który wysypuje się w logach odnośnie tego :

Kod:
L 01/18/2010 - 19:45:57: [AMXX]    [0] dbmod_5.8d.sma::Damage1 (line 6974)
L 01/18/2010 - 19:47:59: Invalid player id 0
L 01/18/2010 - 19:47:59: [AMXX] Displaying debug trace (plugin "dbmod_5.8d.amxx")
L 01/18/2010 - 19:47:59: [AMXX] Run time error 10: native error (native "get_user_attacker")

sma w załączniku..
Jest to uciążliwe ponieważ, serwer mi crashuje i wyłącza przez to..

Użytkownik c1rca edytował ten post 19.01.2010 17:12

  • +
  • -
  • 0

#2 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 19.01.2010 15:37

Zamień (linijka 6974):
	attacker = get_user_attacker(id)

na:
	if (is_user_connected(id))
attacker = get_user_attacker(id)


I skompiluj ponownie.
  • +
  • -
  • 1

#3 c1rca

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 13
Początkujący

  • Postów:227
  • GG:
  • Steam:steam
  • Lokalizacja:Częstochowa
Offline

Napisano 19.01.2010 15:53

Oki, nie zamykaj, potem dam znać czy się coś zmieniło ;)

#Edit
Jesteś kochany Pav, BŁĘDÓW JUŻ nie ma - zobaczmy jak z crashami i wyłączeniami się serwera...

Użytkownik c1rca edytował ten post 19.01.2010 17:13

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych