Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[pomoc!] stawianie serwera na ssh


  • Zamknięty Temat jest zamknięty
20 odpowiedzi w tym temacie

#1 Repo

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:Kraków
Offline

Napisano 02.01.2010 01:12

Cześć, dostałem dzisiaj serwer dedykowany, na którym już stoi jeden serwer CS 1.6, z tym że ja jakoś mam problemy z postawieniem serwera.
Serwer stoi na linuxie i łącze się przez shh przez putty, i prosiłbym kogoś i wytłumaczenie jak takowy postawić, na linuxie jeszcze nigdy nie stawiałem i mam z tym problemy ;)
Pozdrawiam,
Repo.
  • +
  • -
  • 0

#2 kasza

    Godlike

  • Przyjaciel

Reputacja: 887
Czempion

  • Postów:4102
  • GG:
  • Steam:steam
  • Imię:Imię
  • Lokalizacja:Lokalizacja
Offline

Napisano 02.01.2010 02:07

Let me google that for you
  • +
  • -
  • 0

Skillownia.com

 

 #3 [UWC3NG] Skillownia.com - 213.189.52.253:27301

 


#3 honey

    Wszechmogący

  • Zbanowany

Reputacja: 124
Zaawansowany

  • Postów:606
  • Steam:steam
  • Lokalizacja:n / a
Offline

Napisano 02.01.2010 02:39

GameCP - Game Hosting Control Panel | Game Server Control Panel - Taki panelik też Ci się może przydać :)

#4 Batonik

    Wszechpomocny

  • Użytkownik

Reputacja: 27
Życzliwy

  • Postów:372
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnobrzeg
Offline

Napisano 02.01.2010 09:09

Jeżeli byś nie znalazł ^^

Tutaj prosto wytłumaczone ( tak myślę :P )
  • +
  • -
  • 1

#5 Repo

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:Kraków
Offline

Napisano 02.01.2010 14:14

Dzięki wszystkim, w sumie znalazłem już kilka poradników i dzięki jednemu na tym forum doszedłem daleko, ale przy uruchamianiu serwera komendą:
screen ./hlds_run -game cstrike -master -insecure -pingboots 1 +port 27015 +maxplayers 22 +map de_dust2 +exec server.cfg +sv_lan 1
wyskakuje mi coś takiego:
Auto detecting CPU
Using AMD Optimised binary.
Auto-restarting the server on crash
Error:libSteamValidateUserIDTickets_i386.so: cannot open shared object file: No such file or directory
Unable to load engine, image is corrupt.

  • +
  • -
  • 0

#6 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 02.01.2010 16:14

Error:libSteamValidateUserIDTickets_i386.so: cannot open shared object file: No such file or directory

Tak trudno przetłumaczyć? Brakuje pliku.

Wydaj jeszcze raz polecenie:
./steam -command update -game cstrike -dir katalog_z_serwerem -verify_all -retry


  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#7 Repo

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:Kraków
Offline

Napisano 02.01.2010 22:19

Teraz mam kolejny problem, nie mam dostępu do roota, a muszę zainstalować screena, jest może jakiś odpowiednik, dzięki któremu serwer będzie chodził po zamknięciu konsoli ?
  • +
  • -
  • 0

#8 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 03.01.2010 11:02

a komenda su lub sudo ? To też nie przejdzie ?
dodatkowo możesz próbować coś z kodu źródłowego zrobić

A najlepiej to zgłoś się do administratora serwera bo to trochę dziwne że screen'a tam nie ma.
  • +
  • -
  • 0

#9 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 03.01.2010 12:08

A najlepiej to zgłoś się do administratora serwera bo to trochę dziwne że screen'a tam nie ma.

Czysty os. ostatnio dostałem debiana bez żadnych repo, czysty system.

sudo apt-get install screen / sudo yum install screen i musi działać.
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#10 Repo

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:Kraków
Offline

Napisano 03.01.2010 14:16

Odpowiedź admina po mojej prośbie, żeby zainstalował screena:
Po pierwsze to apt-get to manager pakietów Debiana a tu jest gentoo <img src='http://amxx.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' />

2 sprawa screen tam jest i zawsze byl <img src='http://amxx.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' />
Czyli już wiem że tam jest gentoo i screen, jakieś porady? ;P
  • +
  • -
  • 0

#11 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 03.01.2010 14:18

muszę zainstalować screena, jest może jakiś odpowiednik, dzięki któremu serwer będzie chodził po zamknięciu konsoli

screen tam jest i zawsze byl ;)


Skoro jest screen to w czym problem ?
  • +
  • -
  • 0

#12 Repo

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:Kraków
Offline

Napisano 03.01.2010 14:21

W tym, że nie wiem jak odpalić screena ;) chodzi mi o to, żeby po wyłączenia konsoli serwer chodził.
2 Sprawa, jakie porty mogę wybierać? Bo standardowy 27015 jest zajęty
  • +
  • -
  • 0

#13 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 03.01.2010 14:27

Ja robiłem np plik START a w nim:
#!/bin/sh
export LD_LIBRARY_PATH=".:$LD_LIBRARY_PATH"
echo "Starting HLDS"
sleep 1
screen -A -m -d -S nazwa_sesji ./hlds_run -autoupdate -console -game cstrike +port ***PORT*** +ip ***IP*** +maxplayers ***LICZBAGRACZY*** +map de_dust2 +rcon_password "***RCON***" +exec server.cfg

  • +
  • -
  • 0

#14 Repo

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:Kraków
Offline

Napisano 03.01.2010 15:03

Sorki, ale nie rozumiem dużo z tego kodu, mógłbyś mi opisać co muszę zrobić?
Korzystam z tego poradnika KLIK i skoro robię na gentoo to robię wszystko wg. tego poradnika? Czy coś inaczej?
  • +
  • -
  • 0

#15 Repo

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:Kraków
Offline

Napisano 05.01.2010 13:58

Ok, serwer niby stoi, ale mam pytania:
1. Jak mam odpalić serwer ze screenem na Gentoo?
2. Jak mam sprawdzić jaki jest wolny port?
3. Jak później sprawdzić czy serwer chodzi prawidłowo?
4. Jak go zabezpieczyć?
5. Jak zrobić serwer mix (czyli że chodzi na Steam i NS)
Sorki za taką ilość pytań ;P

/PS. sorki za post pod postem ;)
  • +
  • -
  • 0

#16 piwko

    Zaawansowany

  • Użytkownik

Reputacja: 6
Nowy

  • Postów:105
  • Lokalizacja:Radymno
Offline

Napisano 05.01.2010 20:17

2. metoda prob? sprawdzaj jaki ci pasuje port ;)
3. wgraj amx i sprawdz logi ;)
5. wgraj dproto
  • +
  • -
  • 1

#17 Repo

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:Kraków
Offline

Napisano 07.01.2010 22:03

Ok, serwer już elegancko stoi, lecz ten dproto nie działa niestety ;)
Nie ma może innego sposobu, żeby działało pod steam i nonsteam? Oczywiście NS na protokole 47 i 48 ;)
  • +
  • -
  • 0

#18 csMisieK

    Zaawansowany

  • Użytkownik

Reputacja: 8
Nowy

  • Postów:85
  • Lokalizacja:Tomaszów
Offline

Napisano 11.01.2010 16:32

Only dproto
  • +
  • -
  • 0

#19 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 12.01.2010 21:26

Only dproto

and binnarki które gdzieś zaginęły.

Co do problemu to AMD/INTEL? W tym pierwszym do parametrów startowych trzeba dopisać -binary ./hlds_i686

screen -A -m -d -S nazwa_sesji ./hlds_run -autoupdate -binary ./hlds_i686 -console -game cstrike +port ***PORT*** +ip ***IP*** +maxplayers ***LICZBAGRACZY*** +map de_dust2 +rcon_password "***RCON***" +exec server.cfg

  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#20 Repo

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:Kraków
Offline

Napisano 18.01.2010 19:01

juz chodzi, musiałem VAC wyłączyć ;)
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych