Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem Z Sql


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 stream

    Profesjonalista

  • Użytkownik

Reputacja: 20
Życzliwy

  • Postów:196
  • Lokalizacja:Kielce
Offline

Napisano 28.12.2009 14:14

Hej,

diablo_sql_host "cs-bachu.xaa.pl"
diablo_sql_user "blaba******"
diablo_sql_pass "hasło!"
diablo_sql_database "blaba******"
diablo_sql_table "dbmod_tablet"
diablo_sql_save "0"

L 12/28/2009 - 14:08:25: Error on Table query: Access denied for user '***********'@'91.204.162.140' to database '***************'
L 12/28/2009 - 14:08:25: Could not connect to SQL database.

Połączenie zewnętrzne do MySQL dodałem żeby mogło się łączyć.

Pomóżcie!

Pozdrawiam!
  • +
  • -
  • 0

#2 Radeon

    Profesjonalista

  • Zbanowany

Reputacja: 9
Nowy

  • Postów:166
  • Lokalizacja:US?
Offline

Napisano 28.12.2009 21:28

dodaj serwer w zezwoleniach dostępu zwnętrznego MYSQL lub po prostu %

#3 Batonik

    Wszechpomocny

  • Użytkownik

Reputacja: 27
Życzliwy

  • Postów:372
  • GG:
  • Steam:steam
  • Lokalizacja:Tarnobrzeg
Online

Napisano 29.12.2009 11:08

Może zacytuje częste pytanie na proserwer.pl:

Na mojej stronie pojawia się komunikat "access denied for user ..." ?

Nie oznacza to, jak niektórzy uważają, że baza danych nie działa. Jest to komunikat informujący, że owszem baza działa ale nie można się do niej połączyć gdyż podawane są złe parametry dostępu. Przykładem może być zła nazwa użytkownika bazy, złe hasło do użytkownika bazy, zła nazwa bazy danych, brak dodania użytkownika bazy danych do tejże bazy (w cpanelu). Jeżeli wcześniej wszystko działało a komunikat pojawił się w pewnym momencie i cały czas występuje, zastanów się czy nie zmieniłeś parametrów do bazy (np. hasła) w skrypcie albo w cpanelu. Wystarczy "niewinne" nadpisanie plików przez ftp np. starym plikiem konfiguracyjnym. Pamiętaj, że zmieniając parametry w jednym z tych miejsc, trzeba zaktulizować je i w drugim. Zdarza się, że inna osoba mająca dostęp do konta zmieniła hasło albo co gorsza osoba niepowołana. W przypadku skryptu, wystarczy wyedytować odpowiedni plik konfiguracyjny. W przypadku bazy, należy usunąć użytkownika bazy danych (ale nie bazę bo stracisz dane) a następnie stworzyć go ponownie z nowym hasłem i dodać do bazy danych. Użytkownik powinien mieć odpowiednie przywileje (najlepiej zaznaczyć wszystkie).


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych