Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

błąd


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 Paldziu

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:42
  • Lokalizacja:z Przedszkola
Offline

Napisano 19.12.2009 13:35

// Custom player models
	for (i = 0; i < ArraySize(model_human); i++)
	{
		ArrayGetString(model_human, i, buffer, charsmax(buffer))
		format(buffer, charsmax(buffer), "models/player/%s/%s.mdl", buffer, buffer)
		ArrayPushCell(g_modelindex_human, engfunc(EngFunc_PrecacheModel, buffer))
		if (g_force_consistency == 1) force_unmodified(force_model_samebounds, {0,0,0}, {0,0,0}, buffer)
		if (g_force_consistency == 2) force_unmodified(force_exactfile, {0,0,0}, {0,0,0}, buffer)
	}
	for (i = 0; i < ArraySize(model_nemesis); i++)
	{
		ArrayGetString(model_nemesis, i, buffer, charsmax(buffer))
		format(buffer, charsmax(buffer), "models/player/%s/%s.mdl", buffer, buffer)
		ArrayPushCell(g_modelindex_nemesis, engfunc(EngFunc_PrecacheModel, buffer))
		if (g_force_consistency == 1) force_unmodified(force_model_samebounds, {0,0,0}, {0,0,0}, buffer)
		if (g_force_consistency == 2) force_unmodified(force_exactfile, {0,0,0}, {0,0,0}, buffer)
	}
	for (i = 0; i < ArraySize(model_survivor); i++)
	{
		ArrayGetString(model_survivor, i, buffer, charsmax(buffer))
		format(buffer, charsmax(buffer), "models/player/%s/%s.mdl", buffer, buffer)
		ArrayPushCell(g_modelindex_survivor, engfunc(EngFunc_PrecacheModel, buffer))
		if (g_force_consistency == 1) force_unmodified(force_model_samebounds, {0,0,0}, {0,0,0}, buffer)
		if (g_force_consistency == 2) force_unmodified(force_exactfile, {0,0,0}, {0,0,0}, buffer)
	}
	for (i = 0; i < ArraySize(model_admin_zombie); i++)
	{
		ArrayGetString(model_admin_zombie, i, buffer, charsmax(buffer))
		format(buffer, charsmax(buffer), "models/player/%s/%s.mdl", buffer, buffer)
		ArrayPushCell(g_modelindex_admin_zombie, engfunc(EngFunc_PrecacheModel, buffer))
		if (g_force_consistency == 1) force_unmodified(force_model_samebounds, {0,0,0}, {0,0,0}, buffer)
		if (g_force_consistency == 2) force_unmodified(force_exactfile, {0,0,0}, {0,0,0}, buffer)
	}
	for (i = 0; i < ArraySize(model_admin_human); i++)
	{
		ArrayGetString(model_admin_human, i, buffer, charsmax(buffer))
		format(buffer, charsmax(buffer), "models/player/%s/%s.mdl", buffer, buffer)
		ArrayPushCell(g_modelindex_admin_human, engfunc(EngFunc_PrecacheModel, buffer))
		if (g_force_consistency == 1) force_unmodified(force_model_samebounds, {0,0,0}, {0,0,0}, buffer)
		if (g_force_consistency == 2) force_unmodified(force_exactfile, {0,0,0}, {0,0,0}, buffer)
	}
	
	// Load up the hard coded extra items
	native_register_extra_item2("NightVision", g_extra_costs2[EXTRA_NVISION], ZP_TEAM_HUMAN)
	native_register_extra_item2("T-Virus Antidote", g_extra_costs2[EXTRA_ANTIDOTE], ZP_TEAM_ZOMBIE)
	native_register_extra_item2("Zombie Madness", g_extra_costs2[EXTRA_MADNESS], ZP_TEAM_ZOMBIE)
	native_register_extra_item2("Infection Bomb", g_extra_costs2[EXTRA_INFBOMB], ZP_TEAM_ZOMBIE)

tu mam gdzieś błąd, wywala mi error
  • +
  • -
  • 0

#2 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 19.12.2009 13:52

Podaj blad z kompilatora, nikt nie bedzie zgadywac :zly:
  • +
  • -
  • 0

#3 Paldziu

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:42
  • Lokalizacja:z Przedszkola
Offline

Napisano 19.12.2009 14:12

/groups/amxmodx/tmp3/textIjrRV5.sma(1060) : error 017: undefined symbol "i"
/groups/amxmodx/tmp3/textIjrRV5.sma(1060) : warning 205: redundant code: constant expression is zero
/groups/amxmodx/tmp3/textIjrRV5.sma(1060) : error 017: undefined symbol "i"
/groups/amxmodx/tmp3/textIjrRV5.sma(1060) : error 001: expected token: ")", but found ";"
/groups/amxmodx/tmp3/textIjrRV5.sma(1060) : fatal error 107: too many error messages on one line


for (i = 0; i < ArraySize(model_human); i++) to 1060

na webcompilatorze jest to samo co na lokalnym
  • +
  • -
  • 0

#4 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 19.12.2009 15:05

Przed // Custom player models
daj
new i

wypada deklarowac zmienne co uzywasz ;>
  • +
  • -
  • 0

#5 Paldziu

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:42
  • Lokalizacja:z Przedszkola
Offline

Napisano 19.12.2009 18:02

to wtedy wywala mi błąd
/groups/amxmodx/tmp3/texth0FDX0.sma(1063) : error 017: undefined symbol "buffer"
/groups/amxmodx/tmp3/texth0FDX0.sma(1063) : error 072: "sizeof" operator is invalid on "function" symbols
/groups/amxmodx/tmp3/texth0FDX0.sma(1063) : error 029: invalid expression, assumed zero
/groups/amxmodx/tmp3/texth0FDX0.sma(1063) : fatal error 107: too many error messages on one line

ale dodałem new buffer, co mi daje

/groups/amxmodx/tmp3/textMibQOY.sma(1064) : error 035: argument type mismatch (argument 3)
/groups/amxmodx/tmp3/textMibQOY.sma(1064) : error 035: argument type mismatch (argument 3)
/groups/amxmodx/tmp3/textMibQOY.sma(1065) : error 035: argument type mismatch (argument 1)
/groups/amxmodx/tmp3/textMibQOY.sma(1065) : error 035: argument type mismatch (argument 1)
/groups/amxmodx/tmp3/textMibQOY.sma(1067) : error 035: argument type mismatch (argument 4)
/groups/amxmodx/tmp3/textMibQOY.sma(1068) : error 035: argument type mismatch (argument 4)
/groups/amxmodx/tmp3/textMibQOY.sma(1072) : error 035: argument type mismatch (argument 3)
/groups/amxmodx/tmp3/textMibQOY.sma(1072) : error 035: argument type mismatch (argument 3)
/groups/amxmodx/tmp3/textMibQOY.sma(1073) : error 035: argument type mismatch (argument 1)
/groups/amxmodx/tmp3/textMibQOY.sma(1073) : error 035: argument type mismatch (argument 1)
/groups/amxmodx/tmp3/textMibQOY.sma(1075) : error 035: argument type mismatch (argument 4)
/groups/amxmodx/tmp3/textMibQOY.sma(1076) : error 035: argument type mismatch (argument 4)
/groups/amxmodx/tmp3/textMibQOY.sma(1080) : error 035: argument type mismatch (argument 3)
/groups/amxmodx/tmp3/textMibQOY.sma(1080) : error 035: argument type mismatch (argument 3)
/groups/amxmodx/tmp3/textMibQOY.sma(1081) : error 035: argument type mismatch (argument 1)
/groups/amxmodx/tmp3/textMibQOY.sma(1081) : error 035: argument type mismatch (argument 1)
/groups/amxmodx/tmp3/textMibQOY.sma(1083) : error 035: argument type mismatch (argument 4)
/groups/amxmodx/tmp3/textMibQOY.sma(1084) : error 035: argument type mismatch (argument 4)
/groups/amxmodx/tmp3/textMibQOY.sma(1088) : error 035: argument type mismatch (argument 3)
/groups/amxmodx/tmp3/textMibQOY.sma(1088) : error 035: argument type mismatch (argument 3)
/groups/amxmodx/tmp3/textMibQOY.sma(1089) : error 035: argument type mismatch (argument 1)
/groups/amxmodx/tmp3/textMibQOY.sma(1089) : error 035: argument type mismatch (argument 1)
/groups/amxmodx/tmp3/textMibQOY.sma(1091) : error 035: argument type mismatch (argument 4)
/groups/amxmodx/tmp3/textMibQOY.sma(1092) : error 035: argument type mismatch (argument 4)
/groups/amxmodx/tmp3/textMibQOY.sma(1096) : error 035: argument type mismatch (argument 3)
/groups/amxmodx/tmp3/textMibQOY.sma(1096) : error 035: argument type mismatch (argument 3)

  • +
  • -
  • 0

#6 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 19.12.2009 18:21

Paldziu, przerabiales to sam?
  • +
  • -
  • 0

#7 Paldziu

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:42
  • Lokalizacja:z Przedszkola
Offline

Napisano 19.12.2009 18:24

hmm zm'a przerabiam 4.3, ale tego nie ruszałem(a pomimo tego mam errory)

~Mi$ jak to zobaczył mało się nie załamał - są errory a powodów brak

jak to naprawisz to będziesz moim guru :P
  • +
  • -
  • 0

#8 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 19.12.2009 18:26

Sprawdz czy nie skopales gdzies klamry czy nawiasu (zapewne niewiele nad 1060 lina) i moze to ci wszystko psuje, bo tak to nigdy nie zadziala...
  • +
  • -
  • 0

#9 Paldziu

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:42
  • Lokalizacja:z Przedszkola
Offline

Napisano 19.12.2009 18:28

klamry są zamknięte(używam notepad++)
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych