Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z zabiciem gracza.


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 Owner123

    Wszechpomocny

  • Użytkownik

Reputacja: 144
Zaawansowany

  • Postów:331
  • Lokalizacja:Barty ;]
Offline

Napisano 14.12.2009 19:20

Zrobiłem item do mojego moda aby była 1/x szansa na natychmiastowe zabicie z dowolnej broni.
Zrobiłem coś takiego:
public AddWpnBonus(id)
{
	new kid = get_user_attacker(id)
	new weapon[32]
	get_weaponname(id, weapon, 31)
	if(g_hasdmg[kid] == true)
	{
		new rannum = (1, g_dmgbonus)
		if(rannum == 1 && get_user_team(kid) != get_user_team(id))
		{
			UTIL_Kill(kid, id, weapon)
		}
		return PLUGIN_CONTINUE
	}
	return PLUGIN_CONTINUE
}
Lecz tu pojawia się problem. Gdy gościa zabiłem funkcją UTIL_Kill zamiast mojej broni pokazuje się znak samobójstwa a w konsoli pisze: "Igrek killed Iks with (i tu pusto)". Niewiem czy robić ify, z deczka nie warto, do każdej broni bo to jest bezsensu.
Proszę o radę bądź wskazówkę jak to zrobić.
  • +
  • -
  • 0

#2 Snejk47

    Zaawansowany

  • Zbanowany

Reputacja: -1
Mniej niż zer0.

  • Postów:78
  • GG:
  • Imię:Snejk
  • Lokalizacja:Bytom
Offline

Napisano 15.12.2009 20:43

Może switche? Chyba inaczej się nie da.

#3 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 15.12.2009 21:03

get_weaponname(id, weapon, 31)

Zle parametry funkcji, zamiast id (gracz) ma byc wid - nr. identyfikujacy bron...

Sprawdz to:
get_weaponname(get_user_weapon( id), weapon, 31)

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych