Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Roundsound


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 .matej

    Początkujący

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:10
Offline

Napisano 13.07.2008 13:13

Witam, dzis wgralem roundsound, dzwieki w jakosci mp3 , wrzucilem pliki 1,2,3 itd .mp3 na serwer, skompilowalem plik .sma ale nie pobiera ani nie odtwarza dzwięków dlaczego?
  • +
  • -
  • 0

#2 Gość__*

  • Gość

Reputacja: 0

Offline

Napisano 13.07.2008 13:19

.matej, pokaż *.sma i opisz co jak zrobiłeś.

#3 .matej

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:10
Offline

Napisano 13.07.2008 13:34

#include <amxmodx>

public plugin_init()
{
register_plugin(RoundSound,1.0,D4v!d3k a Webspider)
register_event(SendAudio, t_win, a, 2&%!MRAD_terwin)
register_event(SendAudio, ct_win, a, 2&%!MRAD_ctwin)
}

public t_win()
{
new rand = random_num(0,3)

client_cmd(0,stopsound)

switch(rand)
{
case 0: client_cmd(0,spk misc/16)
case 1: client_cmd(0,spk misc/21)
case 2: client_cmd(0,spk misc/1)
case 3: client_cmd(0,spk misc/2)
case 4: client_cmd(0,spk misc/9)
case 5: client_cmd(0,spk misc/12)
case 6: client_cmd(0,spk misc/13)
case 7: client_cmd(0,spk misc/14)
case 8: client_cmd(0,spk misc/10)
case 9: client_cmd(0,spk misc/23)
case 10: client_cmd(0,spk misc/22)
case 11: client_cmd(0,spk misc/26)
case 12: client_cmd(0,spk misc/40)
case 13: client_cmd(0,spk misc/51)
case 14: client_cmd(0,spk misc/49)
case 16: client_cmd(0,spk misc/26)
}

return PLUGIN_CONTINUE
}

public ct_win()
{
new rand = random_num(0,3)

client_cmd(0,stopsound)

switch(rand)
{
case 0: client_cmd(0,spk misc/48)
case 1: client_cmd(0,spk misc/19)
case 2: client_cmd(0,spk misc/47)
case 3: client_cmd(0,spk misc/44)
case 4: client_cmd(0,spk misc/42)
case 5: client_cmd(0,spk misc/37)
case 6: client_cmd(0,spk misc/35)
case 7: client_cmd(0,spk misc/33)
case 8: client_cmd(0,spk misc/32)
case 9: client_cmd(0,spk misc/28)
case 10: client_cmd(0,spk misc/27)
case 11: client_cmd(0,spk misc/24)
case 12: client_cmd(0,spk misc/17)
case 13: client_cmd(0,spk misc/19)
case 14: client_cmd(0,spk misc/4)
case 15: client_cmd(0,spk misc/6)
case 16: client_cmd(0,spk misc/7)

}

return PLUGIN_CONTINUE
}

public plugin_precache()
{
precache_sound(misc/1.wav)
precache_sound(misc/2.wav)
precache_sound(misc/4.wav)
precache_sound(misc/6.wav)
precache_sound(misc/7.wav)
precache_sound(misc/9.wav)
precache_sound(misc/10.wav)
precache_sound(misc/12.wav)
precache_sound(misc/13.wav)
precache_sound(misc/14.wav)
precache_sound(misc/15.wav)
precache_sound(misc/16.wav)
precache_sound(misc/17.wav)
precache_sound(misc/19.wav)
precache_sound(misc/20.wav)
precache_sound(misc/21.wav)
precache_sound(misc/22.wav)
precache_sound(misc/24.wav)
precache_sound(misc/26.wav)
precache_sound(misc/27.wav)
precache_sound(misc/28.wav)
precache_sound(misc/32.wav)
precache_sound(misc/33.wav)
precache_sound(misc/35.wav)
precache_sound(misc/37.wav)
precache_sound(misc/40.wav)
precache_sound(misc/42.wav)
precache_sound(misc/44.wav)
precache_sound(misc/47.wav)
precache_sound(misc/48.wav)
precache_sound(misc/49.wav)
precache_sound(misc/51.wav)

return PLUGIN_CONTINUE
}
moge nawet wrzucic paczke piosenek gdy bedzie potrzebna gdy wklejam w webcompiler wyskakuje że są 4 błędy


a jak jest koniec rundy to takie cos :
Dołączona grafika
  • +
  • -
  • 0

#4 Kali

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
Offline

Napisano 13.07.2008 15:41

Ja mam cos podobnego ... muzyke mam na serwie ja ją słysze ale jezeli ktos jej na kompie nie ma to jej nie ma bo sciagnac nie moze ich :S poprostu wchodzi na serwer i nic mu sie nie sciaga a mimo to ma cl_allowdownload 1
  • +
  • -
  • 0

#5 .matej

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:10
Offline

Napisano 13.07.2008 16:24

teraz wgram alt_end_round_sound i blad jest pokazany na tamtym screenie ???:( ???:(

[ Dodano: 14-07-2008, 20:32 ]
odświeżam
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych