Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

zp_antidote - problem


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 honey

    Wszechmogący

  • Zbanowany

Reputacja: 124
Zaawansowany

  • Postów:606
  • Steam:steam
  • Lokalizacja:n / a
Offline

Napisano 06.12.2009 17:51

Witam, mam problem dot. pewnego pluginu, a dokładnie temu: zp_antidotum (.sma w załączniku).
Od pewnego czasu przez ten plugin, crashuje mi się serwer patrząc w logi widzę:

L 12/06/2009 - 00:47:52: [FAKEMETA] Invalid entity
L 12/06/2009 - 00:47:52: [AMXX] Displaying debug trace (plugin "zp_antidote.amxx")
L 12/06/2009 - 00:47:52: [AMXX] Run time error 10: native error (native "pev")
L 12/06/2009 - 00:47:52: [AMXX]    [0] zp_antidote.sma::fw_ThinkGrenade (line 83)

I nie wiem przez co jest to spowodowane. Wszystkie potrzebne moduły mam włączone, amx najnowszy. Jeśli ktoś mi zdoła pomóc daje + :

Załączone pliki



#2 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 06.12.2009 17:54

spróbuj
if(!pev_valid(entity))
zamienić na
if(pev_valid(entity) < 2)

  • +
  • -
  • 0

#3 honey

    Wszechmogący

  • Autor tematu
  • Zbanowany

Reputacja: 124
Zaawansowany

  • Postów:606
  • Steam:steam
  • Lokalizacja:n / a
Offline

Napisano 06.12.2009 17:59

Zmieniłem zobaczymy teraz, mam nadzieję że działa :)
Jak zadziała edytuję i dam pomógł :)

#4 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 06.12.2009 18:01

L 12/06/2009 - 00:47:52: [AMXX] Run time error 10: native error (native "pev")
L 12/06/2009 - 00:47:52: [AMXX] [0] zp_antidote.sma::fw_ThinkGrenade (line 83)


Coś tu się nie zgadza. Błąd wskazuje na linijkę 83 a funkcja w której jest błąd jest w linijcę 86.
Czyli tak jakby nie było:
if(!pev_valid(entity))
		return HAM_IGNORED

Skompiluj ten kod co masz ponownie i sprawdź wtedy.
  • +
  • -
  • 0

#5 honey

    Wszechmogący

  • Autor tematu
  • Zbanowany

Reputacja: 124
Zaawansowany

  • Postów:606
  • Steam:steam
  • Lokalizacja:n / a
Offline

Napisano 06.12.2009 19:46

Ok działa R3X dzięki ;)
Można close ;)




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych