Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z mapami na serwerze


  • Zamknięty Temat jest zamknięty
13 odpowiedzi w tym temacie

#1 Adi

    Pomocny

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:64
Offline

Napisano 01.11.2009 03:02

Witam.
Mam problem dotyczący map na serwerze.
Kiedy ktoś nie ma mapy i wchodzi na serwer, ta mapa mu się ściąga, a kiedy się już ściągnęła wyskakuje w konsoli:

Map [maps/de_dust2_1337.bsp] has incorrect BSP version (1297369148 should be 30).
Host_Error: Disconnect

Można to ominąć tak:
Kiedy ta mapa nam się ściągnie, będziemy mieli w folderze maps tą mapę, ale będzie ona miała tylko 2KB.
Kiedy ją usuniemy i na nowo wejdziemy na serwer, mapa nam się ściągnie w całości i będziemy mogli grać.

Wygląda to tak jakby za pierwszym razem ściągała się tylko część mapy, i wywala za to że nie jest cała,
a za drugim dopiero ściągała się całość.

Co jest nie tak ?
Mam publiczny, nowy serwer, który jest już bardzo grywalny i nie mogę sobie pozwolić na takie błędy,
więc proszę o jak najszybszą odpowiedź.

Napiszę to najkrócej jak się da:

Gdy na serwerze jest mapa, której nie mam i gdy ją ściągnę poprzez wejście na ten serwer mapa ściągnie się tylko w części.
Aby wejść na serwer muszę usunąć tą część mapy z folderu maps i ściągnąć na nowo.
Dopiero za drugim razem ściąga się poprawnie.

Z góry dzięki.
  • +
  • -
  • 0

#2 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 01.11.2009 09:03

Masz FastDL ? Może tam masz niepoprawne pliki ?
  • +
  • -
  • 0

#3 Adi

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:64
Offline

Napisano 03.11.2009 12:53

Tak, mam FastDL.
Ale gdzie mają być te niepoprawne pliki ?
  • +
  • -
  • 0

#4 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 03.11.2009 14:24

Ale gdzie mają być te niepoprawne pliki ?

na serwerze WWW (fastdl)
  • +
  • -
  • 0

#5 Adi

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:64
Offline

Napisano 03.11.2009 22:13

To chyba tyczy się ogólnie całego ściągania plików z serwera.

Wcześniej wgrałem rundę nożową podczas której nie działała tylko muzyczka i dźwięki.
Domyślam się że dlatego że się źle ściągały (nie w całości)

Wgrałem knife_mod i wyskakuje błąd z modelami noży.
Pewnie dlatego że się ściąga tylko część tych modeli.
(Mod_LoadBrushModel: models/knife-mod/v_butcher.mdl has wrong version number (1297369148 should be 30))

Tak samo jest z mapami.
Ściągają się tylko w części i nie można na nich grać.

Więc moje pytanie brzmi:
Czemu pliki z serwera nie ściągają się w całości ?
Jak to naprawić ?
  • +
  • -
  • 0

#6 kasza

    Godlike

  • Przyjaciel

Reputacja: 887
Czempion

  • Postów:4102
  • GG:
  • Steam:steam
  • Imię:Imię
  • Lokalizacja:Lokalizacja
Offline

Napisano 03.11.2009 22:38

Miałem taki sam problem. Gracze niech usuna pobrane "zle" pliki, a Ty wgraj je jeszcze raz na FDL (serwa chyba nie musisz-ja wgralem dla pewnosci)
  • +
  • -
  • 0

Skillownia.com

 

 #3 [UWC3NG] Skillownia.com - 213.189.52.253:27301

 


#7 Adi

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:64
Offline

Napisano 03.11.2009 22:47

Nie rozumiem.
Jak wgrać na FDL ?
Sry ale nie znam się na tym.
Nie chcę żeby gracze musieli coś ściągać albo usuwać.
Chcę żeby się od razu dobrze ściągało przy wejściu na serwer.
  • +
  • -
  • 0

#8 kasza

    Godlike

  • Przyjaciel

Reputacja: 887
Czempion

  • Postów:4102
  • GG:
  • Steam:steam
  • Imię:Imię
  • Lokalizacja:Lokalizacja
Offline

Napisano 03.11.2009 22:51

Wgraj jeszcze raz pliki na Fastdownload i serwa.
  • +
  • -
  • 0

Skillownia.com

 

 #3 [UWC3NG] Skillownia.com - 213.189.52.253:27301

 


#9 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 03.11.2009 22:52

Nie chcę żeby gracze musieli coś ściągać albo usuwać.

Jeżeli pobrali uszkodzone pliki to nic na to już nie poradzisz - muszą je usunąć i ściągnąć od nowa.
  • +
  • -
  • 0

#10 Adi

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:64
Offline

Napisano 03.11.2009 23:11

Dobra, ale załóżmy że nikt nic nie pobrał.
To i tak ten kto wejdzie pierwszy raz nie będzie mógł dobrze ściągnąć ;/
I będzie musiał usuwać ;x
  • +
  • -
  • 0

#11 kasza

    Godlike

  • Przyjaciel

Reputacja: 887
Czempion

  • Postów:4102
  • GG:
  • Steam:steam
  • Imię:Imię
  • Lokalizacja:Lokalizacja
Offline

Napisano 04.11.2009 15:00

No własnie bedzie mogl jak podmienisz modele/mapy/muza itp na FDL i Serwie.
Nierozumie Cie tylko czemu, zadajesz te pytania skoro uzyskales juz odp. co zrobic aby bylo dobrze. Zrob to, nie podziala-pisz dalej.
  • +
  • -
  • 0

Skillownia.com

 

 #3 [UWC3NG] Skillownia.com - 213.189.52.253:27301

 


#12 Adi

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:64
Offline

Napisano 05.11.2009 14:50

A mógłbyś wytłumaczyć po kolei jak usunąć tego Fast DL ?
Bo ja nigdy nie miałem z tym styczności, kolega to wgrywał.
  • +
  • -
  • 0

#13 kasza

    Godlike

  • Przyjaciel

Reputacja: 887
Czempion

  • Postów:4102
  • GG:
  • Steam:steam
  • Imię:Imię
  • Lokalizacja:Lokalizacja
Offline

Napisano 05.11.2009 22:31

Wszystkie pliki wrzucasz je poprostu jeszcze raz... Jak niewiesz niech kolega Ci zrobi O:)
  • +
  • -
  • 0

Skillownia.com

 

 #3 [UWC3NG] Skillownia.com - 213.189.52.253:27301

 


#14 GwynBleidD

    Godlike

  • Administrator

Reputacja: 1849
Godlike

  • Postów:3066
  • Steam:steam
  • Lokalizacja:Przemyśl
Offline

Napisano 06.11.2009 14:34

Problem koledze rozwiązałem, okazało się, że w server.cfg zostały jakieś pozostałości po starym FastDL, który już nie istnieje i ściągał się zamiast plików komunikat błędu z hostingu. Wystarczyło skasować drugi wpis fastDL i śmiga.

Napisałem tak jakby ktoś miał podobny problem, bo sam się z tym troszkę głowiłem.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych