Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Szukam Pluginu


  • Zamknięty Temat jest zamknięty
10 odpowiedzi w tym temacie

#1 Raketen

    Pomocny

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:41
  • Lokalizacja:Stargard Szczeciński
Offline

Napisano 29.10.2009 15:48

Witam, Szukam pluginu, który będzie mi blokował komende na diablo modzie przez pierwsze 4minuty. Chodzi mi o to, że jak ktoś wpisze klasa bądź /klasa to pojawi się napis "Nie możesz uruchomić klasy przez 4 minuty od startu mapy."
Dziękuję.
  • +
  • -
  • 0

#2 Rygiel12

    Profesjonalista

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:166
  • GG:
  • Lokalizacja:Katowice
Offline

Napisano 30.10.2009 11:21

jak dotychczas niema pluginu takiego , czyba ze masz diablo moda na sql . lub gdy ty bedziesz . na serwerze to wylaczaj db moda a potem go wlaczysz po ilus tam minutach

Pozdrawiam
mysle ze pomoglem

#3 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 30.10.2009 16:04

a może po prostu tak :)?
/* Plugin generated by AMXX-Studio */

#include <amxmodx>
#include <amxmisc>

#define PLUGIN "New Plug-In"
#define VERSION "1.0"
#define AUTHOR "Home"


public plugin_init() {
	register_plugin(PLUGIN, VERSION, AUTHOR)
	register_clcmd("/klasa","klasa").
}

public klasa(id){
	return PLUGIN_HANDLED
}

  • +
  • -
  • 0

#4 Raketen

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:41
  • Lokalizacja:Stargard Szczeciński
Offline

Napisano 30.10.2009 16:09

A gdzie tu jest po ilu minutach od startu mapy klasa i /klasa działa?
Tak mam Diablo MOD 5.9l SQL
  • +
  • -
  • 0

#5 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 30.10.2009 16:12

to może tak
/* Plugin generated by AMXX-Studio */ 

#include <amxmodx> 
#include <amxmisc> 

#define PLUGIN "New Plug-In" 
#define VERSION "1.0" 
#define AUTHOR "Home" 

new czas=0;

public plugin_init() { 
    register_plugin(PLUGIN, VERSION, AUTHOR) 
    register_clcmd("/klasa","klasa")
    set_task(180.0,"diablo_on",1);
} 

public diablo_on(){
	czas=1;
}

public klasa(id){
	if(czas == 0){
		 return PLUGIN_HANDLED
	}
}

  • +
  • -
  • 0

#6 Raketen

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:41
  • Lokalizacja:Stargard Szczeciński
Offline

Napisano 30.10.2009 16:27

Ale po wpisaniu miał się wyświetlać jeszcze napis "Nie możesz uruchomić klasy przez 4 minuty od startu mapy."
  • +
  • -
  • 0

#7 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 30.10.2009 16:39

/* Plugin generated by AMXX-Studio */ 



#include <amxmodx> 

#include <amxmisc> 



#define PLUGIN "New Plug-In" 

#define VERSION "1.0" 

#define AUTHOR "Home" 



new czas=0; 



public plugin_init() { 

    register_plugin(PLUGIN, VERSION, AUTHOR) 

    register_clcmd("/klasa","klasa") 

    set_task(240.0,"diablo_on",1); 

} 



public diablo_on(){ 

    czas=1; 

} 



public klasa(id){ 

    if(czas == 0){ 

    	set_hudmessage(0, 255, 0, -1.0, -1.0)

    	show_hudmessage(id, "Nie możesz uruchomić klasy przez 4 minuty od startu mapy")

        return PLUGIN_HANDLED 

    } 

}

  • +
  • -
  • 0

#8 Raketen

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:41
  • Lokalizacja:Stargard Szczeciński
Offline

Napisano 30.10.2009 16:42

A i mam pytanie co do czas=1 to 1 to jedna minuta tak?
  • +
  • -
  • 0

#9 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 30.10.2009 16:50

nie czas jest ustawiony w
set_task(240.0,"diablo_on",1);
240 sekund a zmienna czas określa czy można już używać komenda jeśli jest równa 0 to nie jeśli jest równa 1 to już można
  • +
  • -
  • 0

#10 Raketen

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:41
  • Lokalizacja:Stargard Szczeciński
Offline

Napisano 30.10.2009 16:55

Plugin nie działa na pewno wszystk dobrze zrobiłeś może jest jakiś błąd?
  • +
  • -
  • 0

#11 wizu

    Godlike

  • Przyjaciel

Reputacja: 224
Profesjonalista

  • Postów:1217
  • GG:
  • Lokalizacja:Sanok
Offline

Napisano 30.10.2009 16:59

Nie czasami
register_clcmd("say /klasa","klasa")
Dopisz go w plugins.ini nad diablo modem.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych