Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Połaczenie SQL


  • Zamknięty Temat jest zamknięty
7 odpowiedzi w tym temacie

#1 booyaka

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:4
  • Lokalizacja:bdg
Offline

Napisano 13.10.2009 13:59

witam,
próbuje napisać plugin, który wymaga połączenia z bazą danych, lecz nie wychodzi mi :/

mój kod
#include <amxmodx>
#include <amxmisc>
#include <sqlx>

#define PLUGIN	"booyaka test"
#define AUTHOR	"booyaka"
#define VERSION	"0.1"
#define szHost "86.***.***.***"
#define szUser "t*****"
#define szPass "******"
#define szDB "t*****"

new Handle:g_hTuple;
new Handle:query
new Handle:hConnection


public plugin_init() {
	new iError, szError[ 128 ];

	register_plugin(PLUGIN, VERSION, AUTHOR)
	register_clcmd("say", "HandleSay", 0, "N/A")

     	g_hTuple = SQL_MakeDbTuple( szHost, szUser, szPass, szDB );
	hConnection = SQL_Connect( g_hTuple, iError, szError, 127 );
	if( hConnection == Empty_Handle ) {
   	log_amx("nie dziala")
	}

}

public HandleSay(id) {
	new args[256]
	read_argv(1, args, 256)
	
	if(containi(args, "/karol")!=-1 || containi(args, "/ja")!=-1) {
		log_amx("komenda dziala")
		Handle:query = SQL_PrepareQuery(hConnection, "CREATE TABLE `dziala_amx`( nr LONG, dane CHAR)")
		SQL_Execute(query)
		SQL_FreeHandle(query)
		return PLUGIN_HANDLED
	}
	
}

konsola
L 10/13/2009 - 14:44:05: Info (map "de_corruption_cz") (file "addons/amxmodx/logs/error_20091013.log")
L 10/13/2009 - 14:44:05: [MySQL] Invalid database handle: 0
L 10/13/2009 - 14:44:05: [AMXX] Run time error 10 (plugin "2.amxx") (native "SQL_PrepareQuery") - debug not enabled!
L 10/13/2009 - 14:44:05: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 10/13/2009 - 14:44:07: [MySQL] Invalid database handle: 0
L 10/13/2009 - 14:44:07: [AMXX] Run time error 10 (plugin "2.amxx") (native "SQL_PrepareQuery") - debug not enabled!
L 10/13/2009 - 14:44:07: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 10/13/2009 - 14:46:14: Start of error session.
L 10/13/2009 - 14:46:14: Info (map "de_corruption_cz") (file "addons/amxmodx/logs/error_20091013.log")
L 10/13/2009 - 14:46:14: [MySQL] Invalid database handle: 0
L 10/13/2009 - 14:46:14: [AMXX] Displaying debug trace (plugin "2.amxx")
L 10/13/2009 - 14:46:14: [AMXX] Run time error 10: native error (native "SQL_PrepareQuery")
L 10/13/2009 - 14:46:14: [AMXX]    [0] 2.sma::HandleSay (line 39)

konsola 2
10/13/2009 - 14:51:51: -------- Mapchange to de_corruption_cz --------
L 10/13/2009 - 14:52:07: [2.amxx] nie dziala
L 10/13/2009 - 14:52:08: [admin.amxx] Login: "booyaka<1><VALVE_ID_LOOPBACK><>" became an admin (account "loopback") (access "bcdefghijklmnopqrstu") (address "loopback")
L 10/13/2009 - 14:52:14: [admin.amxx] Login: "booyaka<1><VALVE_ID_LOOPBACK><>" became an admin (account "loopback") (access "bcdefghijklmnopqrstu") (address "loopback")
L 10/13/2009 - 14:52:14: [amxbans.amxx] [AMXBANS] Nie zaladowano przyczyn banow z bazy danych. Satyczne przyczyny banowa zostaly zaladowane
L 10/13/2009 - 14:52:14: [amxbans.amxx] [AMXBANS] AMXBans 5.0 jest online
L 10/13/2009 - 14:52:41: [2.amxx]komenda dziala
dane w #define podaje NA PEWNO dobrze, nie wiem dlaczego to nie działa

proszę o pomoc
  • +
  • -
  • 0

#2 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 13.10.2009 14:19

Handle:query = SQL_PrepareQuery(hConnection, "CREATE TABLE `dziala_amx`(`nr` integer( 8 ),`dane` VARCHAR( 128 ) )

A przynajmniej daj debug przy testowaniu tego.
  • +
  • -
  • 0

#3 booyaka

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:4
  • Lokalizacja:bdg
Offline

Napisano 13.10.2009 15:25

bład kompilacji

/groups/amxmodx/tmp3/textkIxR1C.sma(37) : error 037: invalid string (possibly non-terminated string)

btw nie wydaje mi się aby to właśnie ta część wywoływała ten błąd, jak wywołuje to co miałem w SQL to tworzy tabele bez problemu.
  • +
  • -
  • 0

#4 MaTusz

    Zaawansowany

  • Użytkownik

Reputacja: 32
Życzliwy

  • Postów:91
  • GG:
  • Lokalizacja:Stargard Szczeciński
Offline

Napisano 13.10.2009 15:26

bład kompilacji

/groups/amxmodx/tmp3/textkIxR1C.sma(37) : error 037: invalid string (possibly non-terminated string)


spróbuj lokalnie http://amxx.pl/topic...lna-vt12467.htm
  • +
  • -
  • 0

#5 booyaka

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:4
  • Lokalizacja:bdg
Offline

Napisano 13.10.2009 15:29

niestety identyczny błąd
  • +
  • -
  • 0

#6 naven

    Hero

  • Power User

Reputacja: 200
Profesjonalista

  • Postów:1088
  • GG:
  • Imię:Adam
  • Lokalizacja:Cieszyn
Offline

Napisano 13.10.2009 16:52

Handle:query = SQL_PrepareQuery(hConnection, "CREATE TABLE `dziala_amx`(`nr` integer( 8 ),`dane` VARCHAR( 128 ) ")

  • +
  • -
  • 0

#7 booyaka

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:4
  • Lokalizacja:bdg
Offline

Napisano 13.10.2009 17:31

Handle:query = SQL_PrepareQuery(hConnection, "CREATE TABLE `dziala_amx`(`nr` integer( 8 ),`dane` VARCHAR( 128 ) ")


z tym jest tak samo,
te same błdey w konsoli,

wydaje mi sie ze on sie w ogole nie może połączyć z baza danych, skoro wywala w konsoli

if( hConnection == Empty_Handle ) {
       log_amx("nie dziala")
    }
dane na pewno podaje dobrze, dostęp do mysql zdalny tez jest, bo amxbans działa, być może źle zapisuje te dane?
  • +
  • -
  • 0

#8 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 13.10.2009 19:05

naven, prawie bo:
Handle:query = SQL_PrepareQuery(hConnection, "CREATE TABLE `dziala_amx`(`nr` integer( 8 ),`dane` VARCHAR( 128 ) ) ")
Nie lubie pisac codu w tym, bo zlamie mi linie i juz nie doliczam sie tych nawiasow i "", wole edytor z kolorowaniem pod pawna ;>
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych