Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z amx_mala_mapa


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
1 odpowiedź w tym temacie

#1 Tymo

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:13
Offline

Napisano 25.05.2016 11:48

Cześć.

Mam taki mały problem z pluginem amx_mala_mapa!

 

Link do pluginu: https://amxx.pl/topi...apa-głosowanie/

 

 

Chodzi konkretnie o ten kawałek kodu, który w momencie gdy jest już grana mała mapa "zabija" plugin, aby ten nie wyświetlał votemap na małą mapę (logiczne)...

if(equali(szText, currentMap))
		{
			set_fail_state("TO NIE JEST BLAD! Grana jest mala mapa, dlatego zabijam plugin. ")
			break;
		}

Sęk w tym, ze takie "zabijanie" pluginu sypie błedami amx'a:

L 05/25/2016 - 12:38:49: Start of error session.
L 05/25/2016 - 12:38:49: Info (map "awp_map") (file "addons/amxmodx/logs/error_20160525.log")
L 05/25/2016 - 12:38:49: [AMXX] Plugin ("amx_mala_mapa.amxx") is setting itself as failed.
L 05/25/2016 - 12:38:49: [AMXX] Plugin says: TO NIE JEST BLAD! Grana jest mala mapa, dlatego zabijam plugin. 
L 05/25/2016 - 12:38:49: [AMXX] Displaying debug trace (plugin "amx_mala_mapa.amxx")
L 05/25/2016 - 12:38:49: [AMXX] Run time error 1: forced exit 
L 05/25/2016 - 12:38:49: [AMXX]    [0] texteaI7Xv.sma::loadSettings (line 327)
L 05/25/2016 - 12:38:49: [AMXX]    [1] texteaI7Xv.sma::plugin_init (line 99)

Można w jakiś inny sposób "zabić" plugin? Tak aby nie sypał błedami...

 

Z góry dzięki za pomoc.


  • +
  • -
  • 0

#2 Tymo

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:13
Offline

Napisano 25.05.2016 18:57

//nie mogę edytowac powyższego tematu

 

Temat można zamknąć, zrobiłem obejście wyłączając dany plugin na "małych" mapach :-)


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych