Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Zbugowany admin_spec_esp.amxx


Najlepsza odpowiedź samson112, 02.04.2016 01:11

Całkowite usunięcie pluginu alias_detector.amxx wraz z jego plikami i folderami pomogło!

 

Dziękuję Ci bardzo za pomoc! ;)

Przejdź do postu


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
14 odpowiedzi w tym temacie

#1 samson112

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:34
Offline

Napisano 01.04.2016 23:27

Witam. 

 

Mam pewien problem. Nie wiem dlaczego, ale na serwerze mam zbugowany cvar pluginu admin_spec_esp.amxx.

Zamiast esp "1" wyświetla się w amxmodmenu esp "--------" i dlatego ten plugin mi nie działa. Za każdym razem po zmianie mapy muszę ręcznie sam ustawić na esp "1" bo znowu jest esp "------". Jak mam esp "-----" to plugin wtedy nie działa. Ktoś wie jak temu zaradzić ?

 

P.S Próbowałem te cvary wkleić w amxx.cfg oraz restartowałem serwer i mapę - to nic nie pomogło. :/

Załączone miniatury

  • 20160402002900_1.jpg
  • 20160402002911_1.jpg
  • 20160402002916_1.jpg

Użytkownik samson112 edytował ten post 01.04.2016 23:34

  • +
  • -
  • 0

#2 aSik

    Wszechobecny

  • Użytkownik

Reputacja: 81
Zaawansowany

  • Postów:449
  • Imię:Robert
  • Lokalizacja:Wrocław
Offline

Napisano 01.04.2016 23:35

amxx.cfg > 

 

linijka z cvarem ma wyglądać tak;

 

esp_cvar "1" - Tutaj dodajesz sobie opisy, 1 włączone, 0 wyłąćzone itp.

 

Najprawdopodobniej masz;

 

 

esp_cvar 1 ---

lub

esp_cvar --- 1

ew. coś w tym stylu ^^

 

W każdym razie masz coś nie tak w pliku amxx.cfg, możesz go tu wrzucić, żeby dostać łatwiejsze porównania, lub gotowy plik


  • +
  • -
  • 1

Odszedłem.

 

Nadal wchodzę na forum, ale nie piszę postów.


#3 samson112

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:34
Offline

Napisano 01.04.2016 23:38

// -----------------------------------------
// Amx Mod X 1.8.2 | HLDS 2013 | Pukawka.pl
// -----------------------------------------
// AMX Mod X Configuration File
echo Executing AMX Mod X Configuration File
 
// Default access for all non admin players (see users.ini for access details)
//
// Default value: "z"
amx_default_access "z"
 
// Name of setinfo which should store a password on a client (you should change this)
// Note: Always prefix the field with an underscore (aka: "_")
// (Example: setinfo _pw "password")
//
// Default value: "_pw"
amx_password_field "_pw"
 
// Mode of logging to a server
// 0 - disable logging, players won't be checked (and access won't be set)
// 1 - normal mode which obey flags set in accounts
// 2 - kick all players not on list
//
// Default value: 1
amx_mode 1
 
// Show admins activity
// 0 - disabled
// 1 - show without admin name
// 2 - show with name
//
// Default value: 2
amx_show_activity 1
 
// Frequency in seconds and text of scrolling message
//
// Default value: "Welcome to %hostname% -- This server is using AMX Mod X" 600
//amx_scrollmsg "Welcome to %hostname% -- This server is using AMX Mod X" 600
 
// Center typed colored messages (last parameter is a color in RRRGGGBBB format)
//
// Default values: "Welcome to %hostname%" "000255100"
//                 "This server is using AMX ModX\nVisit http://www.amxmodx.org" "000100255"
//amx_imessage "Welcome to %hostname%" "000255100"
//amx_imessage "This server is using AMX Mod X\nVisit http://www.amxmodx.org" "000100255"
 
// Frequency in seconds of colored messages
//
// Default value: 180
amx_freq_imessage 150
 
// Ban times for the main ban menu (amx_banmenu)
// Use 0 for permanent ban
// Default values: 0 5 10 15 30 45 60
amx_plmenu_bantimes 0 5 10 15 30 45 60
 
// Slap damage amounts for the main slap menu (amx_slapmenu)
// Slay is automaticall inserted as the first option
// Default values: 0 1 5
amx_plmenu_slapdmg 0 1 5
 
// Set in seconds how fast players can chat (chat-flood protection)
//
// Default value: 0.75
amx_flood_time 0.75
 
// Amount of slots to reserve.
//
// Default value: 0
amx_reservation 1
 
// If you set this to 1, you can hide slots on your server.
// If server "full" of public slots and slots hidden, you must manually connect with connect console command
//
// Default value: 0
amx_hideslots 1
 
// Displaying of time remaining
// a - display white text on bottom
// b - use voice
// c - don't add "remaining" (only in voice)
// d - don't add "hours/minutes/seconds" (only in voice)
// e - show/speak if current time is less than this set in parameter
//
// Default value: "ab 1200" "ab 600" "ab 300" "ab 180" "ab 60" "bcde 11"
amx_time_display "ab 1200" "ab 600" "ab 300" "ab 180" "ab 60" "bcde 11"
 
// Announce "say thetime" and "say timeleft" with voice, set to 0 to disable.
//
// Default value: 1
amx_time_voice 1
 
// Minimum delay in seconds between two voting sessions
//
// Default value: 10
amx_vote_delay 10
 
// How long voting session goes on
//
// Default value: 10
amx_vote_time 10
 
// Display who votes for what option, set to 0 to disable, 1 to enable.
//
// Default value: 1
amx_vote_answers 1
 
// Some ratios for voting success
 
// Default value: 0.40
amx_votekick_ratio 0.40
 
// Default value: 0.40
amx_voteban_ratio 0.40
 
// Default value: 0.40
amx_votemap_ratio 0.40
 
// Default value: 0.02
amx_vote_ratio 0.02
 
// Max. time to which map can be extended
//
// Default value: 90
amx_extendmap_max 90
 
// Step for each extending
//
// Default value: 15
amx_extendmap_step 15
 
// If you set this to 0, clients cannot chose their language, instead they use
// whatever language the server is configured to use.
//
// Default value: 1
amx_client_languages 0
 
// Plugin Debug mode
// 0 - No debugging (garbage line numbers)
// 1 - Plugins with "debug" option in plugins.ini are put into debug mode
// 2 - All plugins are put in debug mode
// Note - debug mode will affect JIT performance
//
// Default value: 1
amx_debug 1
 
// Plugin MultiLingual Debug
// To debug a language put its 2 letter code between quotes ("en", "de", etc)
// "" means disabled
//
// Default value: ""
amx_mldebug ""
 
//
// Beginning of Counter-Strike package specific configurations.
//
 
// Rank mode
// 0 - by nick
// 1 - by authid 
// 2 - by ip
//
// Default value: 1
csstats_rank 0
 
// Max size of the stats file
//
// Default value: 3500
csstats_maxsize 99999999
 
// Whether or not to rank bots with csstats - set to 1 to rank bots, 0 otherwise.
//
// Default value: 0
csstats_rankbots 0
 
// Duration of HUD-statistics
//
// Default value: 12.0
amx_statsx_duration 12.0
 
// HUD-statistics display limit relative round freeze end
// Negative time will clear the HUD-statstics before the round freeze time has ended
//
// Default value: -2.0
amx_statsx_freeze -2.0
 
//Cvary
sv_rsdisplay "1"
sv_rsadvertise "0"
amx_bulletdamage_recieved "1"
amx_bulletdamage "1"
ad_react_all "1"
ad_rand_min "95"
ad_rand_max "95"
sv_parachute "1"
parachute_fallspeed "100"
ss_hostname "" 
ss_username "" 
ss_password "" 
ss_database "" 
ss_mscreens "5" 
ss_interval "1.0" 
ss_sitemap "[moja strona]" 
ss_banplayer "1" 
ss_bantime "0" 
ss_banreason "Wstaw 5 ssow na [moja strona]"
amx_bancfg_delay "0.1"
amx_bancfg_logs "1"
amx_bancfg_show_hudmsg "0"
amx_bancfg_steam_support "0"
amx_bancfg_auth "1"

  • +
  • -
  • 0

#4 samson112

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:34
Offline

Napisano 01.04.2016 23:41

Ja nawet cvarów nie mam w tym amxx.cfg z tego pluginu, bo w opisie pluginu nie podawali cvarów i z tego co wiem każdemu działa bez cvarów  w amxx.cfg ten plugin ...

 

Próbowałem wkleić te cvary z pluginu ręcznie w amxx.cfg i nawet wgrywałem na nowo ten plugin i dalej nic...

 

Nawet wyłączyłem wszystkie pluginy i zostawiłem tylko ten i nadal to samo. :/


Użytkownik samson112 edytował ten post 01.04.2016 23:46

  • +
  • -
  • 0

#5 aSik

    Wszechobecny

  • Użytkownik

Reputacja: 81
Zaawansowany

  • Postów:449
  • Imię:Robert
  • Lokalizacja:Wrocław
Offline

Napisano 01.04.2016 23:46

W *.sma masz cvary, które powinny być wpisane do amxx.cfg, żeby łatwo było ustawić plugin, niedoświadczonym ludziom (w tym przypadku Tobie)

 

Podaj *.sma, lub sam wycinek z cvarami (raczej je poznasz po chwili przypatrzenia się w kod)


  • +
  • -
  • 1

Odszedłem.

 

Nadal wchodzę na forum, ale nie piszę postów.


#6 samson112

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:34
Offline

Napisano 01.04.2016 23:47

// cvars
register_cvar("esp","1")
register_cvar("esp_timer","0.3")
register_cvar("esp_allow_all","0")
register_cvar("esp_disable_default_keys","0")
register_cvar("aesp_version",VERSION,FCVAR_SERVER|FCVAR_UNLOGGED|FCVAR_SPONLY)

  • +
  • -
  • 0

#7 aSik

    Wszechobecny

  • Użytkownik

Reputacja: 81
Zaawansowany

  • Postów:449
  • Imię:Robert
  • Lokalizacja:Wrocław
Offline

Napisano 01.04.2016 23:54

Spoiler

 

 

gotowiec


  • +
  • -
  • 1

Odszedłem.

 

Nadal wchodzę na forum, ale nie piszę postów.


#8 samson112

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:34
Offline

Napisano 02.04.2016 00:03

Ja właśnie tak próbowałem i to nic nie dało :/

 

Ale lipa :/


Użytkownik samson112 edytował ten post 02.04.2016 00:06

  • +
  • -
  • 0

#9 aSik

    Wszechobecny

  • Użytkownik

Reputacja: 81
Zaawansowany

  • Postów:449
  • Imię:Robert
  • Lokalizacja:Wrocław
Offline

Napisano 02.04.2016 00:08

Wrzuciłeś gotowca do cstrike>addons>amxmodx>configs i podmieniłeś plik?

 

Musisz coś robić źle, jeżeli to nie działa.


  • +
  • -
  • 1

Odszedłem.

 

Nadal wchodzę na forum, ale nie piszę postów.


#10 samson112

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:34
Offline

Napisano 02.04.2016 00:14

Nie wrzuciłem, tylko dopisałem tak jak pokazałeś:

 

esp "1"
esp_timer "0.3"
esp_allow_all "0"
esp_disable_default_keys "0"
 
Dodam, że nie mam żadnych error logów, a plugin jest załadowany poprawnie...

Załączone miniatury

  • 20160402011056_1.jpg

Użytkownik samson112 edytował ten post 02.04.2016 00:15

  • +
  • -
  • 0

#11 samson112

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:34
Offline

Napisano 02.04.2016 00:16

A jeśli nie wierzysz to zapraszam pw, dam Ci admina i sprawdzisz sam w amxmodmenu w cvarach....

 

//Cvary
sv_rsdisplay "1"
sv_rsadvertise "0"
amx_bulletdamage_recieved "1"
amx_bulletdamage "1"
ad_react_all "1"
ad_rand_min "95"
ad_rand_max "95"
sv_parachute "1"
parachute_fallspeed "100"
ss_hostname "" 
ss_username "" 
ss_password "" 
ss_database "" 
ss_mscreens "5" 
ss_interval "1.0" 
ss_sitemap "[moja strona]" 
ss_banplayer "1" 
ss_bantime "0" 
ss_banreason "Wstaw 5 ssow na [moja strona]"
amx_bancfg_delay "0.1"
amx_bancfg_logs "1"
amx_bancfg_show_hudmsg "0"
amx_bancfg_steam_support "0"
amx_bancfg_auth "1"
esp "1"
esp_timer "0.3"
esp_allow_all "0"
esp_disable_default_keys "1"

Użytkownik samson112 edytował ten post 02.04.2016 00:18

  • +
  • -
  • 0

#12 aSik

    Wszechobecny

  • Użytkownik

Reputacja: 81
Zaawansowany

  • Postów:449
  • Imię:Robert
  • Lokalizacja:Wrocław
Offline

Napisano 02.04.2016 00:33

Nie mam na to czasu szczerze, ale spróbuj wgrać ten plugin, i zobaczyc czy działa

 

 

Załączone pliki


  • +
  • -
  • 1

Odszedłem.

 

Nadal wchodzę na forum, ale nie piszę postów.


#13 samson112

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:34
Offline

Napisano 02.04.2016 00:49

Nie działa :/


  • +
  • -
  • 0

#14 aSik

    Wszechobecny

  • Użytkownik

Reputacja: 81
Zaawansowany

  • Postów:449
  • Imię:Robert
  • Lokalizacja:Wrocław
Offline

Napisano 02.04.2016 00:50

nazwa_pluginu.amxx debug

 

wpisz "debug" po nazwie pluginu w plugins.ini


  • +
  • -
  • 1

Odszedłem.

 

Nadal wchodzę na forum, ale nie piszę postów.


#15 samson112

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:34
Offline

Napisano 02.04.2016 01:11   Najlepsza odpowiedź

Całkowite usunięcie pluginu alias_detector.amxx wraz z jego plikami i folderami pomogło!

 

Dziękuję Ci bardzo za pomoc! ;)


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych