Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Nowy

problem z wytrzymaloscią perku w silniku

cod nowy

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
1 odpowiedź w tym temacie

#1 Minion Andrzej

    Nowy

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:5
  • Imię:Tomasz
  • Lokalizacja:Polska
Offline

Napisano 27.02.2016 12:47

Witam

Mam problem. Mianowicie dodałem wyświetlanie wytrzymałości w hudzie w silniku coda. I tutaj jest problem bo wyskakuje mi coś porąbanego.

	set_hudmessage(55, 183, 0, 0.02, 0.21, 0, 0.0, 0.3, 0.0, 0.0);
	ShowSyncHudMsg(id, SyncHudObj, "[FORUM : ---]^n[Klasa : %s]^n[Doswiadczenie : %i / %i]^n[Poziom : %i]^n[Perk : %s] [Wytrzymalosc Perku: %i/%i]^n[Zdrowie : %d]", nazwy_klas[klasa_gracza[id]], doswiadczenie_gracza[id], PobierzDoswiadczeniePoziomu(poziom_gracza[id]), poziom_gracza[id], nazwy_perkow[perk_gracza[id]], cod_get_perk_durability(id), get_user_health(id));
	
	return PLUGIN_CONTINUE;

To oczywiście kod odpowiadający za ten błąd. Przed dodaniem wytrzymałości do huda wszystko ładnie działało, ale jak już ją dodałem to maxymalna wytrzymałość zmienia swoją wartość (tzn. na początku jest 100/100, jak dana osoba zginie to jest 90/122, następnie 80/134 i potem znowu do 70/122 wraca - oczywiście bywa w różnych kolejnościach). Może to dużego błędu nie robi, ale o estetykę trzeba dbać.

 

Druga sprawa to wyświetlanie HP, które ustawiłem po wytrzymałości. W kodzie niby wszystko gra, ale mi wyświetlają się flagi i IP (śmieszne).

 

 

Oczywiście natywy dodane do coda, poniżej załączam ss'a jak to mniej więcej wygląda. Nie wiem co tu może nie działać. Jak wspomniałem, wszystko zaczęło się po dodaniu wytrzymałości do huda.

 

bug.PNG


Użytkownik Minion Andrzej edytował ten post 27.02.2016 12:49

  • +
  • -
  • 0

#2 Minion Andrzej

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 2
Nowy

  • Postów:5
  • Imię:Tomasz
  • Lokalizacja:Polska
Offline

Napisano 27.02.2016 13:15

Dobra naprawiłem..., a głowiłem się nad tym 2 dni...

[Doswiadczenie : %i / %i] - tutaj był błąd, gdyż brakowało 1 zmiennej (powinno być [Doswiadczenie : %i)

 

Do zamknięcia.


  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: cod nowy

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych