Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

RoundSound


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 Mariusz512

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:8
Offline

Napisano 01.10.2009 11:44

Witam mam problem z roundsound , tutaj kod sma :

#include <amxmodx>

public plugin_init()
{
register_plugin("RoundSound","1.0","PaintLancer")
register_event("SendAudio", "t_win", "a", "2&%!MRAD_terwin")
register_event("SendAudio", "ct_win", "a", "2&%!MRAD_ctwin")
}

public t_win()
{
new rand = random_num(0,2)

client_cmd(0,"stopsound")

switch(rand)
{
case 0: client_cmd(0,"spk misc/1")
case 1: client_cmd(0,"spk misc/2")
case 2: client_cmd(0,"spk misc/3")
case 3: client_cmd(0,"spk misc/4")
case 4: client_cmd(0,"spk misc/5")
case 5: client_cmd(0,"spk misc/6")
case 6: client_cmd(0,"spk misc/7")
case 7: client_cmd(0,"spk misc/8")
case 8: client_cmd(0,"spk misc/9")
case 9: client_cmd(0,"spk misc/10")
case 10: client_cmd(0,"spk misc/11")
case 11: client_cmd(0,"spk misc/12")
case 12: client_cmd(0,"spk misc/13")
case 13: client_cmd(0,"spk misc/14")
case 14: client_cmd(0,"spk misc/15")
case 15: client_cmd(0,"spk misc/16")
case 16: client_cmd(0,"spk misc/17")
case 17: client_cmd(0,"spk misc/18")
case 18: client_cmd(0,"spk misc/19")
case 19: client_cmd(0,"spk misc/20")
}

return PLUGIN_CONTINUE
}

public ct_win()
{
new rand = random_num(0,2)

client_cmd(0,"stopsound")

switch(rand)
{
case 0: client_cmd(0,"spk misc/1")
case 1: client_cmd(0,"spk misc/2")
case 2: client_cmd(0,"spk misc/3")
case 3: client_cmd(0,"spk misc/4")
case 4: client_cmd(0,"spk misc/5")
case 5: client_cmd(0,"spk misc/6")
case 6: client_cmd(0,"spk misc/7")
case 7: client_cmd(0,"spk misc/8")
case 8: client_cmd(0,"spk misc/9")
case 9: client_cmd(0,"spk misc/10")
case 10: client_cmd(0,"spk misc/11")
case 11: client_cmd(0,"spk misc/12")
case 12: client_cmd(0,"spk misc/13")
case 13: client_cmd(0,"spk misc/14")
case 14: client_cmd(0,"spk misc/15")
case 15: client_cmd(0,"spk misc/16")
case 16: client_cmd(0,"spk misc/17")
case 17: client_cmd(0,"spk misc/18")
case 18: client_cmd(0,"spk misc/19")
case 19: client_cmd(0,"spk misc/20")
}

return PLUGIN_CONTINUE
}

public plugin_precache()
{
precache_sound("misc/1.mp3")
precache_sound("misc/2.mp3")
precache_sound("misc/3.mp3")
precache_sound("misc/4.mp3")
precache_sound("misc/5.mp3")
precache_sound("misc/6.mp3")
precache_sound("misc/7.mp3")
precache_sound("misc/8.mp3")
precache_sound("misc/9.mp3")
precache_sound("misc/10.mp3")
precache_sound("misc/11.mp3")
precache_sound("misc/12.mp3")
precache_sound("misc/13.mp3")
precache_sound("misc/14.mp3")
precache_sound("misc/15.mp3")
precache_sound("misc/16.mp3")
precache_sound("misc/17.mp3")
precache_sound("misc/18.mp3")
precache_sound("misc/19.mp3")
precache_sound("misc/20.mp3")

return PLUGIN_CONTINUE
}


pliki w załączniku (pliki mp3,.amxx,.sma)

Po wgraniu na serwer roundsound nie dziala , co jest nie tak ?
  • +
  • -
  • 0

#2 Saper

    Godlike

  • Przyjaciel

Reputacja: 220
Profesjonalista

  • Postów:1315
  • GG:
  • Imię:Juzio ;d
  • Lokalizacja:Bialystok
Offline

Napisano 01.10.2009 11:48

gdzie masz wrzucone pliki mp3 i jakie maja nazwy ??
  • +
  • -
  • 0

#3 Mariusz512

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:8
Offline

Napisano 01.10.2009 11:50

do sound/misc 1,2,3itd
  • +
  • -
  • 0

#4 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 01.10.2009 11:53

Po wgraniu na serwer roundsound nie dziala , co jest nie tak ?

to jest nie tak że zamiast "mp3 play sound/misc/nazwa" masz "spk mics/nazwa" ;>

poza tym jeżeli chcesz żeby wszystkie dźwięki były brane pod uwagę to zmień "random_num(0,2)" na "random_num(0,19)"
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych