Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

plmenu.amxx - error logiRun time error 10: native error (native "cs_set_user_team")


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 michal7840

    Wszechpomocny

  • Zbanowany

Reputacja: 7
Nowy

  • Postów:334
  • Imię:Michał
Offline

Napisano 27.08.2015 14:58

Witam. Serwer czasami ma crasha, i jedyne error logi jakie są, to właśnie te niżej. Wiecie jak to naprawić?

L 08/27/2015 - 15:14:52: [AMXX] Displaying debug trace (plugin "plmenu.amxx")
L 08/27/2015 - 15:14:52: [AMXX] Run time error 10: native error (native "cs_set_user_team")
L 08/27/2015 - 15:14:52: [AMXX]    [0] plmenu.sma::actionTeamMenu (line 663)



#2 Sofcik

    Zaawansowany

  • Użytkownik

Reputacja: 9
Nowy

  • Postów:106
  • GG:
  • Imię:Łukasz
  • Lokalizacja:Zabrze / Rotterdam
Offline

Napisano 27.08.2015 15:02

Spróbuj w pliku plugins.ini dopisać "debug" po tym pluginie.

http://amxx.pl/topic...ów-z-pluginami/

 


2. Logi
Gdy mamy pewność, że plugin został załadowany przyszedł czas na szperanie w plikach. Logi, czyli zapisy czynności, są zapisywane w folderze addons/amxmodx/logs/.

Logi zwyczajne są nazywane w formacie L<RRRRMMDD>.log a logi błędów error_<RRRRMMDD>.log. Informacje o problemach mogą się pojawić i w jednych i w drugich. Zgłoszone błędy całkowicie wyjaśniają powód problemów tylko kiedy plugin ma status debug. Aby wymusić ten stan należy w plugins.ini dopisać debug po nazwie pluginu, np.
test.amxx debugW stanie running komunikaty są okrojone i nie lokalizują konkretnie źródła błędu, natomiast w debugu mamy informacje o ścieżce wywołania, czyli co i w której linijce po kolei się wykonywało zanim wystąpił problem. Ścieżka sięga ostatniej funkcji wywołanej przez moduł.


Użytkownik Sofcik edytował ten post 27.08.2015 15:03

  • +
  • -
  • 0

1447472674_sofcikp.png


#3 NoLiFeR

    Wszechobecny

  • Użytkownik

Reputacja: 103
Zaawansowany

  • Postów:483
  • GG:
  • Imię:Adrian
  • Lokalizacja:Sosnowiec
Offline

Napisano 27.08.2015 15:12

ma debug -.- Chłopie, jak się nie znasz, to się nie wypowiadaj...


Daj nam sma Twojego plmenu.


  • +
  • -
  • 0

#4 michal7840

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 7
Nowy

  • Postów:334
  • Imię:Michał
Offline

Napisano 27.08.2015 19:00

ma debug -.- Chłopie, jak się nie znasz, to się nie wypowiadaj...


Daj nam sma Twojego plmenu.

 

Proszę:

 

Spoiler


#5 NoLiFeR

    Wszechobecny

  • Użytkownik

Reputacja: 103
Zaawansowany

  • Postów:483
  • GG:
  • Imię:Adrian
  • Lokalizacja:Sosnowiec
Offline

Napisano 27.08.2015 19:15

Błąd powodowany był tym, iż próbowałeś przenieść nieistniejącego (rozłączonego) gracza...
Dodałem cztery linijki, oto one:

 

if(!is_user_connected(player)){
	displayTeamMenu(id, g_menuPosition[id]);
	return PLUGIN_HANDLED
}

Pierwsza sprawdza czy gracz jest połączony, jeżeli nie to wyświetla administratorowi menu spowrotem (2), oraz stopuje działanie pluginu(3).

W czwartej tylko zamykamy warunek.

Proszę:
 

Załączone pliki


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych