Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem, 1/1 z broni nie działa


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
8 odpowiedzi w tym temacie

#1 ForeverAllone

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:36
  • Imię:Patryk
  • Lokalizacja:Polska
Offline

Napisano 24.08.2015 13:14

Witam, nie wiem gdzie zrobiłem błąd, że nie działa 1/1 z AWP

public TakeDamage(this, idinflictor, idattacker, Float:damage, damagebits)
{
    if(!is_user_connected(idattacker))
        return HAM_IGNORED;
        
    if(!ma_klase[idattacker])
        return HAM_IGNORED;      
        
    if(get_user_team(this) != get_user_team(idattacker) && get_user_weapon(idattacker) == CSW_AWP && damagebits & DMG_BULLET) 
        cod_inflict_damage(idattacker, this, float(get_user_health(this))-damage+1.0, 0.0, idinflictor, damagebits);
            
    if(get_user_team(this) != get_user_team(idattacker) && get_user_weapon(idattacker) == CSW_HEGRENADE && damagebits & DMG_HEGRENADE && random_num(1, 2) == 1)
        cod_inflict_damage(idattacker, this, float(get_user_health(this))-damage+1.0, 0.0, idinflictor, damagebits);
	
	return HAM_IGNORED;
}

Załączone pliki


  • +
  • -
  • 0

#2 WeBsteR

    Wszechwidzący

  • Użytkownik

Reputacja: 57
Pomocny

  • Postów:297
  • Imię:dawid
  • Lokalizacja:Rzeszów
Offline

Napisano 24.08.2015 15:28

Proszę:

Załączone pliki


  • +
  • -
  • 0
Zabijaka Gryps to mój autorytet!

#3 ForeverAllone

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:36
  • Imię:Patryk
  • Lokalizacja:Polska
Offline

Napisano 30.08.2015 14:27

Nie działa;/


  • +
  • -
  • 0

#4 Metal9712

    Pomocny

  • Użytkownik

Reputacja: 9
Nowy

  • Postów:53
  • GG:
  • Imię:Aleksander
  • Lokalizacja:Polska
Offline

Napisano 30.08.2015 14:36

proszę sprawdzić czy działa. :)

Załączony plik  joker.sma   5,72 KB  15 Ilość pobrań
  joker.amxx


Użytkownik Metal9712 edytował ten post 30.08.2015 14:37

  • +
  • -
  • 0

#5 ForeverAllone

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:36
  • Imię:Patryk
  • Lokalizacja:Polska
Offline

Napisano 30.08.2015 15:22

proszę sprawdzić czy działa. :)

attachicon.gifjoker.sma

if(get_user_weapon(idattacker) == CSW_AWP && random_num(1,1) == 1)
		cod_inflict_damage(idattacker, this, float(get_user_health(this))-damage+1.0, 0.0, idinflictor, damagebits);
	if(get_user_weapon(idattacker) == CSW_AWP && random_num(1,2) == 1)
		cod_inflict_damage(idattacker, this, float(get_user_health(this))-damage+1.0, 0.0, idinflictor, damagebits);

Tutaj nie zrobiłeś błędu odnośnie HE?:D Bo jest 2x AWP:)


  • +
  • -
  • 0

#6 Metal9712

    Pomocny

  • Użytkownik

Reputacja: 9
Nowy

  • Postów:53
  • GG:
  • Imię:Aleksander
  • Lokalizacja:Polska
Offline

Napisano 30.08.2015 15:31

Tak, tak. Zrobiłem błąd. Pospieszyłem się za bardzo, przepraszam. :D

if(get_user_weapon(idattacker) == CSW_AWP && random_num(1,1) == 1)
        cod_inflict_damage(idattacker, this, float(get_user_health(this))-damage+1.0, 0.0, idinflictor, damagebits);
if(get_user_weapon(idattacker) == CSW_HEGRENADE && random_num(1,2) == 1)
        cod_inflict_damage(idattacker, this, float(get_user_health(this))-damage+1.0, 0.0, idinflictor, damagebits);

  • +
  • -
  • 0

#7 ForeverAllone

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:36
  • Imię:Patryk
  • Lokalizacja:Polska
Offline

Napisano 30.08.2015 17:07

 nie działa;/


  • +
  • -
  • 0

#8 Metal9712

    Pomocny

  • Użytkownik

Reputacja: 9
Nowy

  • Postów:53
  • GG:
  • Imię:Aleksander
  • Lokalizacja:Polska
Offline

Napisano 30.08.2015 17:22

Teraz powinno działać, przerobiłem 1/1 z noża ze swojego działającego komandosa na 1/1 z awp. :>

Załączone pliki


Użytkownik Metal9712 edytował ten post 30.08.2015 17:24

  • +
  • -
  • 0

#9 ForeverAllone

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:36
  • Imię:Patryk
  • Lokalizacja:Polska
Offline

Napisano 30.08.2015 19:21

Dziwne jest to ze inną klase napisałem podobnie i działa. A ta ma focha... Nawet silnik od 0 zrobiony.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych