Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Lag serwera przy zmianie mapy


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
5 odpowiedzi w tym temacie

#1 michal7840

    Wszechpomocny

  • Zbanowany

Reputacja: 7
Nowy

  • Postów:334
  • Imię:Michał
Offline

Napisano 29.07.2015 20:25

Witam. Od wczoraj zdarza sie lag serwera przy zmianie mapy i wszystkich wywala. Postanowiłem troszkę ogarnąć pluginy i moduły, wywalić niepotrzebne.

 

Np. mam plugin banip_fakes.amxx + wgrany moduł fake detector, i nie wiem czy wywalić któryś z tych.

Dodam że żadnych error logów nie mam.

 

Niżej daje wam plugins.ini i meta list:

 

plugins.ini:

 

Spoiler

 

meta list:

Currently loaded plugins:
      description      stat pend  file              vers      src   load  unlod
 [ 1] AMX Mod X        RUN   -    amxmodx_mm_i386.  v1.8.2    ini   Start ANY  
 [ 2] dproto_EF        RUN   -    dproto_i386.so    v0.9.548  ini   Start Never
 [ 3] FakeDetector     RUN   -    fakedetector_mm_  v1.7      ini   Start Never
 [ 4] VoiceTranscoder  RUN   -    vtc.so            v80       ini   ANY   ANY  
 [ 5] NetBufExtender   RUN   -    nbex.so           v1.0      ini   ANY   Never
 [ 6] MySQL            RUN   -    mysql_amxx_i386.  v1.8.2    pl1   ANY   ANY  
 [ 7] SQLite           RUN   -    sqlite_amxx_i386  v1.8.2    pl1   ANY   ANY  
 [ 8] Fun              RUN   -    fun_amxx_i386.so  v1.8.2    pl1   ANY   ANY  
 [ 9] Engine           RUN   -    engine_amxx_i386  v1.8.2    pl1   ANY   ANY  
 [10] FakeMeta         RUN   -    fakemeta_amxx_i3  v1.8.2    pl1   ANY   ANY  
 [11] CStrike          RUN   -    cstrike_amxx_i38  v1.8.2    pl1   ANY   ANY  
 [12] CSX              RUN   -    csx_amxx_i386.so  v1.8.2    pl1   ANY   ANY  
 [13] Ham Sandwich     RUN   -    hamsandwich_amxx  v1.8.2    pl1   ANY   ANY  
13 plugins, 13 running

Użytkownik michal7840 edytował ten post 29.07.2015 20:26


#2 michal7840

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 7
Nowy

  • Postów:334
  • Imię:Michał
Offline

Napisano 30.07.2015 17:31

Nie mogę edytować posta więc napiszę nowego.

 

Dzisiaj lag (30-40 sekund) nie był przy zmianie mapy, był tak w środku. Dziwne jest to że po tym lagu mapa się nie zmieniła, tylko czas mapy leciał od początku...

W konsoli podczas laga nic nie było, error logów również nie mam... Proszę o pomoc bo nie wiem jak sobie z tym poradzić.


Użytkownik michal7840 edytował ten post 30.07.2015 17:32


#3 Linux'

    Pan Pomocny

  • Power User

Reputacja: 489
Wszechobecny

  • Postów:1426
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:AmxMod i SourceMod
Offline

Napisano 30.07.2015 17:44

1. Ogranicz serwerowe modele, efekty.

2. wyłącz moduly z ktorych nie korzystaja pluginy, proponuja zaczac od sqllite. Z doswiadczenia wiem, ze niezle potrafi przymulic w polaczeniu z mysql.

3. Sprawdz jak sie trzymia fpsy na serwerze (komenda stats), powtorz kilka razy test co piec sekund i podeslij wyniki. Jak sa spadki to raportuj do hostingu, maszyna nie wyrabia pewnie.


  • +
  • -
  • 0

Posiadam na sprzedaż w pełni odwzorowaną paczkę nowego coda do csgo. Kliknij by dowiedzieć się więcej!

 

- PISZE MODYFIKACJE.

- NAPRAWIAM POPSUTE PLUGINY.

- DZIALAM W DZIALACH AMXX/SOURCEMOD. MASZ ZLECENIE? PISZ.


#4 michal7840

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 7
Nowy

  • Postów:334
  • Imię:Michał
Offline

Napisano 30.07.2015 17:57

1. Ogranicz serwerowe modele, efekty.

2. wyłącz moduly z ktorych nie korzystaja pluginy, proponuja zaczac od sqllite. Z doswiadczenia wiem, ze niezle potrafi przymulic w polaczeniu z mysql.

3. Sprawdz jak sie trzymia fpsy na serwerze (komenda stats), powtorz kilka razy test co piec sekund i podeslij wyniki. Jak sa spadki to raportuj do hostingu, maszyna nie wyrabia pewnie.

 

1. Nie mam tego dużo, z modeli mam tylko spadochron i 4 modele broni wgrane (nie sądzę żeby przez to były te lagi skoro na innych serwerach jest wgranych więcej tych pierdół i oni nie mają takich problemów)

2. A ten sqlite za co odpowiada? Bo mam wgrany sklepik sms i amxbans, i jak to wyłącze to nie wiem czy nie będzie problemów z połączeniem do bazy danych.

3. Takie wyniki są przy 14 graczach na serwerze (serwer 27 slotów)


stats
CPU   In    Out   Uptime  Users   FPS    Players
26.50 81.36 127.86    4026  6980  405.78      14

stats
CPU   In    Out   Uptime  Users   FPS    Players
19.80 87.34 143.03    4026  6980  931.18      14

stats
CPU   In    Out   Uptime  Users   FPS    Players
19.00 75.22 122.96    4026  6981  756.88      14

stats
CPU   In    Out   Uptime  Users   FPS    Players
20.67 84.35 142.47    4027  6981  916.39      14

stats
CPU   In    Out   Uptime  Users   FPS    Players
20.00 86.72 146.14    4027  6981  506.27      14

stats
CPU   In    Out   Uptime  Users   FPS    Players
20.00 73.71 122.63    4027  6981  929.94      14

stats
CPU   In    Out   Uptime  Users   FPS    Players
35.00 98.02 178.64    4028  6981  228.74      14

Aha, dzisiaj miałem laga jakoś o 18:30, a teraz zauważyłem że w errorlogach o 18:10 mam coś takiego:

L 07/30/2015 - 18:10:42: Info (map "de_eldorado") (file "addons/amxmodx/logs/error_20150730.log")
L 07/30/2015 - 18:10:42: Invalid cellvector handle provided (6:0:0)
L 07/30/2015 - 18:10:42: [AMXX] Displaying debug trace (plugin "sklep_sms.amxx")
L 07/30/2015 - 18:10:42: [AMXX] Run time error 10: native error (native "ArrayGetArray")
L 07/30/2015 - 18:10:42: [AMXX]    [0] sklep_sms.sma::_serviceChosen (line 836)
L 07/30/2015 - 18:10:42: [AMXX]    [1] sklep_sms.sma::_menuServiceType_checkPass (line 785)
L 07/30/2015 - 18:10:42: [AMXX]    [2] sklep_sms.sma::menuServiceType_nick (line 739)

Nie sądzę żeby powyższy error powodował te lagi, ponieważ wcześniej jak był ten lag to nie było tych errorów.



#5 michal7840

    Wszechpomocny

  • Autor tematu
  • Zbanowany

Reputacja: 7
Nowy

  • Postów:334
  • Imię:Michał
Offline

Napisano 01.08.2015 20:52

Dzisiaj miałem laga na jakieś 3 minuty, wszystkich wyrzuciło ale mapka się nie zmieniła...

 

Pisałem do hostingu, ale odpisali mi że żadnych ataków na maszynę nie było i maszyna nie jest obciążona. Sami nie wiedzą co jest nie tak.



#6 Linux'

    Pan Pomocny

  • Power User

Reputacja: 489
Wszechobecny

  • Postów:1426
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:AmxMod i SourceMod
Offline

Napisano 01.08.2015 21:14

No to stawiam na zbyt duzy czas zapytania miedzy baza a serwerem. wyłącz na probe wszystkie pluginy korzystajace z mysql/sqllite (sklep, amxbans itp itd) i sprawdz. Jak pomoze to znaczy, ze masz po prostu za slaba baze lub jakis wadliwy plug.
  • +
  • -
  • 0

Posiadam na sprzedaż w pełni odwzorowaną paczkę nowego coda do csgo. Kliknij by dowiedzieć się więcej!

 

- PISZE MODYFIKACJE.

- NAPRAWIAM POPSUTE PLUGINY.

- DZIALAM W DZIALACH AMXX/SOURCEMOD. MASZ ZLECENIE? PISZ.





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych