Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

set_hudmessage


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 kasza

    Godlike

  • Przyjaciel

Reputacja: 887
Czempion

  • Postów:4102
  • GG:
  • Steam:steam
  • Imię:Imię
  • Lokalizacja:Lokalizacja
Offline

Napisano 27.09.2009 09:02

mam cos takiego:
#include <amxmodx>
#include <amxmisc>

#define PLUGIN "raty+hud"
#define VERSION "1.0"
#define AUTHOR "Kasza"

public plugin_init() { 
	register_plugin("raty+hud", "1.0", "kasza") 
	register_event("HLTV", "Nowa_Runda", "a", "1=0", "2=0") 
	
}
public Nowa_Runda() 
{ 
	for(new i=0;i<33;i++){
		console_cmd(i, "ex_interp 0.01")
		server_cmd("wait")
		console_cmd (i,"cl_cmdrate 101")
		server_cmd("wait")
		console_cmd (i,"cl_updaterate 101")
		server_cmd("wait")
		console_cmd (i,"rate 25000")
		set_hudmessage(42, 212, 255, 0.1, 0.7, 0, 6.0, 10.0)
		show_hudmessage(i, "Twoj interp ustawiono na 0.01")
		
	}
}

i wywala mi takie logi :

L 09/27/2009 - 02:34:09: [AMXX]    [0] textGEjW2I.sma::Nowa_Runda (line 24)
L 09/27/2009 - 02:34:46: Invalid player id 12
L 09/27/2009 - 02:34:46: [AMXX] Displaying debug trace (plugin "interpowo.amxx")
L 09/27/2009 - 02:34:46: [AMXX] Run time error 10: native error (native "show_hudmessage")


L 09/27/2009 - 03:31:26: Invalid player id 12
L 09/27/2009 - 03:31:26: [AMXX] Run time error 10 (plugin "interpowo.amxx") (native "show_hudmessage") - debug not enabled!
L 09/27/2009 - 03:31:26: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

debug w plugins.ini nie pomaga. Plugin kompiluje sie bez problemow. Od czego to moze byc ?
  • +
  • -
  • 0

Skillownia.com

 

 #3 [UWC3NG] Skillownia.com - 213.189.52.253:27301

 


#2 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 27.09.2009 09:09

próbujesz wysłać wiadomość HUD do gracza którego nie ma na serwie.
więc albo podaj id=0 żeby wysłać wiadomość do wszystkich albo sprawdzać czy użytkownik jest połączony z serwerem.

wystarczy:
public Nowa_Runda()
{ 
  console_cmd(0, "ex_interp 0.01")
  server_cmd("wait")
  console_cmd(0,"cl_cmdrate 101")
  server_cmd("wait")
  console_cmd(0,"cl_updaterate 101")
  server_cmd("wait")
  console_cmd(0,"rate 25000")
  set_hudmessage(42, 212, 255, 0.1, 0.7, 0, 6.0, 10.0)
  show_hudmessage(0, "Twoj interp ustawiono na 0.01")
}

  • +
  • -
  • 0

#3 kasza

    Godlike

  • Autor tematu
  • Przyjaciel

Reputacja: 887
Czempion

  • Postów:4102
  • GG:
  • Steam:steam
  • Imię:Imię
  • Lokalizacja:Lokalizacja
Offline

Napisano 27.09.2009 09:27

dzięki Pavulon. Ja by cos nie dzialalo napisze PW o otworzenie.
  • +
  • -
  • 0

Skillownia.com

 

 #3 [UWC3NG] Skillownia.com - 213.189.52.253:27301

 





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych