Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.
  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z errorem undefined symbol "id"


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
3 odpowiedzi w tym temacie

#1 XXL

    Wszechmogący

  • Power User

Reputacja: 138
Zaawansowany

  • Postów:626
Offline

Napisano 08.06.2015 17:53

Witam próbowałem dodać do pluginu sprawdzanie gracza poprzez flagę ale niestety wywala mi error  przy kompilacji:

2.sma(146) : error 017: undefined symbol "id"

W linijcie 146 znajduję się własnie ten kod który próbowałem dodać czyli:

new flagi = (!(get_user_flags(id) & FLAGA))

tak samo było z dodaniem takiego kodu

new flagi = get_user_flags(id) & FLAGA

Moja bilbioteka pluginu wygląda tak:

#include <amxmodx>
#include <amxmisc>
#include <sqlx>
#include <colorchat>
#include <hamsandwich>
#include <fun>
#include <cstrike>
#include <engine>
#include <fakemeta_util>
#include <nvault>
#include <csx>
#include <jailbreak>

Oraz  

#define FLAGA ADMIN_LEVEL_H

Możecie mi pomóc co robię źle?


  • +
  • -
  • 0

#2 TibacK

    Diler pod gimnazjum dla niepełnosprawnych dzieci

  • Power User

Reputacja: 506
Wszechwiedzący

  • Postów:2565
Offline

Napisano 08.06.2015 18:43

Bo nie zdefiniowałeś id, albo zmienna przechowująca index gracza jest inaczej nazwana, pokaż więcej kodu (zwłaszcza przed linią 146)


  • +
  • -
  • 0

#3 krzysztofr

    Pomocny

  • Użytkownik

Reputacja: 7
Nowy

  • Postów:73
  • Imię:Krzysztof
  • Lokalizacja:Toruń
Offline

Napisano 10.08.2015 17:56

Niewiem czy mi sie wydaje, czy w kodzie poniżej jest błąd

 

 

new flagi = (!(get_user_flags(id) & FLAGA))

 


  • +
  • -
  • -2

#4 XXL

    Wszechmogący

  • Autor tematu
  • Power User

Reputacja: 138
Zaawansowany

  • Postów:626
Offline

Napisano 11.08.2015 11:42

Nie ważne można zamknąć 


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych