Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

CZemu to nie dziala


  • Zamknięty Temat jest zamknięty
11 odpowiedzi w tym temacie

#1 zurawa123

    Zaawansowany

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:98
  • Lokalizacja:Bydzia
Offline

Napisano 06.09.2009 22:23

Gdy wpisze /frag100 w say to nic sie nie dzieje nie daje fragow ani nic
/* Plugin generated by AMXX-Studio */

#include <amxmodx>
#include <amxmisc>
#include <fun>

#define PLUGIN "Test1"
#define VERSION "1.0"
#define AUTHOR "Ojciec Dyrektor"


public plugin_init() {
	register_plugin(PLUGIN, VERSION, AUTHOR)
	register_clcmd ("say /frag100", "frag") 
}
public frag(id)
{
        new id = read_data(1)  
        new frags = get_user_frags(id) 
        set_user_frags(id, frags + 100)
        return PLUGIN_CONTINUE 
}


[ Dodano: 06-09-2009, 23:24 ]
L 09/06/2009 - 23:18:13: [FUN] Invalid player 2
L 09/06/2009 - 23:18:13: [AMXX] Run time error 10 (plugin "test1.amxx") (native "set_user_frags") - debug not enabled!
L 09/06/2009 - 23:18:13: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
BdG SqaD / Ojciec : /frag100
BdG SqaD / Ojciec : /frags100
L 09/06/2009 - 23:18:52: [FUN] Invalid player 2
L 09/06/2009 - 23:18:52: [AMXX] Run time error 10 (plugin "test1.amxx") (native "set_user_frags") - debug not enabled!
  • +
  • -
  • 0

#2 Tifa

    Zaawansowany

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:77
  • GG:
  • Lokalizacja:Szczecin
Offline

Napisano 07.09.2009 00:24

Po nazwie Plugina dopisz debug:

test1.amxx debug

A jak chcesz dodać fragi wejdź do:
cstrike/addons/amxmodx/data
Skopiuj na Pulpit plik csstats.dat
Pobierz to rozpakuj skopiuj na pulpit i uruchom:
http://www.speedysha.../747266228.html

Teraz możesz dodawać zmieniać każdy Stat z osobna...
  • +
  • -
  • 0

#3 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 07.09.2009 07:08

/* Plugin generated by AMXX-Studio */

#include <amxmodx>
#include <amxmisc>
#include <fun>

#define PLUGIN "Test1"
#define VERSION "1.0"
#define AUTHOR "Ojciec Dyrektor"


public plugin_init() {
register_plugin(PLUGIN, VERSION, AUTHOR)
register_clcmd ("say /frag100", "frag")
}
public frag(id)
{
new id = read_data(1)
new frags = get_user_frags(id)
set_user_frags(id, frags + 100)
return PLUGIN_CONTINUE
}


a po co ci tam:
new id = read_data(1)
??

Wystarczy takie coś:
#include <amxmodx>
#include <fun>

public plugin_init() {
	register_plugin("Test1", "1.0", "Ojciec Dyrektor")
	register_clcmd ("say /frag100", "frag")
}

public frag(id)
	set_user_frags(id, get_user_frags(id) + 100)

  • +
  • -
  • 0

#4 zurawa123

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:98
  • Lokalizacja:Bydzia
Offline

Napisano 07.09.2009 17:53

nadal nie działa jak to wpisze to nic się nie dzieje
  • +
  • -
  • 0

#5 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 07.09.2009 18:30

#include <amxmodx> 
#include <fun> 

public plugin_init() { 
    register_plugin("Test1", "1.0", "Ojciec Dyrektor") 
    register_clcmd ("say /frag100", "frag") 
} 

public frag(id)
{ 
    set_user_frags(id, get_user_frags(id) + 100)
}
^^ ?
  • +
  • -
  • 0

#6 zurawa123

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:98
  • Lokalizacja:Bydzia
Offline

Napisano 07.09.2009 19:06

CAly czas nie dziala
  • +
  • -
  • 0

#7 wizu

    Godlike

  • Przyjaciel

Reputacja: 224
Profesjonalista

  • Postów:1217
  • GG:
  • Lokalizacja:Sanok
Offline

Napisano 07.09.2009 19:51

Jesteś pewny, że przekompilowujesz i nadpisujesz plik .amxx na serwerze?
  • +
  • -
  • 0

#8 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 08.09.2009 08:26

CAly czas nie dziala

nie działa to wiele nie mówi...
w amx_plugins status runnging ?
jakieś logi błędów ?
  • +
  • -
  • 0

#9 zurawa123

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:98
  • Lokalizacja:Bydzia
Offline

Napisano 08.09.2009 15:40

Test1 1.0 Ojciec Dyrektor test1.amxx running
w logach nie ma zadnego blendu
a nie dziala to ze jak wpisze /frag100 to nic sie nie dzieje
  • +
  • -
  • 0

#10 naven

    Hero

  • Power User

Reputacja: 200
Profesjonalista

  • Postów:1088
  • GG:
  • Imię:Adam
  • Lokalizacja:Cieszyn
Offline

Napisano 08.09.2009 16:55

debuguj go
  • +
  • -
  • 0

#11 zurawa123

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:98
  • Lokalizacja:Bydzia
Offline

Napisano 08.09.2009 21:35

zauwazylem ze dodaje sie w ilosci zabójstw jak się patrzy w dedicat server ale nie dodaja sie do tabeli ani do rankingu a ma sie dodawac
  • +
  • -
  • 0

#12 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 08.09.2009 21:55

zauwazylem ze dodaje sie w ilosci zabójstw jak się patrzy w dedicat server ale nie dodaja sie do tabeli ani do rankingu a ma sie dodawac

to się mówi...

#include <amxmodx>
#include <cstrike>
#include <fun>

new msgScoreInfo

public plugin_init() {
	register_plugin("Test1", "1.0", "Ojciec Dyrektor")
	register_clcmd ("say /frag100", "frag")
	msgScoreInfo = get_user_msgid("ScoreInfo")
}

public frag(id)
{
	new UserFrags = get_user_frags(id)
	set_user_frags(id, UserFrags + 100)
	
	message_begin(MSG_BROADCAST, msgScoreInfo)
	write_byte(id)
	write_short(UserFrags + 100)
	write_short(cs_get_user_deaths(id))
	write_short(0)
	write_short(int:cs_get_user_team(id))
	message_end()
	
	return PLUGIN_HANDLED
}

na tablicę wyników działa,a ranking to nie wiem...
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych