Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Czy da się jakoś ustawić żeby przycisk "e" nie działał na serwerze?


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 Paral

    Pomocny

  • Użytkownik

Reputacja: -1
Mniej niż zer0.

  • Postów:60
  • Lokalizacja:Polska
Offline

Napisano 02.01.2015 22:55

Witajcie.

Czy da się jakoś ustawić żeby przycisk "e" nie działał na serwerze?

Za pomoc leci plusik ..


  • +
  • -
  • 0

#2 NiczegoWinien

    Profesjonalista

  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:215
  • Lokalizacja:No Disc
Offline

Napisano 02.01.2015 22:59

/* Plugin generated by AMXX-Studio */

#include <amxmodx>
#include <amxmisc>
#include <fakemeta>

#define PLUGIN "New Plug-In"
#define VERSION "1.0"
#define AUTHOR "author"


public plugin_init() {
	register_plugin(PLUGIN, VERSION, AUTHOR)
	
	register_forward(FM_EmitSound, "EmitSound");
}
public EmitSound(id, iChannel, szSound[], Float:fVol, Float:fAttn, iFlags, iPitch ) 
	return FMRES_IGNORED;

Moze cos takiego


  • +
  • -
  • 0

PokeMod na Sprzedaz. Wejdz i dowiedz sie wiecej.

http://www.poke-revolution.pl/

 

b_350_20_5A6C3E_383F2D_D2E1B5_2E3226.png


#3 ogieR8

    Wszechmogący

  • Power User

Reputacja: 203
Profesjonalista

  • Postów:637
  • Imię:Mariusz
  • Lokalizacja:Ruda Śląska
Offline

Napisano 02.01.2015 23:06

Ma blokować 'C' czy komende +use przypisaną standardowo do 'C' ? Jeśli to drugie to łap

#include <amxmodx>

public plugin_init() {
	register_plugin("Blocked +USE", "0.1", "ogieR8")
	register_clcmd("+use","block")
}

public block(id) return PLUGIN_HANDLED

  • +
  • -
  • 0
DiabloEwenement v.2.0 [||||||_____]
 

Irytuje mnie nieczytelny kod, jeśli oczekujesz ode mnie pomocy - zmień to !
CodeGenerators.pl - skopiuj kod do okna po prawej, kliknij 'Ułóż". To wszystko, trudne ?


#4 Paral

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: -1
Mniej niż zer0.

  • Postów:60
  • Lokalizacja:Polska
Offline

Napisano 02.01.2015 23:20

Hmm, a więc zrobiłem plik sma i dałem tam po kolei wasze te kody co mi daliście i skompilowałem aby były też w amx i wrzucilem na serwer lecz nie pomogło.

Chodzi mi o to żeby przycisk "e" na serwerze nie działał gdyż dlatego że ktoś jak kilka "e" albo ja to słychać jakby ktoś spadał z wysoka i łamał się i można tym strasznie spamować.


  • +
  • -
  • 0

#5 grankee

    Godlike

  • Support Team

Reputacja: 507
Wszechwiedzący

  • Postów:1500
  • Lokalizacja:Radom
Offline

Napisano 03.01.2015 04:10

Zacznijmy od tego, że nie każdy musi mieć pod "e" to samo, ja na przykład ze standardowego cfg mam tylko strzelanie skok i WSAD. Kolejna sprawa, założyłeś już temat dotyczący tego dziwnego zjawiska, załatw to tam, bo powielasz problem w drugim topicu.


  • +
  • -
  • 1




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych