Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
AMXBans 6.x

Błąd połączenia z baza mysql

amxbans 6.x błąd

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
6 odpowiedzi w tym temacie

#1 zdzislaw17

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:6
  • Lokalizacja:den haag
Offline

Napisano 24.11.2014 14:29

Witam, problem polega na tym, że mimo konfiguracji pliku sql.cfg w konsoli serwa cały czas widnieje "localhost"

L 11/24/2014 - 14:24:39: [amxbans_main.amxx] [AMXBans] Connection failed!
L 11/24/2014 - 14:24:39: [amxbans_main.amxx] [AMXBans] Threaded Query Error, Place: 17
L 11/24/2014 - 14:24:39: [amxbans_main.amxx] [AMXBans] Message: Access denied for user 'csmania_bany'@'localhost' (using password: TAK) (1045)
L 11/24/2014 - 14:24:39: [amxbans_main.amxx] [AMXBans] Query statement:

Co może być przyczyną?

 

Plik sql.cfg

 

// SQL configuration file
// File location: $moddir/addons/amxmodx/configs/sql.cfg


// *NOTE* Linux users may encounter problems if they specify "localhost" instead of "127.0.0.1"
// We recommend using your server IP address instead of its name


// *NOTE* amx_sql_type specifies the DEFAULT database type which admin.sma will use.


amx_sql_host "sql.s21.vdl.pl"
amx_sql_user "csmania_bany"
amx_sql_pass "haslo"
amx_sql_db "csmania_bany"
amx_sql_table "admins"
amx_sql_type "mysql"
 

 

 

Użytkownik zdzislaw17 edytował ten post 24.11.2014 14:29

  • +
  • -
  • 0

#2 BeMM

    Profesjonalista

  • Użytkownik

Reputacja: 43
Pomocny

  • Postów:175
  • GG:
  • Lokalizacja:KrK
Offline

Napisano 24.11.2014 15:27

Zezwoliłeś bazie na połączenie zewnętrzne?


  • +
  • -
  • 0

#3 zdzislaw17

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:6
  • Lokalizacja:den haag
Offline

Napisano 24.11.2014 15:29

tak, znak % dodany


  • +
  • -
  • 0

#4 zdzislaw17

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:6
  • Lokalizacja:den haag
Offline

Napisano 24.11.2014 16:14

Dodam, że zainstalowałem amxbans tam gdzie stoi serwer i działa jak należy a na zewnętrznej bazie nie łączy. 

L 11/24/2014 - 16:16:14: [amxbans_main.amxx] [AMXBans] Message: Access denied for user 'csmania_bany'@'localhost' (using password: TAK) (1045)
L 11/24/2014 - 16:16:14: [amxbans_main.amxx] [AMXBans] Query statement: SELECT `fid`, `reason`, `created`, `length` FROM `amx_flagged` WHERE `player_id` = 'BOT' OR `player_ip` = '127.0.0.1' ORDER BY `length` ASC;

Sory nie można edytować.


Użytkownik zdzislaw17 edytował ten post 24.11.2014 16:17

  • +
  • -
  • 0

#5 blokers

    Pomocny

  • Zbanowany

Reputacja: 6
Nowy

  • Postów:49
  • Imię:Burak
  • Lokalizacja:zwacz
Offline

Napisano 27.11.2014 08:16

sql.cfg podaj, bo widze, ze przez 127.0.0.1 jedziesz.


Użytkownik blokers edytował ten post 27.11.2014 08:17

b_350_20_692108_381007_FFFFFF_000000.png


#6 zdzislaw17

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:6
  • Lokalizacja:den haag
Offline

Napisano 29.11.2014 15:20

sql.cfg podaj, bo widze, ze przez 127.0.0.1 jedziesz.

Właśnie tutaj miałem wszystko dobrze ustawione. 

 

amx_sql_host "sql.s21.vdl.pl"
amx_sql_user "csmania_bany"
amx_sql_pass "haslo"
amx_sql_db "csmania_bany"
amx_sql_table "admins"
amx_sql_type "mysql"

Teraz udało mi sie zainstalować amxbans na serwerze linuxpl.com używając bazy z pukawki. Tylko, że w banliist serwer jest jako nie aktywny;/

<ciach!>

Coś tu nie gra ale nie wiem co...

 


  • +
  • -
  • 0

#7 psilocybe

    Toasty!

  • Power User

Reputacja: 246
Wszechwidzący

  • Postów:524
  • Steam:steam
  • Imię:Filip
  • Lokalizacja:PL
Offline

Napisano 01.12.2014 20:00

Miałem identyczny problem, na bazie serwerowni śmigało, jak zainstalowałem na zewnętrznej bazie już nie działało.

 

Sam nie wiem jak sobie z tym poradziłem, na pewno zamiast nazwy serwera sql w sql.cfg mam jego IP, w amxbans.cfg ręcznie podałem IP serwera gry, no i korzystałem przy instalacji z tego poradnika: http://amxx.pl/topic...serwerpl-xaapl/(ręczne dodawanie serwera)

 

Aha i znak % nie jest prawidłowym rozwiązaniem, podaj tam IP swojego serwera.


  • +
  • -
  • 0

Dołączona grafika

Dołączona grafika






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych