Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

start restart


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 nismo

    Zaawansowany

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:98
Offline

Napisano 10.06.2008 18:45

Cześć,

Przed reinstalacją amxa na serwie była nożówka po reinstalacji nagle zamiast nożówki jest grana pistoletówka jak to zmienić?
dzięki.

#include <amxmodx>             // AMX Mod X
#include <amxmisc>

new czas = 45
new pokaz_czas
new restart_title[1][] = {
	"www.kozoki.com"
}

public plugin_init() 
{ 
	register_plugin("ROund STart REstart","1.0","Gracz")
	set_task(5.0,"restart_odlicz", 0) 

	return PLUGIN_CONTINUE 
}


public restart_odlicz(){
 	unpause("ac","switchweapon.amxx")

	new configsDir[64]
	get_configsdir(configsDir, 63)
	server_cmd("exec %s/niegra.cfg", configsDir)

	set_task(2.0,"muza_on", 0)
	set_task(45.0,"wywal_noz", 0)
	
	set_task(48.0,"restart_rundy_play", 0) 

	set_task(47.0,"restart_rundy", 0) 
        set_task(47.0,"restart_rundy_1", 0) 
	set_task(1.0,"wyswietl_res",8188,"",0,"b")



}

public muza_on(){
	client_cmd(0,"stopsound")
	client_cmd(0,"spk misc/gbz")
}

public wywal_noz(){
	pause("ac","switchweapon.amxx")
}

public wyswietl_res(){

	new jac1=random_num(0,255)
	new jac2=random_num(0,255)
	new jac3=random_num(0,255)	
	pokaz_czas = czas

	set_hudmessage(jac1, jac2, jac3, 0.65, 0.75, 2, 0.02, 1.0, 0.01, 0.1, 10)  
	show_hudmessage(0,"^n %s ^nRESTART ZA: %i sec^n", restart_title, pokaz_czas) 
	czas--

/*
	message_begin(MSG_ALL, get_user_msgid("ScreenFade"), {0,0,0}, 0)
	write_short( 1<<10 ) // fade lasts this long duration
	write_short( 1<<10 ) // fade lasts this long hold time
	write_short( 1<<12 ) // fade type (in / out)
	write_byte( jac1 ) // fade red
	write_byte( jac2 ) // fade green
	write_byte( jac3 ) // fade blue
	write_byte( 50 ) // fade alpha
	message_end()
*/
}

public restart_rundy_play(){
	set_hudmessage(10, 255, 40, -1.0, 0.30, 0, 6.0, 6.0, 0.5, 0.15, 4)
	show_hudmessage(0,"^nGRAMY^n")
}


public restart_rundy(){
	client_cmd(0,"stopsound")
	client_cmd(0,"spk misc/reset")
	server_cmd("sv_restart 1")

}

public restart_rundy_1(){
	remove_task(8188)
	czas = 45
	set_hudmessage(10, 255, 40, -1.0, 0.30, 0, 6.0, 6.0, 0.5, 0.15, 4)
	show_hudmessage(0,"")
	client_cmd(0,"stopsound")
	client_cmd(0,"spk misc/")
}

public restart_rundy_2(){
	set_hudmessage(10, 255, 40, -1.0, 0.30, 0, 6.0, 6.0, 0.5, 0.15, 4)
	show_hudmessage(0,"Dwa")
	client_cmd(0,"stopsound")
	client_cmd(0,"spk misc/two")

}

public restart_rundy_3(){
	new configsDir[64]
	get_configsdir(configsDir, 63)
	server_cmd("exec %s/gra.cfg", configsDir)
	set_hudmessage(10, 255, 40, -1.0, 0.30, 0, 6.0, 6.0, 0.5, 0.15, 4)
	show_hudmessage(0,"Jeden")
	client_cmd(0,"stopsound")
	client_cmd(0,"spk misc/one")
}

public plugin_precache() 
{
    precache_sound("misc/gbz.wav")
    precache_sound("misc/three.wav")
    precache_sound("misc/two.wav")
    precache_sound("misc/one.wav")
    precache_sound("misc/reset.wav")

    return PLUGIN_CONTINUE
}

  • +
  • -
  • 0

#2 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 10.06.2008 18:47

Przekompiluj na serwerze w obecnej wersji amxx'a.

Skoro pluga nie zmieniales, to winny jest nowy amxx.
  • +
  • -
  • 0

#3 nemore

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:17
  • GG:
  • Lokalizacja:Przeworsk
Offline

Napisano 13.06.2008 21:14

brakuje ci pluga switchweapon

unpause("ac","switchweapon.amxx")


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych