Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Dodanie tłumaczenia do pluginu QuickDefuse


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
2 odpowiedzi w tym temacie

#1 verman

    Profesjonalista

  • Użytkownik

Reputacja: 37
Życzliwy

  • Postów:204
  • GG:
  • Lokalizacja:Bielsko-Biała
Offline

Napisano 06.11.2014 16:56

Próbowałem dodać do pluginu tłumaczenie. Plugin niestety nie posiada możliwości dodawania dodatkowego tłumaczenie poprzez edycję pliku tekstowego. Dlatego chciałem spróbować to zrobić.

 

Pod: 

public OnPluginStart()
{

Dodałem:

LoadTranslations("QuickDefuse.pharses")

Następnie linijkę:

SetPanelTitle(panel, "Choose a Wire:" )

Zamieniłem na:

SetPanelTitle(panel, "%t", "choose_a_wire" )

Do pliku QuickDefuse.phrases dodałem:

"Phrases"
{
"choose_a_wire"
{
"en" "Choose a wire:"
"pl" "Wybierz kabel:"
}
}
 
Przy próbie kompilacji wywala mi następujący błąd:
/groups/sourcemod/upload_tmp/textrDWuUv.sp(60) : error 035: argument type mismatch (argument 3)

Na scriptingu praktycznie się nie znam. Starałem się to zrobić metodą prób i błędów, podglądając inne pluginy, ale niestety poległem.

Załączone pliki


Użytkownik verman edytował ten post 06.11.2014 16:57

  • +
  • -
  • 0

#2 Dr.MacKay

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:6
  • Lokalizacja:Kraków
Offline

Napisano 06.11.2014 17:47

Tam masz źle zmienną adresowaną, mógłbyś algorytym jakiś wprowadzic. Dzięki za +


  • +
  • -
  • 0

#3 verman

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 37
Życzliwy

  • Postów:204
  • GG:
  • Lokalizacja:Bielsko-Biała
Offline

Napisano 06.11.2014 17:56

Jak już wcześniej napisałem praktycznie się na tym nie znam. Liczę na to, że ktoś przedstawi mi przykład  :).

 


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych