Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[ROZWIĄZANE] Błąd s1: s2 - prefix?


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 `Sernik

    `Profesjonalista !

  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 08.09.2014 12:51

Witam wszystkich,

mam nietypowy problem związany z chatem AMXX, otóż. Na moim serwerze gra pewna osoba mieszkającą w niemczech, na w pełni niemieckim komputerze i posiada na moim serwerze flagę "VIPa". W tymże VIPie jest dodany prefix na chat, by każda wiadomość zaczynała się od zielonego prefixu [VIP]. Wszystko fajnie żadnych problemów z tym nie miałem do czasu gdy dostałem zgłoszenie od wcześniej wymienionego gracza, że podczas gdy ktoś lub on sam, piszę na chacie i posiada flagę "t" wiadomość ta się nie wyświetla, a w zamian otrzymuję taką konstrukcję:

[VIP] s1: s2

 

W miejscu s1 powinien być nick, a w miejscu s2 wiadomość, niestety nie mam pod ręką screena jednak gdy gracz będzie dostępny prześle mi go.

 

Sytuację opisałem tak jak zrozumiałem, kiedyś jeden z jego zrzutów ekranu już widziałem i faktycznie wyglądało to jak błąd związany z prefixem zwłaszcza, ze nadmienił iż gdy prefixu w VIPie nie było, problem również zniknął.

Czy to jest wina jakiejś niemieckiej konfiguracji sprzętowej? Czy może błąd czegoś innego, na co ja absolutnie nie mogę wpaść? Prefixu z VIPa bym nie chciał usuwać gdyż nie ukrywajmy jest to raczej promująca usługę rzecz.

 

VIP jest generatorowy i mimo stałych problemów z przydzielaniem losowo vipa graczom, innych problemów nigdy nie miałem, ale teraz coś takiego? 

 

Jeżeli ktos ma jakiś pomysł lub sugestię proszę o pomoc.

 

Pozdrawiam


  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#2 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6034
Godlike

  • Postów:10832
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 09.09.2014 18:05

Korzysta pewnie z niemieckojęzycznej wersji cs'a 

 

Poprosze sma i screeny


  • +
  • -
  • 0

#3 `Sernik

    `Profesjonalista !

  • Autor tematu
  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 10.09.2014 17:43

Korzysta ze STEAMowej wersji angielskiej.

Dodał mi również pewną notkę, więc dodam. Problem pojawia się tylko wtedy gdy gracz posiada VIPa i właśnie ten prefix. Czyli Jeżeli on posiada VIPa nie widzi sam co napisał. Jeżeli inne VIPy piszą również ich tekst jest niewidoczny:

 

Screen:

Spoiler

 

.sma:

Spoiler

  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#4 bicek

    Ja tu tylko sprzątam.

  • Zbanowany

Reputacja: 914
Master

  • Postów:796
  • Lokalizacja:Wieluń
Offline

Napisano 20.12.2014 17:05

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Brak zainteresowania ze strony autora.


Z pozdrowieniami,
Zespół AMXX.PL.

#5 `Sernik

    `Profesjonalista !

  • Autor tematu
  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 21.12.2014 15:39

Problem jest o tyle ciekawy, że błąd jest z wartością s1:s2 w funkcji prefixu. Tak jakby CS nie odczytywał tych wartości jako NICK i Wiadomość. Proszę o pomoc.
  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#6 `Sernik

    `Profesjonalista !

  • Autor tematu
  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 21.12.2014 20:19

Problem rozwiązany.. Rozwiązaniem jest wyłączenie uczestniczenia w testach BETA CS 1.6. Jeżeli się w nich kiedyś brało udział najwidoczniej psuły coś w plikach gry. Pozdrawiam do zamknięcia
  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#7 bicek

    Ja tu tylko sprzątam.

  • Zbanowany

Reputacja: 914
Master

  • Postów:796
  • Lokalizacja:Wieluń
Offline

Napisano 21.12.2014 20:34

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Pomoc udzielona

Jeśli się z tym nie zgadzasz, report.png raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych