Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Parametry serwera


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
20 odpowiedzi w tym temacie

#1 SeeK

    Wszechobecny

  • Użytkownik

Reputacja: 190
Profesjonalista

  • Postów:437
Offline

Napisano 30.08.2014 11:01

Mam postawiony serwer FFA ( 31 slotów ) na VPSie KVM CPU: 2GHz, RAM: 1GB jednakże na serwerze daje się odczuć lagi, ping jest prawie 2-krotnie większy niż na innych serwerach. Czy parametry tego VPSa są za małe, czy wystarczy ustawić prawidłowo kilka cvarów?

 

Po wpisaniu kilka razy w konsoli "stats", takie oto są wyniki:

Spoiler

  • +
  • -
  • 0

http://sklep-sms.pl - sklep do gry Counter-Strike w którym dokonuje się zakupów bez wychodzenia z serwera!

 

Planeta-Skilla.pl - Zapraszam!  :)


#2 xenos

    Wszechobecny

  • Użytkownik

Reputacja: 209
Profesjonalista

  • Postów:456
  • GG:
  • Imię:Konrad
  • Lokalizacja:Rzeszów
Offline

Napisano 30.08.2014 11:04

Pierwsze pytanie gdzie stoi maszyna i na jakim łączu.. chociaż jeśli to vps to pewnie łącze dzielone. 


  • +
  • -
  • 0
"Jeśli potrafię to pomogę, jeśli nie potrafię to wskaże drogę którą trzeba dążyć by znaleźć odpowiedz" 

Pluginy:
Szukanie Aktywnych Banów w AmxBansie
Drop After Death
Kto postawił mine

#3 SeeK

    Wszechobecny

  • Autor tematu
  • Użytkownik

Reputacja: 190
Profesjonalista

  • Postów:437
Offline

Napisano 30.08.2014 11:13

Mintshost, łącze dobre, testowalem upload i download i oba mają ok 24mbps.
  • +
  • -
  • 0

http://sklep-sms.pl - sklep do gry Counter-Strike w którym dokonuje się zakupów bez wychodzenia z serwera!

 

Planeta-Skilla.pl - Zapraszam!  :)


#4 GwynBleidD

    Godlike

  • Administrator

Reputacja: 1849
Godlike

  • Postów:3066
  • Steam:steam
  • Lokalizacja:Przemyśl
Offline

Napisano 30.08.2014 11:43

Download i upload to jedno, a ping to drugie. Chodzi o lokalizację łącza, czyli kraj (ewentualnie miasto).

 

Dwa: masz dość spore spadki FPS serwera, przejrzyj pluginy czy któryś nie robi za dużo operacji w thinku albo innym często wykonującym się forwardzie.


  • +
  • -
  • 0
NIE pomagam na PW. Nie trudź się, na zlecenia nie odpiszę... Od pomagania jest forum.
NIE zaglądam w tematy wysłane na PW. Jeśli są na forum to prędzej czy później je przeczytam. Jeśli mam co w nich odpisać, to odpiszę.
 
1988650.png?theme=dark

#5 BeMM

    Profesjonalista

  • Użytkownik

Reputacja: 43
Pomocny

  • Postów:175
  • GG:
  • Lokalizacja:KrK
Offline

Napisano 30.08.2014 12:08

Najlepiej najpierw wyłącz amxx i sprawdź czy lagi są dalej, wtedy będziesz miał rozwiązanie.


  • +
  • -
  • 0

#6 SeeK

    Wszechobecny

  • Autor tematu
  • Użytkownik

Reputacja: 190
Profesjonalista

  • Postów:437
Offline

Napisano 30.08.2014 14:27

Odpaliłem htop'a i się okazało, że jednka zużycie procesora przez proces hlds wynosi ~70%. Wydaje mi się, że to może być problemem.

 

GwynBleiD, wcześniej serwer działał na VPSie OpenVZ i nie było problemu z spadkiem fpsów, więc chyba to nie problem pluginów.


  • +
  • -
  • 0

http://sklep-sms.pl - sklep do gry Counter-Strike w którym dokonuje się zakupów bez wychodzenia z serwera!

 

Planeta-Skilla.pl - Zapraszam!  :)


#7 GwynBleidD

    Godlike

  • Administrator

Reputacja: 1849
Godlike

  • Postów:3066
  • Steam:steam
  • Lokalizacja:Przemyśl
Offline

Napisano 30.08.2014 16:17

Monitoruj dłuższą chwilę htopem VPSa i patrz, czy nie masz skoków zużycia zasobów. Popatrz również, czy ramu nie brakuje.

 

Możliwe, że zasoby masz przydzielane "dynamicznie" albo hosting daje ciała i część ramu dla VPSów jest na maszynie swapowana... Jeśli nie ma skoków i po wyłączeniu amxx dalej są problemy z FPSami, prawie na 100% wina hostingu.


  • +
  • -
  • 0
NIE pomagam na PW. Nie trudź się, na zlecenia nie odpiszę... Od pomagania jest forum.
NIE zaglądam w tematy wysłane na PW. Jeśli są na forum to prędzej czy później je przeczytam. Jeśli mam co w nich odpisać, to odpiszę.
 
1988650.png?theme=dark

#8 SeeK

    Wszechobecny

  • Autor tematu
  • Użytkownik

Reputacja: 190
Profesjonalista

  • Postów:437
Offline

Napisano 30.08.2014 16:59

A ktoś może mi wytłumaczyć, dlaczego CPU mam 0.00 cały czas?


  • +
  • -
  • 0

http://sklep-sms.pl - sklep do gry Counter-Strike w którym dokonuje się zakupów bez wychodzenia z serwera!

 

Planeta-Skilla.pl - Zapraszam!  :)


#9 SeeK

    Wszechobecny

  • Autor tematu
  • Użytkownik

Reputacja: 190
Profesjonalista

  • Postów:437
Offline

Napisano 30.08.2014 17:11

A co jeżeli po wyłączeniu AMXXa dalej są skoki pingu, ale zużycie cpu jest cały czas na niskim poziomie?

 

W ogóle też się dziwne rzeczy dzieją, bo mam zużycie procesora przez proces 58%, a ogólne zużycie poszczególnych rdzeni nie przekracza 15%...

 

1409414976-Zrzut_ekranu_z_2014-08-30_17:


  • +
  • -
  • 0

http://sklep-sms.pl - sklep do gry Counter-Strike w którym dokonuje się zakupów bez wychodzenia z serwera!

 

Planeta-Skilla.pl - Zapraszam!  :)


#10 GwynBleidD

    Godlike

  • Administrator

Reputacja: 1849
Godlike

  • Postów:3066
  • Steam:steam
  • Lokalizacja:Przemyśl
Offline

Napisano 30.08.2014 18:57

A ktoś może mi wytłumaczyć, dlaczego CPU mam 0.00 cały czas?

Bo HLDS nie jest w stanie tego poprawnie śledzić :)
 
 

A co jeżeli po wyłączeniu AMXXa dalej są skoki pingu, ale zużycie cpu jest cały czas na niskim poziomie?

Prawdopodobnie wina hostingu, brakuje zasobów dla maszyny na której stoi VPS. Ewentualnie przekraczasz gwarantowaną ilość zasobów na swoim VPSie, a niegwarantowane zasoby są przyznawane raz Tobie, raz komuś innemu. Jeśli nie masz podziału na gwarantowane zasoby i zasoby dostępne na chwilę, ewentualnie masz pewność, że nie przekraczasz tych gwarantowanych, wina hostingu.


W ogóle też się dziwne rzeczy dzieją, bo mam zużycie procesora przez proces 58%, a ogólne zużycie poszczególnych rdzeni nie przekracza 15%...

Przy wielu rdzeniach/procesorach może być to różnie liczone.

Ping na serwerze niekoniecznie musi być powiązany z tymi skokami VPS, sprawdź dobrze jakość łącza do operatora (pingi, nie download/upload) i upewnij się, że nikt Ci VPSa nie atakuje (sprawdź zużycie łącza różnymi monitorami sieci, podobnymi do htopa)
  • +
  • -
  • 0
NIE pomagam na PW. Nie trudź się, na zlecenia nie odpiszę... Od pomagania jest forum.
NIE zaglądam w tematy wysłane na PW. Jeśli są na forum to prędzej czy później je przeczytam. Jeśli mam co w nich odpisać, to odpiszę.
 
1988650.png?theme=dark

#11 SeeK

    Wszechobecny

  • Autor tematu
  • Użytkownik

Reputacja: 190
Profesjonalista

  • Postów:437
Offline

Napisano 30.08.2014 19:07

VPS który posiadam to VPS KVM, czyli taki, który powinien mieć w sporej części zasoby przeznaczone tylko dla siebie. Poprosiłem hosting o przydzielenie dodatkowego rdzenia, ale nic to nie pomogło.

Sieć sprawdzałem za pomocą narzędzia vnstat i nic podejrzanego w wynikach nie znalazłem.

Serwer uruchomiłem na najczystszym CSie, zassanym prosto z steacmd, bez żadnych dodatków. Niezależnie czy grało 2 ludzi, czy 10, ping tak samo skakał. Wszystko jest okej i co 10-20 sekund skacze z 30 do 150 i znowu jest okej.

 

No zostaje mi tylko pogadać z supportem hostingu i zobaczymy czy to coś przyniesie dobrego :)


  • +
  • -
  • 0

http://sklep-sms.pl - sklep do gry Counter-Strike w którym dokonuje się zakupów bez wychodzenia z serwera!

 

Planeta-Skilla.pl - Zapraszam!  :)


#12 Lokator

    Życzliwy

  • Użytkownik

Reputacja: 21
Życzliwy

  • Postów:36
  • Lokalizacja:Zabrze
Offline

Napisano 30.08.2014 19:31

Chłopaki? Po co tyle kombinacji? ; )

 

Twój VPS zapewne stoi na serwerze dedykowanym z procesorem AMD czego HLDS bardzo nie lubi.

Stąd brak zachowania stabilnych fpsów, mimo że obciążenia na rdzeniu praktycznie nie ma.

 

Pingi szaleją na serwerze ze względu na brak stabilnych fpsów, a więc to również zasługa AMD.


  • +
  • -
  • 0

Czysta paczka (AMXModX + Metamod-P + Dproto + VoiceTransCoder) - nieaktualna!

 

Posiadam konta wyłącznie na WebHostingTalk.pl, GameHostingTalk.pl oraz Amxx.pl!

 

Na forum Amxx.pl już nie działamNie handluje niczym poza forum WHT oraz GHT!


#13 Puchate

    Wszechobecny

  • Użytkownik

Reputacja: 198
Profesjonalista

  • Postów:432
  • Lokalizacja:Polska
Offline

Napisano 31.08.2014 02:20

Mam postawiony serwer FFA ( 31 slotów ) na VPSie KVM CPU: 2GHz, RAM: 1GB jednakże na serwerze daje się odczuć lagi, ping jest prawie 2-krotnie większy niż na innych serwerach. Czy parametry tego VPSa są za małe, czy wystarczy ustawić prawidłowo kilka cvarów?

 

Po wpisaniu kilka razy w konsoli "stats", takie oto są wyniki:

Spoiler

 

Pamiętaj że uruchamianie serwera HLDS na serwerze VPS jest ryzykowne gdyż właściwie każdy hosting stosuje zasade oversellingu. Normalną rzeczą może być więc spory spadek mocy Twojego serwera VPS (co za tym idzie - lagi) w danym okresie czasu, gdy inni właściciele serwerów VPS na tym samym "serwerze-matce" zaczną aktywnie zużywać przydzielone im zasoby.

 

Co z tym ticrate? Ustaw je na względnie niskie, duże skoki FPS nie służą jakości gry, działają głównie na zły recoil. 300 FPS na serwer publiczny jest optymalną wartością, wiec sys_ticrate 350 jest pragmatycznym ustawieniem.

 

Jakie to engine? Jakie masz rate serwera ustawione?

 

Twoje rdzenie są wirtualnymi procesorami emulowanymi przez wirtualizacje KVM, co nie jest tak dobre jak bezpośredni dostęp do CPU. Zobacz, że HLDS nawet nie może pobrać ile zużywa rdzenia gdyż pewne systemowe funkcje nie działają na vCPU.

 

W topie masz dwa procesory, więc to raczej dwa rdzenie 2x1GHz. HLDS jest aplikacją jednowątkową więc teraz uruchamiasz go na 1GHz vCPU. Słabo.

 

PS. Czemu nie chcesz serwera na hostingu ?

 

 

 

 

 

 

 

 

 

 

 

 


Użytkownik Puchate edytował ten post 31.08.2014 02:22

  • +
  • -
  • 0

#14 SeeK

    Wszechobecny

  • Autor tematu
  • Użytkownik

Reputacja: 190
Profesjonalista

  • Postów:437
Offline

Napisano 31.08.2014 02:30

Puchate, po użyciu komendy "cat /proc/cpuinfo" dostaję info, że taktowanie rdzenia wynosi 3.7GHz, natomiast w spesycikacji usługi, którą zakupiłem posiada 2GHz oO Drugi rdzeń został mi przydzielony chwilowo, abym mógł sprawdzić, czy to coś pomoże.

 

Hostingu nie chcę, ponieważ nie-hosting wychodzi taniej i co więcej, mam lepszą kontrolę nad samym serwerem. A najważniejsze, że kiedyś się zdecydowałem na nie-hosting i teraz zmiana oznaczała by również zmianę adresu IP :)


  • +
  • -
  • 0

http://sklep-sms.pl - sklep do gry Counter-Strike w którym dokonuje się zakupów bez wychodzenia z serwera!

 

Planeta-Skilla.pl - Zapraszam!  :)


#15 Puchate

    Wszechobecny

  • Użytkownik

Reputacja: 198
Profesjonalista

  • Postów:432
  • Lokalizacja:Polska
Offline

Napisano 31.08.2014 06:58

Czyli pokazuje tam info o całym rdzeniu, nie o przydzielonym. Przejdź na wyższy pakiet i jeden rdzeń koniecznie.


  • +
  • -
  • 0

#16 SeeK

    Wszechobecny

  • Autor tematu
  • Użytkownik

Reputacja: 190
Profesjonalista

  • Postów:437
Offline

Napisano 31.08.2014 14:18

Na razie przeniosę się na maszynę z prockiem intela, tak jak lokator mi radzi. Pamiętam, że kiedyś próbowałem postawić serwer na swoim starym komputerze z prockiem amd i też były problemy z funkcjonowanie serwera. Więc wydaje mi się ta teoria ( o gryzieniu sie hlds z procesorami amd ) całkiem prawdopodobna.


  • +
  • -
  • 0

http://sklep-sms.pl - sklep do gry Counter-Strike w którym dokonuje się zakupów bez wychodzenia z serwera!

 

Planeta-Skilla.pl - Zapraszam!  :)


#17 Puchate

    Wszechobecny

  • Użytkownik

Reputacja: 198
Profesjonalista

  • Postów:432
  • Lokalizacja:Polska
Offline

Napisano 31.08.2014 14:29

Nie chodzi tu o producenta procesora, tylko o to jak jest rozdzielana moc. Intel ma inne wartości mocy (taktowania), więc przydział będzie tam inny, więc inaczej też będzie działać serwer.


  • +
  • -
  • 0

#18 Lokator

    Życzliwy

  • Użytkownik

Reputacja: 21
Życzliwy

  • Postów:36
  • Lokalizacja:Zabrze
Offline

Napisano 31.08.2014 16:09

Nie chodzi tu o producenta procesora, tylko o to jak jest rozdzielana moc. Intel ma inne wartości mocy (taktowania), więc przydział będzie tam inny, więc inaczej też będzie działać serwer.

 

Bezsensowna wypowiedź. W tym przypadku właśnie chodzi o producenta. Intel i AMD to dwaj różni producenci procesorów.

Procesory tych dwóch producentów różnią się technologicznie - w odmienny sposób przetwarzają i operują danymi.

Obaj producenci kładą największy nacisk na zupełnie inne aspekty swoich procesorów.

 

Jak nie masz pojęcia, to się nie wypowiadaj.


Użytkownik Lokator edytował ten post 31.08.2014 16:10

  • +
  • -
  • -7

Czysta paczka (AMXModX + Metamod-P + Dproto + VoiceTransCoder) - nieaktualna!

 

Posiadam konta wyłącznie na WebHostingTalk.pl, GameHostingTalk.pl oraz Amxx.pl!

 

Na forum Amxx.pl już nie działamNie handluje niczym poza forum WHT oraz GHT!


#19 Puchate

    Wszechobecny

  • Użytkownik

Reputacja: 198
Profesjonalista

  • Postów:432
  • Lokalizacja:Polska
Offline

Napisano 31.08.2014 19:44

*
Popularny


Jak nie masz pojęcia, to się nie wypowiadaj.
 

Jeżeli chcesz wkroczyć w wojnę na argumenty, to w porządku, jestem za :) Tylko jeżeli o czymś piszesz to pisz o tym w żargonie technicznym, bo na razie swoimi postami prezentujesz postawę typowego leminga.

 

 

Procesory tych dwóch producentów różnią się technologicznie - w odmienny sposób przetwarzają i operują danymi.

 

Tak ? A byłem przekonany ze obecne Intele i AMD są w architekturze i386 (x64)  ^D^ więc podstawowe rejestry są takie same, różnić się mogą rozkazy procesora ze specjalnych zestawów instrukcji typu SSE, ale tutaj one nie są potrzebne. HLDS nie potrafi korzystać z żadnych dodatkowych instrukcji obecnych w dzisiejszych procesorach, dlatego tak słabo działa mimo ogromnego przeskoku wydajnościowego CPU w czasie 15 lecia istnienia tej gry. Jedyne zmiany jakie weszły do engine przez ten czas to nowszy kompilator oraz biblioteki systemowe użyte do kompilacji kodu. Poza tym wciąż cały serwer opiera się o pętle while(1) oraz usleep, więc stabilności tutaj szukać też nie można  ;)

 

 

Obaj producenci kładą największy nacisk na zupełnie inne aspekty swoich procesorów.

 

Tak? A byłem przekonany że produkując CPU głównym aspektem jest jak najwyższe FLOPS

 

 

 Intel i AMD to dwaj różni producenci procesorów.

Niewiarygodne  :facepalm2:  poznałeś to po nazwie czy po czym innym? ;)


Użytkownik Puchate edytował ten post 31.08.2014 19:56

  • +
  • -
  • 8

#20 Lokator

    Życzliwy

  • Użytkownik

Reputacja: 21
Życzliwy

  • Postów:36
  • Lokalizacja:Zabrze
Offline

Napisano 31.08.2014 23:01

W żargonie technicznym nie piszę bo najzwyczajniej w świecie go nie znam. Teraz się z Tobą zgadzam. Bardzo ładnie to ująłeś.

Gdyby to samo zostało napisane przez Ciebie w Twoim pierwszym poście, wtedy zdanie "Nie chodzi tu o producenta procesora" byłoby jak najbardziej ok.


  • +
  • -
  • 0

Czysta paczka (AMXModX + Metamod-P + Dproto + VoiceTransCoder) - nieaktualna!

 

Posiadam konta wyłącznie na WebHostingTalk.pl, GameHostingTalk.pl oraz Amxx.pl!

 

Na forum Amxx.pl już nie działamNie handluje niczym poza forum WHT oraz GHT!





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych