Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Amxbans crashuje serwer?


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 20.08.2009 15:55

W zasadzie problem dość dziwny, raz na kilka dni pojawiają się error logi odnośnie amxbans, następnie pad serwera i koniec zabawy. Moduł mysql wgrywałem od wersji 1.76d oraz 1.8.1, ale to nic nie zmienia. Amxbans w wersji 5.0 (podstawowy), 5.1 (defender), 5.2 (niemiecka), w każdej występuje ten sam błąd:
L 08/20/2009 - 16:45:11: [MySQL] Invalid handle: 0
L 08/20/2009 - 16:45:11: [AMXX] Displaying debug trace (plugin "amxbans.amxx")
L 08/20/2009 - 16:45:11: [AMXX] Run time error 10: native error (native "SQL_FreeHandle")
L 08/20/2009 - 16:45:11: [AMXX]    [0] amxbans.sma::plugin_end (line 618)

Z MySQL na serwerze korzysta również plugin War3FT, jego logi są czyste jak łza, więc coś tutaj jest sprzeczne.

Wyłączenie amxbans - odpada
Reinstal - ostateczność
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#2 FlameS

    Zaawansowany

  • Użytkownik

Reputacja: 7
Nowy

  • Postów:97
  • GG:
  • Lokalizacja:Częstochowa
Offline

Napisano 20.08.2009 15:58

nie wiem.. ja używam bazy danych z eskill.pl amxbans by defender wgrywam all i śmiga aż miło spróbuj jednak ten reinstal.. zrobić i wgraj inna wersję defendera chcesz to Ci na PW wyślę na tym na czym ja śmigam i zobaczysz czy będzie ok ;P
  • +
  • -
  • 0

#3 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 20.08.2009 16:01

Raczej amxbans nie powinno crash'ować, zwłaszcza z takim błędem.
Żeby się go pozbyć zmień jedną funkcję w amxbans.sma i skompiluj ponownie:
public plugin_end()
{
	if (g_SqlX)
		SQL_FreeHandle(g_SqlX)
}

  • +
  • -
  • 0

#4 Portek

    Kończymy zabawę, permanentna emerytura!

  • Autor tematu
  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 20.08.2009 16:11

Raczej amxbans nie powinno crash'ować, zwłaszcza z takim błędem.

To jedyny log jaki występuje, zastanawia mnie tylko częstotliwość jego pojawiania się, jednego dnia logi są czyste, drugiego serwer się crashuje i logi zawalone przez amxbans.
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#5 FlameS

    Zaawansowany

  • Użytkownik

Reputacja: 7
Nowy

  • Postów:97
  • GG:
  • Lokalizacja:Częstochowa
Offline

Napisano 20.08.2009 16:44

To zrób reinstal a ja Ci dam mojego amxbansa który u mnie śmiga i będzie ok ;)
  • +
  • -
  • 0

#6 Portek

    Kończymy zabawę, permanentna emerytura!

  • Autor tematu
  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 21.08.2009 08:46

To zrób reinstal

Reinstal - ostateczność


a ja Ci dam mojego amxbansa który u mnie śmiga i będzie ok

A na jakiego grzyba mi twój amxbans? Po dodaniu if'a który podesłał Pavulon zniknęły error logi i serwer działa stabilnie.
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#7 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 21.08.2009 10:32

zniknęły error logi i serwer działa stabilnie.

Trzeba mieć nadzieje że niedługo pojawi się v6.0 i nie będzie żadnych problemów :)

Status from 6.0 Beta:

Web: 100% (Beta-Testing)
Plugin: 30%


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych