Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
Klasa

[ROZWIĄZANE] wykasowanie pistoletu w pierwszej rundzieKlasa posiada pistolet, a nie powinna go mieć...

klasa

Najlepsza odpowiedź BlackPerfum, 20.07.2014 17:37

P350 przypatrz się:

public Spawn(id)
{
	if(ma_klase[id])
	{
		strip_user_weapons(id)	//to dodales
		
		noze[id] = 20
		new param[1]
		param[0] = id
		if(!task_exists(id + POKAZ_STATUS))
			set_task(0.1, "pokaz_informacje", id+POKAZ_STATUS, _, _, "b");
		if(!task_exists(4247545 + id))
			set_task(0.2, "make_footsteps", 4247545+id, param, 1, "b")
		strip_user_weapons(id) //A to bylo xD
		give_item(id, "weapon_knife");
		g_isDying[id] = true
		set_user_footsteps(id, 1);
		set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 0);
	}
}
GJ haha.gif

Do funkcji cod_class_enabled dodaj funkcje strip_user_weapons + give_item i będzie śmigać
Spoiler
Przejdź do postu


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 freetu

    Wszechwiedzący

  • Power User

Reputacja: 71
Pomocny

  • Postów:504
  • Lokalizacja:Kwidzyn
Offline

Napisano 20.07.2014 16:18

Witam,

Mam problem z klasą. Otóż po wejściu na serwer jest tak, że nie mamy wybranej żadnej klasy i wtedy nam automatycznie przydziela glock (w TT) lub USP (w CT). Ta klasa nie powinna mieć żadnej broni, a w pierwszej rundzie po wejściu na serwer ma właśnie ten pistolet. Proszę zmodyfikowanie klasy by ten pistolet był wyrzucany, bo sam nie mogę sobie z tym poradzić skutecznie. A nie którzy to robią co chwile reconecty żeby właśnie sobie grać z przewagą...

Spoiler

 

Załączone pliki


  • +
  • -
  • 0

#2 Oporowiec.

    Zaawansowany

  • Zbanowany

Reputacja: 10
Początkujący

  • Postów:146
  • Imię:Wojtek
  • Lokalizacja:Zadupie
Offline

Napisano 20.07.2014 16:46

całą funkcje: Public_Spawn(id) podmień na tą:

public Spawn(id)
{
	if(ma_klase[id])
	{
		strip_user_weapons(id)	
		
		noze[id] = 20
		new param[1]
		param[0] = id
		if(!task_exists(id + POKAZ_STATUS))
			set_task(0.1, "pokaz_informacje", id+POKAZ_STATUS, _, _, "b");
		if(!task_exists(4247545 + id))
			set_task(0.2, "make_footsteps", 4247545+id, param, 1, "b")
		strip_user_weapons(id)
		give_item(id, "weapon_knife");
		g_isDying[id] = true
		set_user_footsteps(id, 1);
		set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 0);
	}
}

nie obiecuję, że będzie działać.


Reset statystyk: http://amxx.pl/topic...statystyk-2014/

 

5392 oraz 6262 Moim autorytetem  :) 


#3 BlackPerfum

    Pseudo interakcja??

  • Power User

Reputacja: 453
Wszechobecny

  • Postów:575
  • Lokalizacja:...
Offline

Napisano 20.07.2014 17:37   Najlepsza odpowiedź

P350 przypatrz się:
public Spawn(id)
{
	if(ma_klase[id])
	{
		strip_user_weapons(id)	//to dodales
		
		noze[id] = 20
		new param[1]
		param[0] = id
		if(!task_exists(id + POKAZ_STATUS))
			set_task(0.1, "pokaz_informacje", id+POKAZ_STATUS, _, _, "b");
		if(!task_exists(4247545 + id))
			set_task(0.2, "make_footsteps", 4247545+id, param, 1, "b")
		strip_user_weapons(id) //A to bylo xD
		give_item(id, "weapon_knife");
		g_isDying[id] = true
		set_user_footsteps(id, 1);
		set_user_rendering(id, kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 0);
	}
}
GJ haha.gif

Do funkcji cod_class_enabled dodaj funkcje strip_user_weapons + give_item i będzie śmigać
Spoiler

  • +
  • -
  • 3
Chcesz napisać do mnie na PW to:
Spoiler

Mój tok myślenia jest błędny? Wskaż mi błąd zmienie to!

Aktualnie bije limit 32 graczy (łącze serwery) ale nadal są lagi przy zbyt dużym przesyłu informacji Dołączona grafika
Gra się płynnie do 40~50 graczy potem łącze pada i zamiast biegać ludzie się teleportują Dołączona grafika

#4 freetu

    Wszechwiedzący

  • Autor tematu
  • Power User

Reputacja: 71
Pomocny

  • Postów:504
  • Lokalizacja:Kwidzyn
Offline

Napisano 20.07.2014 17:46

Dzięki blackperfum za pomoc i wskazanie poprawnego rozwiązania ;) Przy okazji sobie poczytałem zalinkowane funkcje ;)

P350 dzięki za próbę pomocy.


  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: klasa

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych