Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[ROZWIĄZANE] Problem z soundami i zmianą mapy


Najlepsza odpowiedź Zabijaka Gryps, 22.06.2014 16:25

3. To nie jest problem.
1. Spróbuj wyłączyć ostatnio wgrywane pluginy, zmienić raz mapę przez konsolę, dopiero wtedy zmienić przez menu. Napisz jaki efekt, czy wtedy zmienia się normalnie, czy też nie.
2. Najprościej: ściągnij Audacity, otwórz utwór, wybierz Plik -> Eksportuj jako mp3, wgraj pod jakąś zupełnie inną nazwą, edytuj w pluginie nazwę tej piosenki i sprawdź. Powinno iść.
4. Wrzuć w folderze configs/galileo/, czyli tak jak jest w paczce. Przejdź do postu


  • Zamknięty Temat jest zamknięty
9 odpowiedzi w tym temacie

#1 Pan_Autokar

    Życzliwy

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:22
  • Imię:Mateusz
  • Lokalizacja:Poznań
Offline

Napisano 22.06.2014 15:31

Otóż mam kolejne problemy :D Wynagrodzę za pomoc :)

 

1.  Wgrałem sobie soundy przy odliczaniu do wybuchu paki stąd :

 

http://amxx.pl/topic...e-3-sounds-v03/

Problem jest taki, że nie odtwarza mi : bomba1. Jest nutka z tekstem "za chwilę będzie explozja..."

Pozostałe odtwarza. Gdy zrobiłem taki trick, że zmieniłem nazwy pliku z @up niedziałającym i skopiowałem 3x, że było bomba, bomba1, bomba2 z tą samą muzyką i nadal tak samo było, że odtwarzało tylko pozostałe dwa, a tego jednego nie, pomimo tego, że w sound\misc nie ma tych co wtedy.

 

2. Zdarza się, że gdy zmieniam mapkę przez amxmodmenu, czyli głosowanie lub zwykła zmiana to serwer się restartuje i wraca do mapy de_dust2, a gdy zmieniam przez konsolkę jest wszystko spoko. Jak to naprawić ?

 

3. To jest bardziej pytanie. Macie jakiś plugin lub sposób by zrobić, że ok. rundę/2 rundy przed końcem mapy robiło się vote do wybrania mapy następnej ? Tak jak jest na prawie każdym serwerze i z tym rtv :D

 

Hojnie wynagrodzę kilkoma tymi plusikami całymi :D


  • +
  • -
  • 0

#2 Zabijaka Gryps

    Wszechwiedzący

  • Power User

Reputacja: 266
Wszechwidzący

  • Postów:563
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Świdnica
Offline

Napisano 22.06.2014 15:38

1. Możliwe że ten utwór jest źle skonwertowany, że cs nie może go odtworzyć. A zmiana nazw na inne i podmiana za tamte nic nie da, gdyż Ty w swoim cs masz te stare, a cs nie może ich nadpisać.
3. Wgraj plugin galileo.
  • +
  • -
  • 1

#3 Pan_Autokar

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:22
  • Imię:Mateusz
  • Lokalizacja:Poznań
Offline

Napisano 22.06.2014 15:39

Okej, dzięki reputacja wleci. A co do 2 ???


  • +
  • -
  • 0

#4 Zabijaka Gryps

    Wszechwiedzący

  • Power User

Reputacja: 266
Wszechwidzący

  • Postów:563
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Świdnica
Offline

Napisano 22.06.2014 15:43

A co dokładniej się dzieje przy tej zmianie z pkt 2? Po prostu dasz zmianę przez menu na jakąś mapę, to po prostu zmienia się na dd2, czy wchodzi zmiana mapy, serwer się crashuje, że trzeba wyjść z ładowania, znowu wejść i wtedy jest dd2?
  • +
  • -
  • 1

#5 Pan_Autokar

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:22
  • Imię:Mateusz
  • Lokalizacja:Poznań
Offline

Napisano 22.06.2014 15:50

Wchodzi zmiana mapy, na chacie jest ADMIN: Avere change lewel: nazwa mapki

I zatrzymuje się na tabeli, pokazuje cały czas tabele i ta kamera się chwieje i tak do jutra by mogło być. No i trzeba wyjść z serwera i wejść od nowa a jak się już wejdzie od nowa to jest de_dust2 niezależnie od tego co się wybrało. Czyli tak jakby serwer się restartuje.


  • +
  • -
  • 0

#6 Zabijaka Gryps

    Wszechwiedzący

  • Power User

Reputacja: 266
Wszechwidzący

  • Postów:563
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Świdnica
Offline

Napisano 22.06.2014 15:58

Czyli crash. Wejdź w konsolę serwerową (na hostingu gdzie jest serwer w panelu zarządzania powinno być "konsola serwerowa" lub coś takiego), na serwerze zmień mapę przez menu i jeśli zdarzy się crash, to skopiuj wszystko co pisze w konsoli i podaj.
  • +
  • -
  • 1

#7 Pan_Autokar

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:22
  • Imię:Mateusz
  • Lokalizacja:Poznań
Offline

Napisano 22.06.2014 16:04

1. Znów to samo :/ Logi z kosoli:

 

L 06/22/2014 - 16:50:55: [mapsmenu.amxx] Cmd: "Avere<2><STEAM_0:0:388573101><>" changelevel "cs_italy"

L 06/22/2014 - 16:50:57: -------- Mapchange to cs_italy --------
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20140622165057_1.dmp
success = no
error:  Couldn't connect to server
Segmentation fault
email debug.log to linux@valvesoftware.com
nie, 22 cze 2014, 16:51:18 CEST: Server restart in 10 seconds
 
Console initialized.
Using breakpad crash handler
Setting breakpad minidump AppID = 10
Forcing breakpad minidump interfaces to load
dlopen failed trying to load:
/home/nozofiles/s50/.steam/sdk32/steamclient.so
with error:
/home/nozofiles/s50/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Protocol version 48
Exe version 1.1.2.7/Stdio (cstrike)
Exe build: 17:45:07 Apr 25 2013 (6027)
STEAM Auth Server
 
"sv_password" is ""
Server IP address 185.25.150.240:27018
   
   Metamod version 1.20  Copyright © 2001-2013 Will Day <willday@metamod.org>
   Metamod comes with ABSOLUTELY NO WARRANTY; for details type `meta gpl'.
   This is free software, and you are welcome to redistribute it
   under certain conditions; type `meta gpl' for details.
   
 
   AMX Mod X version 1.8.2 Copyright © 2004-2006 AMX Mod X Development Team 
   AMX Mod X comes with ABSOLUTELY NO WARRANTY; for details type `amxx gpl'.
   This is free software and you are welcome to redistribute it under 
   certain conditions; type 'amxx gpl' for details.
  
Version 0.9.356 Linux
[DPROTO]: Loading config './dproto.cfg'
[DPROTO]:  LoggingMode = 2
[DPROTO]: Config sucessfully loaded.
[DPROTO]: Done.
L 06/22/2014 - 16:51:28: -------- Mapchange to de_dust2 --------
stray key in process_key: item_getiteminfo 61
[AMXX] Loaded 2 admins from file
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
/home/nozofiles/s50/.steam/sdk32/steamclient.so
with error:
/home/nozofiles/s50/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
 
Executing AMX Mod X Configuration File 
Scrolling message displaying frequency: 10:00 minutes
couldn't exec listip.cfg
Menu item 17 added to Menus Front-End: "Plugin Cvars" from plugin "pluginmenu.amxx"
Menu item 18 added to Menus Front-End: "Plugin Commands" from plugin "pluginmenu.amxx"
Connection to Steam servers successful.
   VAC secure mode is activated.
 

2.Pobrałem konwertor i ponownie przekonwertowałem na mp3 i nadal to samo :/ Może to chodzi w jakieś wielkości Hz czy coś takiego przy konwersacji było ?

 

3. Jest w consoli coś takiego co mnie niepokoi :/ Co to może być i jak to naprawić ?

L 06/22/2014 - 16:46:18: -------- Mapchange to de_dust2 --------

stray key in process_key: item_getiteminfo 61
[AMXX] Loaded 2 admins from file
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
/home/nozofiles/s50/.steam/sdk32/steamclient.so
with error:
/home/nozofiles/s50/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit

 


Użytkownik Pan_Autokar edytował ten post 22.06.2014 16:27

  • +
  • -
  • 0

#8 Zabijaka Gryps

    Wszechwiedzący

  • Power User

Reputacja: 266
Wszechwidzący

  • Postów:563
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Świdnica
Offline

Napisano 22.06.2014 16:25   Najlepsza odpowiedź

3. To nie jest problem.
1. Spróbuj wyłączyć ostatnio wgrywane pluginy, zmienić raz mapę przez konsolę, dopiero wtedy zmienić przez menu. Napisz jaki efekt, czy wtedy zmienia się normalnie, czy też nie.
2. Najprościej: ściągnij Audacity, otwórz utwór, wybierz Plik -> Eksportuj jako mp3, wgraj pod jakąś zupełnie inną nazwą, edytuj w pluginie nazwę tej piosenki i sprawdź. Powinno iść.
4. Wrzuć w folderze configs/galileo/, czyli tak jak jest w paczce.
  • +
  • -
  • 1

#9 wezmnienozem

    Zaawansowany

  • Girl

Reputacja: 37
Życzliwy

  • Postów:148
  • Imię:Anka
  • Lokalizacja:Łódź
Offline

Napisano 22.06.2014 16:28

2. Pamiętaj, że musi być stereo w przypadku mp3 a te parametry nie są objęte jakoś. 

Polecam Format Factory  do konwersji. 


  • +
  • -
  • 0

Pomogę z grafiką, CS i przy tworzeniu stron internetowych xD


#10 Pan_Autokar

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:22
  • Imię:Mateusz
  • Lokalizacja:Poznań
Offline

Napisano 22.06.2014 16:30

1. Teraz po dodaniu galileo normalnie zmieniło mapkę, zobaczę co będzie gdy innym razem będzie potrzeba.

2. Zrobię to i dam znać.

3. Dzięki :)

4. Już po problemie ale byłeś szybszy :D

 

5. Jak przerobić aby odtwarzało w .wav :) ?


Użytkownik Pan_Autokar edytował ten post 22.06.2014 16:45

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych