Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Nowy

QTM_CodMod, a debug - Dlaczego serwer nie działa?

cod nowy

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 Daniel`owsky

    Zaawansowany

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:84
  • Lokalizacja:Lokalizacja
Offline

Napisano 11.06.2014 06:22

Witajcie. Wyczytałem, że gdy przy nazwie pluginu jest dopisany "debug" to ta opcja obciąża serwer. Gdy usunąłem napis debug sprzed nazwy QTM_CodMod.amxx to nie dało wejść się na serwer (pasek ładowania zacinał się w połowie). Co może być tego przyczyną?


  • +
  • -
  • 0

Zapraszam na jednego z najlepszych CoD Modów w Polsce! Darmowe Premki! IP: 80.72.38.187:27090 

 

b_350_20_692108_381007_FFFFFF_000000.png


#2 ex0

    Wolny strzelec.

  • Power User

Reputacja: 377
Wszechpomocny

  • Postów:1124
  • GG:
  • Imię:Kacper
  • Lokalizacja:Żywiec
Offline

Napisano 11.06.2014 06:37

Wyczytałem, że gdy przy nazwie pluginu jest dopisany "debug" to ta opcja obciąża serwer.

Gdzie to wyczytałeś waściu ?

Ja tam mam standardowo w amxx.cfg debugowanie całości i ? Nie widzę żadnych spadków FPSów przez to ani większego zużycia procesora?
Moim zdaniem brednie, lub na "moich" maszynach nie widać różnicy z i bez debugowania.
 

 

Gdy usunąłem napis debug sprzed nazwy QTM_CodMod.amxx to nie dało wejść się na serwer (pasek ładowania zacinał się w połowie).

 

A widzisz, czyli coś z silnikiem nie jest tak jak być powinno, skoro bez debugowania na serwer wejść nie możesz to coś tutaj jest nie tak. (Ale ja się powtarzam..)

Przyczyn może być mnóstwo, od jakichś pierdołek związanych z funkcjami HAM`a lub podobnymi aż do strasznie zrypanego kodu całego silnika :/
 


  • +
  • -
  • -1

TWORZENIE FOR SPOŁECZNOŚCIOWYCH | ZARZĄDZANIE STRONAMI INTERNETOWYMI
WSPARCIE TECHNICZNE SERWERÓW HLDS | MODERNIZACJA, OPTYMALIZACJA, ZABEZPIECZENIA


Zapraszam do mojego profilu ;)


#3 Daniel`owsky

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:84
  • Lokalizacja:Lokalizacja
Offline

Napisano 11.06.2014 10:35

http://amxx.pl/topic...h-a-obciazenie/ - Tutaj wyczytałem

 

A i żadnych errorów z silnikiem, nigdy nie było.


  • +
  • -
  • 0

Zapraszam na jednego z najlepszych CoD Modów w Polsce! Darmowe Premki! IP: 80.72.38.187:27090 

 

b_350_20_692108_381007_FFFFFF_000000.png


#4 ex0

    Wolny strzelec.

  • Power User

Reputacja: 377
Wszechpomocny

  • Postów:1124
  • GG:
  • Imię:Kacper
  • Lokalizacja:Żywiec
Offline

Napisano 11.06.2014 14:19

Szczerze?
Jak sebul czy tam Dark pisali .

Jedna kwestia, że debug się włącza jednorazowo przy wyskoczeniu jakichś logów.
Druga kwestia, że debug obciąża w zależności od struktury pluginu, u mnie jest to w ogóle nie odczuwalne z tego co patrzyłem więc mam cały czas włączony debug i za czystym przeproszeniem mam to gdzieś bo nie obserwuje, żadnego zużycia procesora wyższego niż 65% przy całym serwerze graczy na moim COD`zie.
Trzecia kwestia, że wszystko zależy od tego gdzie ten serwer stoi, bo takie gadanie "że debug obciąża"

Jak wspomniał Sebul lub Dark w tamtym temacie, sprawdza każde z osobna, lecz czy to aż tak obciąża?
Z ciekawości sam to sprawdziłem i efekt różnicy 2-5% także znikomy moim zdaniem....

 

A i żadnych errorów z silnikiem, nigdy nie było.

A więc wyłącz teraz debugowanie i sprawdź czy serwer ruszy, jeżeli nie podaj proszę .sma i wtedy zobaczymy co mu leży na kodzie.


  • +
  • -
  • 0

TWORZENIE FOR SPOŁECZNOŚCIOWYCH | ZARZĄDZANIE STRONAMI INTERNETOWYMI
WSPARCIE TECHNICZNE SERWERÓW HLDS | MODERNIZACJA, OPTYMALIZACJA, ZABEZPIECZENIA


Zapraszam do mojego profilu ;)


#5 Daniel`owsky

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:84
  • Lokalizacja:Lokalizacja
Offline

Napisano 11.06.2014 20:04

Jak wyłączę debug to serwer zacina się w połowie ładowania paska.


  • +
  • -
  • 0

Zapraszam na jednego z najlepszych CoD Modów w Polsce! Darmowe Premki! IP: 80.72.38.187:27090 

 

b_350_20_692108_381007_FFFFFF_000000.png






Również z jednym lub większą ilością słów kluczowych: cod nowy

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych