Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Auto-Restart by Peref - nie odtwarza mp3


  • Zamknięty Temat jest zamknięty
Brak odpowiedzi do tego tematu

#1 assbluster

    Początkujący

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:11
  • Lokalizacja:MC
Offline

Napisano 12.08.2009 13:18

No więc tak, plugin działa - wszystko pięknie pokazuje, odtwarza dźwięki one, two, three, restart tylko nie chce mi odtworzyć muzyczki mp3. Wydaje mi sie że mam dobrze zmienione:
client_cmd(0,"mp3 play misc/pirate.mp3")
i
precache_sound( "misc/pirate.mp3")
Plik mam oczywiście w misc...
Z początku myślałem że to wina parametrów mp3 ale podstawiłem taką która na bank jest ok bo roundsound bezproblemowo ją odtwarza, no a ten plugin nie chce. Logi mam czyste, nawet zadne info o tym plugu sie nie pokazuje. Nie wiem ocb, dodam jeszcze że muzyczke w wav normalnie odtwarza... Co jest nie tak?

[ Dodano: 12-08-2009, 14:26 ]
Ehh.. zapomniałem że to ma być tak:
client_cmd(0,"mp3 play sound/misc/pirate.mp3")
bo czytałem, że funkcja play ma jakiś problem ze ścieżką no i jakoś działa. Jedyną wadą jest to żeod razu po włączeniu serwera i wejściu na niego pierwszy raz, runda nożowa leci ale dźwięk już nie. dźwięk leci od 45 sekundy a na serwer wchodze jak zostaje 35. Czyli wygląda na to że by odtworzyć plik mp3 to gracz musi być już na serwie w momencie odtwarzania, bo inaczej nic nie usłyszy, tak?

[ Dodano: 12-08-2009, 16:14 ]
Hmm.. jednak nie działa mp3... Nic nie robiłem z plikiem, pluginu też nie edytowałem po prostu "popsuł" się, robiłem ze 20 restartów, dawałem nowe mapy i nic nie odtwarza. No nic, trzeba będzie zadowolic sie wav'em choc jest 2x większy od mp3
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych