Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem vip Run time error 10: native error


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
Brak odpowiedzi do tego tematu

#1 proner112

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:8
  • Lokalizacja:CK
Offline

Napisano 22.04.2014 20:00

Witam, wygenerowałem sobie dziś vipa lecz zauważyłem, że pokazuje mi się errorlog
 

L 04/22/2014 - 20:52:54: [CSTRIKE] Non-player entity 8 out of range
L 04/22/2014 - 20:52:54: [AMXX] Displaying debug trace (plugin "vip.amxx")
L 04/22/2014 - 20:52:54: [AMXX] Run time error 10: native error (native "cs_set_armoury_type")
L 04/22/2014 - 20:52:54: [AMXX]    [0] codclass_vip_2240402.sma::Round_Start (line 47)

Vip działa jak należy jednak chciałbym pozbyć się tego błędu.
Tutaj kawałek kodu który zawiera cs_set_armoury_type

public Round_Start()
{
    round++;
    for (new id=1; id < 33; id++)
    {
        if(is_user_alive(id) && get_user_flags(id) & flaga){
            give_item(id, "weapon_hegrenade")
            give_item(id, "weapon_hegrenade")
            give_item(id, "weapon_smokegrenade")
            give_item(id, "weapon_flashbang")
            give_item(id, "weapon_flashbang")
            give_item(id, "item_thighpack")
            
            cs_set_armoury_type(id,CSW_VESTHELM)
        }
    }
}

Co mam dopisać lub zmienić w tym kodzie by usunąć błąd? Z góry dziękuje za odpowiedzi :)


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych